×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

MOH

Unanswered Question
Aug 14th, 2002
User Badges:

I configured the MOH server on the same CCM. All the MOH .wav files got translated OK, but I could not hear any music when the phone was on hold.

I only hear the default beep tone. I watch the console system monitor, the MOH server counters don't change. Is there any thing special that I need to configure? This is just the conversation between IP phones.

I set up MGCP between CCM and gateway VG200, the MOH does not work either. Thank you much in advance for any input.

Hung

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mjordy Thu, 08/15/2002 - 07:03
User Badges:
  • Cisco Employee,

Hung,


A couple of things to try:


1. Make sure you've set the "Run Flag" on the MOH server configuration page to YES (Goto Service --> Media Resource --> Music On Hold Server. Then select the MOH server from the list and verify that the "Run Flag" field is set to yes).


2. Make sure you've enable the proper codec(s) for your MOH streams. If your phone(s)/gateway(s) are using G.729 and you only have the G.711 MOH stream connected, you won't be able to receive the MOH stream at these devices. (Under Service --> Service Parameters, select the server(s), click on the "Cisco IP Voice Media Streaming App" service. Then under "System Wide Parameter" section, select the desired codec(s) you want to enable in the "Supported MOH Codecs" field. To select more than one, hold down the Ctrl-key and click on the desired codecs. Then click UPDATE).


The above is assuming you are doing unicast MOH. If you are attempting to do multicast MOH, make sure unicast MOH works before enabling multicast MOH. If configuring multicast MOH ensure that your gateway(s) support it, that your network is properly configured for multicast, and that you enable the proper settings on CallManager.


Thanks,

Jordy

qbui Thu, 08/15/2002 - 09:56
User Badges:

Jordy,


Thanks for your response.

The obove 2 things were configured correctly. MOH is unicast between the IP phones on the same subnets. I set up the region LAB under the system configuration and chose G.711 as the codec. The IP phones are put in this region. The codec type for MOH server is also G.711. Run flag is "Yes". Still no luck.

I setup pim spare-mode just between couple router hops from CCM to the VG200 gateway. I saw the muticast flew the gateway but the PSTN phone won't hear the music either. It only hears the default beep tone just like the IP phones. The music-on-hold is configure on VG200 as well. Not sure what was wrong. Thanks again for any further input.


Thanks,

Hung


Actions

This Discussion