cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
340
Views
0
Helpful
5
Replies

prec-bit setting with policy-map

rabeder
Level 1
Level 1

hi,

my question:

i want to set the ip-prec bit with a route-map.

but it does not work - does anyone know why ???

!

route-map set_ip_prec permit 10

match ip address voip

set ip precedence critical

!

route-map set_ip_prec permit 20

match ip address premium

set ip precedence flash-override

!

route-map set_ip_prec permit 30

match ip address gold

set ip precedence flash

!

route-map set_ip_prec permit 40

match ip address silver

set ip precedence immediate

!

route-map set_ip_prec permit 50

set ip precedence priority

!

interface FastEthernet0/0

ip address 10.22.211.250 255.255.255.0

ip policy route-map set-ip-prec

load-interval 30

speed auto

!

5 Replies 5

murabi
Level 4
Level 4

Look at the usage guidelines excerpt on CCO below

"Usage Guidelines

Packets that are generated by the router are not normally policy routed. However, you can use this command to policy route such packets. You might enable local policy routing if you want packets originated at the router to take a route other than the obvious shortest path.

The ip local policy route-map command identifies a route map to use for local policy routing. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteriathe conditions under which packets should be policy routed. The set commands specify the set actionsthe particular policy routing actions to perform if the criteria enforced by the match commands are met. The no ip local policy route-map command deletes the reference to the route map and disables local policy routing."

If you are expecting the packets from the router to be policy routed, then you must issue the

"ip local policy" command.

Check this URL for more details and example

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/ind_r/1rfindp1.htm#1017874

thisisshanky
Level 11
Level 11

If this router is generating VOIP traffic, and you want to set precedence to critical, then, you should use the global command for policy routing ....viz....ip local policy route-map set-ip-prec. Because, the normal ip policy route-map command doesnt policy route, packets generated by the router itself.

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus

bbranch
Level 3
Level 3

What traffic are you trying to match ?, you have defined match clauses (VOIP, Permium, Gold, Silver) but do not appear to have defined what these reference (i.e. where are the named ACL's these reference).

Also what direction is the traffic flowing, policy routing is applied on input to an interface so if your traffic is flowing out of FE0/0 then the policy map will not be applied.

lwantland
Level 1
Level 1

You need to configure an access list for each match statement. For example:

route-map set_ip_prec permit 10

match ip address voip

set ip precedence critical

!

ip access-list extended voip

permit ip host 10.0.0.0 any

You use your named IP access lists to define what IP's get each precedence level.

rabeder
Level 1
Level 1

hi all,

i have found the mistake:

"ip policy route-map set-ip-prec "

AND

"route-map set_ip_prec" _ versus - !!!

;-)