ISDN - PRI NI2

Unanswered Question
Sep 20th, 2002

I have a Cisco Call Manager V3.2, Cisco 3640 Router, and a Definity G3. The definity has a TN464F. We are trying to set it up so that we use ISDN PRI NI2. They still will not communicate with each other. The Cisco is setup for the

isdn switch-type primary-ni

Controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

voice port 1/0:23

mgcp

mgcp call-agent 172.16.20.11 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

!

mgcp profile default

dial-peer voice 9991023 pots

destination-pattern .

no digit-strip

port 1/0:23

The definity is setup for

ds1 circuit pack....

isdn-pri signaling

protocol version b

connect: network

interface companding mulaw

trunk group.....

group type isdn

service type tie

supplemenary service protocol a

The call manager is setup with a gateway and the endpoint is setup mostly with defaults.

Is there something we are missing? When calling from ip phone we get a fast busy. When calling from a non ip we get a fast busy. If we use the Trunk access code we get a slow busy.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
mcnerney@uwyo.edu Wed, 09/25/2002 - 07:39

You will need to define the IP extensions on the G3 to allow inbound calls from the PBX. I have a Nortel SL-100 and defined the IP extensions to point toward the trunk group connecting the gateway with the PBX. Next you will have to define route patterns for outbound dialing on the CM. For example, we use 5 digit dialing on the PBX so I set up a route pattern 6xxxx with a Called Party Transform of 766XXXX and in the same Partition as the sets. The PBX needs a 7-digit number coming inbound on a trunk group. For local calling I set up a route pattern 9.[2-9]xxxxxx with the same Partition as the sets and a discard Digits: PreDot. By stripping the 9 gave me the flexibility of using the same route patterns already defined on the PBX. Good luck.

cairns-a Tue, 10/15/2002 - 08:48

You may want to try setting up the ds1 on G3 to connect: line-side. I have a simular set up and line-side works. Depending on the version of the G3, you may need to set up the links. Also, look to make sure you have a D-channel set up in the G3. How are you routing the call out of the G3? If you need help, email me. I have spend sometime making the G3 and a 3661 work together.

tcairns@estes-express.com

doweiner Tue, 10/15/2002 - 10:22

Both sides of your circuit are acting as user-side. Set the "Connect" field on the DEFINITY DS1 page (change ds1 xxxxx) to "pbx" and you will get a new field to the right called "Interface". Set this field to "Network". This now makes the G3 act as network side. You will need to take all trunks out of the trunk group and delete the signaling group first - the G3 won't let you change the DS1 settings otherwise.

In your trunk group, Page 1 -

set "group type" to "isdn", "COR" to whatever will allow calls to complete, "service type" to "tie", "Codeset to Send Display:" to 0 (zero)

Page 2 - "Send Name:" to "y", "send Calling Number: " to "y", "Send Connected Number:" to "y"

All other fields at default settings should work.

cairns-a Tue, 10/15/2002 - 16:18

Here is good link on setting this up. http://www.cisco.com/univercd/cc/td/doc/product/access/acs_mod/cis3600/sw_conf/pbx_int/36ldt1pr.pdf

I would like to know if the "connection" set to PBX then network, works. The G3 "connect" field on the ds1 is what the G3 is connecting to. If you had a PRI from the PSTN then you would want to set the "connect" field to network. Since you are connecting to a gateway and the G3 will act as the network, I think you would want to set the "connect" field to line-side.

I think the link will help.

Trae

c.shepard Wed, 10/16/2002 - 05:26

I did not try that option. What I had to do to get it to work was reconfigure the cisco router a little. For some reason MGCP is not working. I tried multiple configurations and still got nowhere. I added a new dial peer below and deconfiged mgcp to get it working.

dial-peer voice 1000 voip

destination-pattern 73..

session target ipv4:172.16.20.11

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

ip qos dscp ef media

!

As far as the connect option I am set to network. However, I am not set to PBX.

Any thoughts on why mgcp is not working?

doweiner Thu, 10/17/2002 - 13:39

I'm not sure what you now mean by "not working". Anyway, I'm assuming the T1 is up (show controller t1 1/0) or you wouldn't even be having dial-peer problems ;^).

You don't mention what version of IOS you are running. For mgcp to work for digital facilities (T1/E1) you need to be running 12.2.11T1. If not, go no further until you upgrade the software. If you are, you're missing a couple commands that take the configuration from the CallManager. These are:

ccm-manager config server

ccm-manager config

After this CallManager will create parameters, dial-peers, etc.

c.shepard Thu, 10/17/2002 - 15:03

Thanks I will try upgrading the IOS. I am currently on 12.2.8 T5.

doweiner Thu, 10/17/2002 - 13:29

I've used this quite a bit, even when I was at Lucent. The "Connect" field is what it is connecting to as you say, so when it is set to "Network" the G3 is acting as User side. When you change the connect field to "PBX" the "Interface" field appears (it is hidden until you change the connect field) and now you specify what the G3 will be acting as - network or user. So, the meaning changes.

I can guarantee you that the config I posted works, I've used it many many times.

c.shepard Thu, 10/17/2002 - 15:07

So does this mean I will have a different result then I do now?

Everything is working except name passing which that option is turned on (set to Y on the G3).

And of course mgcp not working but that is probably due to an IOS problem as someone stated above.

Right now since the G3 is set as network (which is considered user to the interface type i am using) and the Call Manager is setup as Network (which of course means network).

doweiner Thu, 10/17/2002 - 20:10

If the PRI is up then your config. should be OK. It is just more usual to have the PBX as network side, but since you're using NI2 the 3600 can be network.

To get calling name going, go into the DEFINITY and on the first page of the trunk-group screen set "Codeset to Send Display:" to 0.

c.shepard Fri, 10/18/2002 - 11:28

I changed the Codeset to 0 and it did nothing. My "service type" is set to tie. "Outgoing display" is y. "Send name" is Y "send calling number" is Y. "Send Codeset 6/7 LAI IE" is n

doweiner Fri, 10/18/2002 - 22:45

we've come a long way :^) Can you send the current router config and the current DEFINITY config (DS1, trunk Group)? I have not had a problem getting the calling name. The only issues, given the settings I've used, have been with calling number and that was because the "change isdn public-unknown-numbering" screen was not filled out. in the DEFINITY. Which way do you not get the name - IP to PBX or PBX to IP? Do you get the info after the call is answered?

c.shepard Mon, 10/21/2002 - 06:31

Here is the router config.

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service internal

!

hostname RCB_MAIN_CISCO

!

logging buffered 4096 debugging

enable secret 5 $1$Wp6c$VLL86VRH3gm9gbm468s68.

enable password t0day

!

clock timezone Central -6

voice-card 1

!

ip subnet-zero

!

!

!

isdn switch-type primary-ni

!

!

!

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller T1 1/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

description Connection to Avaya Definity PBX

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description Data VLAN

encapsulation dot1Q 1 native

ip address 10.1.1.6 255.255.0.0

!

interface FastEthernet0/0.10

description Voice VLAN

encapsulation dot1Q 10

ip address 172.16.20.1 255.255.255.0

ip helper-address 172.16.20.11

ip helper-address 172.16.20.10

!

interface Serial1/0:23

no ip address

no logging event link-status

isdn switch-type primary-ni

isdn incoming-voice voice

no cdp enable

!

interface Serial2/0

description Connection to South

ip address 10.4.1.17 255.255.255.252

serial restart_delay 0

!

interface Serial2/1

description Connection to Pryor

ip address 10.4.1.25 255.255.255.252

serial restart_delay 0

!

interface Serial2/2

no ip address

encapsulation frame-relay IETF

serial restart_delay 0

!

interface Serial2/2.17 point-to-point

description Connection to Broken Arrow

bandwidth 384000

ip address 10.4.1.9 255.255.255.252

frame-relay interface-dlci 17

!

interface Serial2/2.18 point-to-point

description Connection to Union

bandwidth 384000

ip address 10.4.1.13 255.255.255.252

frame-relay interface-dlci 18

!

interface Serial2/2.19 point-to-point

description Connection to Inola

bandwidth 384000

ip address 10.4.1.5 255.255.255.252

frame-relay interface-dlci 19

!

interface Serial2/2.20 point-to-point

description Connection to Collinsville

bandwidth 384000

ip address 10.4.1.21 255.255.255.252

frame-relay interface-dlci 20

!

interface Serial2/2.21 point-to-point

description Connection to Owasso

bandwidth 384000

ip address 10.4.1.29 255.255.255.252

frame-relay interface-dlci 21

!

interface Serial2/2.22 point-to-point

description Connection to Skiatook

bandwidth 384000

ip address 10.4.1.33 255.255.255.252

frame-relay interface-dlci 22

!

interface Serial2/2.23 point-to-point

description Connection to Training

bandwidth 384000

ip address 10.4.1.37 255.255.255.252

frame-relay interface-dlci 23

!

interface Serial2/2.25 point-to-point

description Connection to Owasso 96

bandwidth 384000

ip address 10.4.1.41 255.255.255.252

frame-relay interface-dlci 25

!

interface Serial2/3

no ip address

shutdown

serial restart_delay 0

!

ip default-gateway 10.1.0.91

ip nat translation timeout never

ip nat translation tcp-timeout never

ip nat translation udp-timeout never

ip nat translation finrst-timeout never

ip nat translation syn-timeout never

ip nat translation dns-timeout never

ip nat translation icmp-timeout never

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.0.91

ip route 10.2.3.0 255.255.255.0 10.4.1.18

ip route 10.2.4.0 255.255.255.0 10.4.1.26

ip route 10.2.5.0 255.255.255.0 10.4.1.30

ip route 10.2.6.0 255.255.255.0 10.4.1.22

ip route 10.2.7.0 255.255.255.0 10.4.1.34

ip route 10.2.8.0 255.255.255.0 10.4.1.6

ip route 10.2.9.0 255.255.255.0 10.4.1.10

ip route 10.2.10.0 255.255.255.0 10.4.1.14

ip route 10.2.11.0 255.255.255.0 10.4.1.42

ip route 10.2.90.0 255.255.255.0 10.4.1.38

ip route 10.3.0.0 255.255.255.0 10.1.0.74

no ip http server

ip pim bidir-enable

!

!

!

snmp-server community priv RO

snmp-server community pub RO

snmp-server chassis-id 0x16

call rsvp-sync

!

voice-port 1/0:23

echo-cancel coverage 32

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 9 pots

destination-pattern 9T

no digit-strip

direct-inward-dial

port 1/0:23

!

dial-peer voice 1000 voip

destination-pattern 73..

session target ipv4:172.16.20.11

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

codec g711ulaw

ip qos dscp ef media

!

dial-peer voice 7100 pots

description Claremore

destination-pattern 71..

no digit-strip

port 1/0:23

!

dial-peer voice 8800 pots

description Pryor

destination-pattern 88..

no digit-strip

port 1/0:23

!

dial-peer voice 1400 pots

description Owasso 86th St.

destination-pattern 14..

no digit-strip

port 1/0:23

!

dial-peer voice 1600 pots

description Collinsville

destination-pattern 16..

no digit-strip

port 1/0:23

!

dial-peer voice 6700 pots

description Skiatook

destination-pattern 67..

no digit-strip

port 1/0:23

!

dial-peer voice 4800 pots

description Inola

destination-pattern 48..

no digit-strip

port 1/0:23

!

dial-peer voice 1300 pots

description Broken Arrow

destination-pattern 13..

no digit-strip

port 1/0:23

!

dial-peer voice 3000 pots

description Union

destination-pattern 30..

no digit-strip

port 1/0:23

!

dial-peer voice 7000 pots

description Training Center

destination-pattern 70..

no digit-strip

port 1/0:23

!

dial-peer voice 7200 pots

description Claremore

destination-pattern 72..

progress_ind alert enable 8

no digit-strip

port 1/0:23

!

dial-peer voice 1001 voip

destination-pattern 73..

session target ipv4:172.16.20.10

dtmf-relay cisco-rtp h245-signal h245-alphanumeric

codec g711ulaw

ip qos dscp ef media

!

dial-peer voice 911 pots

destination-pattern 911

no digit-strip

port 1/0:23

prefix 9

!

alias exec sf sho frame-relay

alias exec sr sho run

alias exec ct conf t

alias exec i sho ip int brie

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

logging synchronous

login

!

ntp clock-period 17181529

ntp server 10.1.0.47 prefer

!

end

c.shepard Mon, 10/21/2002 - 10:47

Trunk Group

Group Type isdn

CDR Reports Y

direction two-way

outgoing display n (This will display the trunk group name)

dial access y

busy threshold 99

queue length 0

service type tie

auth code n

testcall itc rest

testcall bcc 2

codeset to send 0

codeset to send national ie 0

max message size 260

charge advice none

supp service protocol a

digit handling enbloc/enbloc

trunk hunt descend

digital loss group 13

numbering format natl-pub (I have tried them all)

bit rate 1200

syncro async

duplex full

disconnect supervision in Y out N

answer supervision timeout 0

ACA Assignment n

measured none

wideband support n

internal alert n

mainten test y

data restriction n

send name y

send calling number y

used for dcs n

suppress # outpulsing n

number format public

outgoing channel id encoding preferred

uui ie treatment service-provider

replace restricted numbers n

replace unavailable numbers n

send connected number y

send ucid y

send condeset 6/7 LAI IE n

US NI Delayed calling name update N

DS1 Circuit pack

location 01b14

line coding b8zs

line compensation 1

framing mode esf

signaling mode isdn-pri

connect pbx

interface network

centreVu long n

country protocol 1

internetworking message progress

protocol version b

interface companding mulaw

crc n

idle code 11111111

slip detection y

near-end csu type other

Signaling group

associated signaling y

trunk group for channel selection 11

supplementary service protocol a.

Let me know what I can do. I appreciate all your help.

mramella Wed, 10/16/2002 - 07:44

If you not able to get multiple frame established by doing a "sh isdn status" try placing "isdn bind-l3 ccm-manager" in the serial port for the trunk.

Example: (Sorry I had an an E1 config, should be no different)

controller E1 0/1

pri-group timeslots 1-31 service mgcp

!

interface Serial0/1:15

no ip address

no logging event link-status

isdn switch-type primary-net5

isdn bind-l3 ccm-manager

no cdp enable

Actions

Login or Register to take actions

This Discussion

Posted September 20, 2002 at 2:17 PM
Stats:
Replies:15 Avg. Rating:
Views:891 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard