I know I am missing something simple.

Unanswered Question
Oct 4th, 2002
User Badges:

Here is what I am trying to do. I have 3 1601 routers on a frame relay net work. All 3 routers have s0.1 connected back to our corporate office. Now, I also have sperate PVCs connecting those routers to one another, so, router A has a PVC to corporate on s0.1 and a PVC to router B on s0.2. Router B has a PVC to corporate on s0.1, s0.2 is to router A and s0.3 is a PVC to router C. Router C has a PVC to corporate on s0.1 and s0.2 is its connection to router B. The problem is, the PVCs back to corporate all work fine, but the PVCs to one another do not. I can get router A to talk to router B, but only if I shut down the connection from router B to router C. Below are the configs for all 3 routers. I know I am missing something here, any help would be appreciated.


ROUTER A

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname Libertyville

!

no logging buffered

enable secret XXX

enable password XXX

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 192.168.16.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no logging event subif-link-status

no logging event dlci-status-change

service-module 56k clock source line

service-module 56k network-type dds

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description Frame Relay PVC to Natick

ip address 192.168.254.66 255.255.255.252

no ip directed-broadcast

frame-relay interface-dlci 875

!

interface Serial0.2 point-to-point

description frame-relay PVC to 19-Astrodome

ip address 10.11.11.1 255.255.0.0

no ip directed-broadcast

frame-relay interface-dlci 335

!

router eigrp 1

passive-interface Ethernet0

network 10.0.0.0

network 192.168.16.0

network 192.168.254.0

!

no ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.65

!

snmp-server community public RW 1

snmp-server community private RW 1

line con 0

session-timeout 25

exec-timeout 25 0

password XXXX

login

transport input none

flowcontrol hardware

line vty 0 4

session-timeout 25

exec-timeout 25 0

password XXX

login

!

end


ROUTER B

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Astrodome

!

enable secret XXX

enable password XXX

!

!

!

interface Ethernet0

ip address 192.168.19.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

encapsulation frame-relay

no fair-queue

service-module 56k clock source line

service-module 56k network-type dds

!

interface Serial0.1 point-to-point

description Frame-Relay PVC to Natick

ip address 192.168.254.78 255.255.255.252

no ip directed-broadcast

frame-relay interface-dlci 875

!

interface Serial0.2 point-to-point

description Frame-Relay PVC From Libertyville

ip address 10.11.11.2 255.255.0.0

frame-relay interface-dlci 878

!

interface Serial0.3 point-to-point

description Frame Relay PVC To Harper Woods

ip address 10.11.11.3 255.255.0.0

frame-relay interface-dlci 320

!

router eigrp 1

passive-interface Ethernet0

network 10.0.0.0

network 192.168.19.0

network 192.168.254.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.77

!

snmp-server community public RW 1

snmp-server community private RW 1


line con 0

session-timeout 25

exec-timeout 25 0

password XXX

login

flowcontrol hardware

line vty 0 4

session-timeout 25

exec-timeout 25 0

password XXX

login

!

end

ROUTER C

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname HarperWoods

!

enable secret XXX

enable password XXX

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 192.168.28.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

no fair-queue

service-module 56k clock source line

service-module 56k network-type dds

!

interface Serial0.1 point-to-point

description Frame-Relay PVC To Natick

ip address 192.168.254.114 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 875

!

interface Serial0.2 point-to-point

description Frame-Relay PVC From Astrodome

ip address 10.11.11.4 255.255.0.0

no ip directed-broadcast

frame-relay interface-dlci 335

!

router eigrp 1

passive-interface Ethernet0

network 10.0.0.0

network 192.168.28.0

network 192.168.254.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.254.113

!

!

line con 0

transport input none

line vty 0 4

password XXX

login

!

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
steve.barlow Fri, 10/04/2002 - 04:11
User Badges:
  • Silver, 250 points or more

Look on router B:

interface Serial0.2 point-to-point

ip address 10.11.11.2 255.255.0.0

!

interface Serial0.3 point-to-point

ip address 10.11.11.3 255.255.0.0


The IPs overlap. Change the link between B and C to 10.12.x.x 255.255.0.0

Also, under EIGRP process, put no auto-summary.

Hope it helps.

Steve


deilert Fri, 10/04/2002 - 11:58
User Badges:
  • Silver, 250 points or more

i think that you need no auto summary under router EIGRP on all the routers

Actions

This Discussion