×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

EIGRP split horizon problem?

Unanswered Question
Oct 13th, 2002
User Badges:

I use EIGRP in topology like below:

|---< routerB > -------linkB-----------< routerC >---|LAN2

|---< routerA > -------linkA-----------< routerC >---|

|

|LAN1

.

in eigrp topology table I see:

on routerC: LAN1 via linkA and via linkB

on routerB: LAN2 via linkB and via routerA

on routerA: LAN2 only via linkA

.

I gues situation on the routerA is because of split horizon rule.

.

My problem is when I turn off the linkA then:

-routerA see LAN2 via routerB

-routerB see LAN2 via linkB

.

now I am turing on the linkA and I was sure I will get the situation:

-routerB see LAN2 via linkB

-routerA see LAN2 via linkA and routerB

(because of split horizon rule routerA should not propagate info about LAN2 to routerB)

.

but that is not true - when the link is up, I get the startup situation.

if I turn off and turn on linkB, I get the startup situation too.

.

I do not understand how it works - can anybody help me to get it please?

.

best regards


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
steve.barlow Sun, 10/13/2002 - 16:16
User Badges:
  • Silver, 250 points or more

Link A and B or the LAN1 interfaces don't have the same bandwidth do they? The best route (lowest metric) to a destination is called the feasible distance (FD). Feasibility condition (FC) is met when the neighbor's FD, also known as reported distance (ie the total metric along a path to a destination network as advertised by an upstream neighbor), to a destination is lower than the router's current FD to the same destination. So for a route to be in the eigrp top table, the advertised distance (AD) must be less than the FD for that route.

A feasible successor is a path whose reported distance is less than the feasible distance.

Do a sh ip eigrp top x.x.x.x (where x.x.x.x is the lan 2 network) and show ip eigrp topology all-links. On routerA the AD of lan2 from linkb/routerb must be larger than the FD.

If not post the show ip eigrp top outputs.

This link explains in more detail the topology table, feasible successors, metrics etc: http://www.cisco.com/warp/public/103/eigrp1.html

Hope it helps.

Steve

p.kodzis Sun, 10/13/2002 - 23:25
User Badges:

I have the same bandwidth configured on WAN links on routerA and routerB. Also the same bandwidth on LAN interfaces of those routers (see config below).


LAN2 network is 10.10.1.0/24. delay and distance make I can have 2 links with the same metric on routerB.


.

#==routerB==

!

interface FastEthernet0/0

ip address 10.10.3.1 255.255.255.0

bandwidth 10000

!

interface Serial2/0

bandwidth 2048

ip address 10.10.250.110 255.255.255.252

delay 2010

!

router eigrp 100

redistribute static

network 10.0.0.0

distance 90 10.10.3.9 0.0.0.0 17

auto-summary

!

#======

.

#==routerA==

interface Ethernet1/0

ip address 10.10.3.9 255.255.255.0

delay 10

!

interface Serial2/0

bandwidth 2048

ip address 10.10.250.142 255.255.255.252

!

router eigrp 100

redistribute static

network 10.0.0.0

distance 90 10.10.3.1 0.0.0.0 17

auto-summary

!

#======

.

#==routerB sh ip eigrp top all==

P 10.10.1.0/24, 2 successors, FD is 1766912, serno 144

via 10.10.250.109 (1766912/28160), Serial2/0

via 10.10.3.9 (1766912/1764352), FastEthernet0/0

#======

.

#==routerA sh ip eigrp top all==

P 10.10.1.0/24, 1 successors, FD is 1764352, serno 448

via 10.10.250.141 (1764352/28160), Serial2/0

#======

.

#=== acl 17 the same on both routers ===

access-list 17 permit 10.10.1.0 0.0.0.255

#=====

.

steve.barlow Mon, 10/14/2002 - 04:45
User Badges:
  • Silver, 250 points or more

The routers don't have the same FD:

routera=1764352

routerb=1766912

So 10.10.1.0/24 from routera is less (1764352) than the FD of routerb, but the AD is more than the FD from routerb to routera. Metric is composed outbound on an interface, and the AD from routerc is equal (both routera and routerb see the metric as 28160). For both routera and routerb to get to lan2, they must count the metric for leaving the s2/0 interface, and leaving the routerc lan2 interface. Routerc is advertising an equal metric so it leaves the serial interfaces on routera and routerb to be different. The AD on both routers from routerc is equal, the bandwidth is equal on the serial links but the FD is different so what is left - delay. Why does s2/0 on routerb have a delay of 2010 and routera doesn't? Remove that delay or add the same on routera and see what you get.

Steve

Actions

This Discussion