Memory usage problem on X25 links

Unanswered Question
Nov 14th, 2002
User Badges:

We have a problem about X25 configuration. We are using PAD connections on an X25 network. Every PAD connection uses about 1k buffer memory. Although the PAD connection is terminated, the buffer is not freed.So after 17000 PAD connections, we get "%No more memory available" error and new PAD connections cannot be established unless we reload the router. I am not experienced on X25 and PADs.So are there any missing commands on the configuration below?

And I am using c2600-i-mz.121-2 IOS.I can upgrade the IOS if this problem is caused by a bug.I am waiting for your comments.

Thanks.

Using 2717 out of 29688 bytes

!

version 12.1

service timestamps debug datetime msec

service timestamps log uptime

no service password-encryption

!

hostname 2600

!

enable secret 5 $1$.YWA$ySJMb/f8IJvXqcIiKhiR3/

!

ip subnet-zero

!

x25 routing

!

!

!

interface Ethernet0/0

ip address 192.168.10.1 255.255.255.0

!

interface Serial1/0

bandwidth 64

ip address 10.0.0.2 255.0.0.0

encapsulation x25

x25 address xxxxxxxxxx

x25 htc 10

x25 t20 60

x25 t21 180

x25 t22 60

x25 t23 60

x25 idle 2

x25 nvc 6

x25 map ip 10.0.0.1 xxxxxxxxxx

x25 map ip 10.0.0.10 xxxxxxxxxx

x25 map ip 10.0.0.12 xxxxxxxxxx

x25 map ip 10.0.0.250 xxxxxxxxxx

pulse-time 1

no cdp enable

lapb interface-outage 15000

lapb N2 10

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/2

no ip address

shutdown

!

interface Serial1/3

no ip address

shutdown

!

ip classless

ip route xxx.xxx.xxx.xxx 255.255.0.0 10.0.0.250

ip route 192.168.1.0 255.255.255.0 10.0.0.1

ip route 192.168.100.0 255.255.255.0 10.0.0.10

ip route 192.168.102.0 255.255.255.0 10.0.0.12

no ip http server

!

x25 route xxxxxxxxxx interface Serial1/0

!

line con 0

transport input none

line aux 0

line vty 0 4

password 2600

login

!

exception memory fragment 10000

exception memory minimum 10000

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
donewald Thu, 11/14/2002 - 07:38
User Badges:
  • Silver, 250 points or more

12.1.2 had actually been deffered for other reasons in other platforms but the recommended "goto release" was 12.1.5 at the time. 12.1.17 is GD and works very well. My customer uses X25 with this 12.1.17 code with no memory leak problems, you've mentioned, to speak of.


Hope this helps,

Don

Actions

This Discussion