×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

How to config 2 NAT translation over two different internet pool?

Unanswered Question
Nov 17th, 2002
User Badges:

There are two ISP provide service to our company, and they assigned two internet subnets to us ---- 202.101.111.X / 18 and 210.34.111.X / 24, I configed our Cisco 2621 router (IOS 12.2) like this :

-----------------start copy config here ----------------------


interface FastEthernet0/0 ----------- to 1st ISP,a unstable internet connection

ip address 210.34.111.171 255.255.255.0

ip nat outside

no ip mroute-cache

speed auto

full-duplex

!

interface FastEthernet0/1 ---------- to our intranet

ip address 172.16.5.1 255.255.255.0

ip nat inside

no ip mroute-cache

speed auto

full-duplex

!

interface Ethernet1/0 ---- to 2nd ISP with stable internet connection

ip address 202.101.111.101 255.255.255.192

ip nat outside

no ip mroute-cache

full-duplex

!

ip nat pool pub 202.101.111.102 201.101.111.119 netmask 255.255.255.192

ip nat pool cer 210.34.111.171 210.34.111.171 netmask 255.255.255.0

ip nat inside source pool pub overload

ip nat inside source pool cer overload

ip classless

ip route 0.0.0.0 0.0.0.0 202.101.111.65

ip route 210.34.0.0 255.255.0.0 210.34.111.1

no ip pim bidir-enable

!

access-list 1 permit 172.16.5.0 0.0.0.255

access-list 2 permit 172.16.5.0 0.0.0.255


--------------end of copy config --------------------


I hope the router couldn NAT it base on the route table: to 210.34.X.X net,use cer pool, while to the other host use the pub pool. but I failed : when I try to access a host with IP 210.34.45.217, it go through this way:

172.16.5.22 ----my desktop

|

172.16.5.1 ---router

|

202.101.111.102 -- after NAT

|

210.34.111.171 --- go to the correct port here,but it take about 200ms

:

:

210.34.45.217


I believe I should change my config(maybe use route-map...), but I don't know how to do,any help will be appreciate.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
d_korman Mon, 11/18/2002 - 01:30
User Badges:

You could associate a route-map with each NAT pool. Use the route-maps to select which pool to use based on appropriate criteria. match IP next-hop might be suitable. Note that the resulting mapping entries are flow-based so cannot be used for incoming connections.

Actions

This Discussion