cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
332
Views
0
Helpful
1
Replies

Load balancing and failover....

josephpjob
Level 1
Level 1

I have one Cisco 4500 with 8 serial port and 6 Ethernet port. From the Ser0 and Ser1 I have two connectivity to my upstream provider. But one is of 2MB and other is of 1MB

See the configuration of 2 of LAN interfaces and ser0, and ser1 interfaces...

interface Ethernet0

description Local range 203.197.151.65-94

ip address 203.197.151.94 255.255.255.224

no ip directed-broadcast

media-type 10BaseT

no mop enabled

!

interface Ethernet1

description IP of Progs 202.4.191.1-126 mask .128

ip address 202.4.191.1 255.255.255.128

no ip directed-broadcast

media-type 10BaseT

!

interface Ethernet2

description Co-location range 202.4.191.129- .190 Mask .192

ip address 202.4.191.189 255.255.255.192

no ip directed-broadcast

media-type 10BaseT

!

interface Serial0

bandwidth 2048

ip address 203.197.150.230 255.255.255.252

no ip directed-broadcast

no ip mroute-cache

!

interface Serial1

bandwidth 1024

ip address 203.197.150.232 255.255.255.252

no ip directed-broadcast

!

Now my requirements are

1. Load balancing and fail over of all traffic from my network.

2. I want to route traffic from eth0 (203.197.151.64/27) through serial0(2mb), in case of any failure with 2MB link, I want the traffic through serial1

For the above two is this configuration is enough...

ip route 0.0.0.0 0.0.0.0 serial0

ip route 0.0.0.0 0.0.0.0 serial1 240

ip route 203.197.151.64 255.255.255.224 serial0(2mb)

ip route 203.197.151.64 255.255.255.224 serial1256k 240

3. I want to route traffic from eth1 through 1MB link, in case of any failure, I want this through 2mb link

So the configuration will be...

ip route 202.4.191.0 255.255.255.128 serial1

ip route 202.4.191.0 255.255.255.128 serial0 240

Is this correct...??

1 Reply 1

thisisshanky
Level 11
Level 11

1. To achieve load balancing you need to have both the routes in the routing table at the same time.

2. with the configuration of default routes as you have done, the second default route wil not be available as long as 2 MB link is up and running. So if you need pure load balancing, you need to use same administrative distance for both the default routes.

The remaining ip rouite statements are of no use, because the ip addresses you have configured on the route statements are directly connected to your router.

If you need to route all traffic from e0 to s0 first and s1 (only when s0 fails), and all traffic from e1 to s1 first and s0 (only when s1 fails), you need to use policy routing.

int e0

ip policy route-map test1

int e1

ip policy route-map test1

route-map test1 permit 10

match interface ethernet0

set interface s0 s1

route-map test2 permit 20

match interface ethernet1

set interface s1 s0

Hope that helps!

Sankar Nair
UC Solutions Architect
Pacific Northwest | CDW
CCIE Collaboration #17135 Emeritus