×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Mac (AppleTalk) Connectivity problems on a Cisco 3500XL switch.

Unanswered Question
Dec 13th, 2002
User Badges:

I have been having connectivity problems with the Macs that are on my network. They keep dropping on and off the network, they get the error message "Access to your appletalk network has been interrupted. When the network becomes available again, a message on your screen will notify you."

Also the PCs do not appear to be having any problems. This problem has seemed to get progressively worst over time. We have a Cisco 3500XL switch, that had just been replaced under warrenty about 5 months ago. The Macs are running OS 9.2.2, HP server Win NT 4.0, Nics are AsanteFast 10/100 PCI using most current driver 4.0 They are set at Full duplex and 100 mbps on Macs and on switch, I have also tried auto negotiate. Are there any diagnostic tools built-in to this Switch? I'm currently using netscape to configure switch. I would greatly appreciate any help you could offer.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Fri, 12/13/2002 - 11:45
User Badges:
  • Purple, 4500 points or more

I assume that you have matched the switch port config , to the MACS nic . If the mac is auto then the switch needs to be auto . Try hardcoding both mac and switch to be the same . Are you seeing any errors on the switch port ?

harmonypress Mon, 12/16/2002 - 09:59
User Badges:

Macs & switch are both set at full duplex & 100mbps. What type of errors should I be looking for and where should I look? There are not many collisions and no late collisions or excessive collisions. There are some ports with high # of collision fragments and total collision packets though.

raarons Tue, 12/17/2002 - 03:10
User Badges:

There should be NO collisions on a properly-configured full-duplex link, late or not. If you are seeing collisions, this implies to me that either the switch or the NIC (or both) on these links is not configured full-duplex.


Some time I ago I had a similar problem, but not with these particular NICs (and the MacOS version was a lot earlier too, if I recall correctly). The problem was finally put to bed by proving that the NIC drivers did not honour the administrative settings on the driver set up, but dropped to half-duplex.


Try setting both ends of links to half-duplex instead of full. There is also an unsupported MAC utility which properly sets the NIC characteristics available here


http://kbase.info.apple.com/cgi-bin/WebObjects/kbase.woa/wa/query?val=60436&x=0&y=0&type=ids&nodes=&dateModified=&wosid=oP9T47Gw3Y1C3ds3BEs1A93lJzI


Hope this helps

harmonypress Tue, 12/17/2002 - 05:48
User Badges:

The Mac utility you reference only supports built-in nics on the blue & white G3s. These are biege G3s currently using AsanteFast 10/100 PCI nics. When I use the built-in nics the problem Improves but the speed drops to half duplex and 10 mbps, when switch is set on auto. Don't see anyplace to configure for the built-in nics.

hampton Mon, 12/16/2002 - 16:43
User Badges:

1. When appletalk messes up, does TCP/IP still work? If so it's probably a zone issues. If not it's a port/nic/switch issue.

2. Where are you seeding the zone(do you have zones?)? You can only seed it from one device. If you are seeding it at the router and someone has turned on zones on the NT server you will see this behavior. I had a lab admin turn EVERYTHING on on his NT server once and things got really odd with these types of messages popping up all the time. If you are seeding the zone on the NT server, make sure nothing else is doing the same (routers, shiva net-modems, old Apple servers, etc.)

3. If you are not seeding the zone, you might want to try turning off Spanning Tree if it's not needed.

As for debugging stuff, if you have a cisco router w/ appletalk support, you can "debug appletalk events" and "debug appletalk errors" other than that, a packet sniffer may help to see the incorrect packets. You should also check to see if the port is dropping, cutting off the mac entirely. You could also try putting a hub inline with the mac.

harmonypress Tue, 12/17/2002 - 06:10
User Badges:

When the appletalk goes down the computer locks up until the connection is lost, and then again when it reconnects about 30 seconds later. So it is hard to tell if TCP/IP is working, although it appears that file transfers and printing progress while off appletalk. How do I check what devices might be seeding the network, could it be a printer? We recently added a new Xante 1200 printer about the time the problem started. Also don't have cisco router, only the 3500XL switch.

kgbsd Tue, 12/17/2002 - 09:28
User Badges:

We have about 800 macs here and we always have this issue when they are plugged into 100mb ports. We almost always have to put them into 10mb ports or hard code it to 10mb and half duplex for them to work. The newer Mac's seem to be better if they are in OS X, but anything in 9.x seems to run better at 10mb.

hampton Wed, 12/18/2002 - 16:15
User Badges:

Just to counter this point, we have a few mac's and I've never seen what you mention above in the numbers that you seem to be suggesting. I've seen a few machnines connected to a few switches that worked better if they were not set to auto-neg, but we've always been able to do 100mb FD unless it was an old machine, and it was only one or two really, not enough to make it policy, so to speak. Plus when this happened, it was more a case that it kept auto-neg'ing down to half duplex and we wanted it at full duplex. And we have a rather large mac population (over 8000 mac's)

hampton Wed, 12/18/2002 - 16:05
User Badges:

We installed a Xante printer this summer too and, not to suggest that it's causing your problems, but it was set up for DHCP, and it started flooding our network. Our DHCP server was dutifully responding to the DHCP requests, but the xante was ignoring them. Our DHCP server generated 10GB of log file over night, was running at 100% CPU and ignoring all other requests to other machines. We statically assigned it as IP address and it stopped. Anyway, you may want to see if there is an upgraded firmware or network issues with your unit.

hampton Wed, 12/18/2002 - 16:24
User Badges:

I've never had a mac pause when just appletalk was dropped. You could test it by pinging the IP address of the mac and watch it when it drops. If TCP/IP is still responding it's an appletalk issue, if you can't it's probably lower on the ladder than protocol.

You can only really check for seeding with a packet sniffer or if you watch the errors on a cisco seed router. The latter you stated you are not using. Printers cannot seed zones, at least I've never seen one do it though it would be possible if it had a hardware RIP/PrintServer but I've never seen one do it, only routers or servers. Old mac servers have the software (called Apple Internet Router or something, hasn't been made in many years) and NT can do it. With the packet sniffer, you would see the zone announcements and such, when there shouldn't be any. I doubt this is the case though, from you later discriptions of the problem. It looks like either the switch is cutting off the ports or something is causing auto-neg to fail. Is the problem localized to one switch? Do other devices on that switch still work fine? Have you tried setting 100FULL on the port in question? If the switch is restarting it would cause a 30 second pause like this.

harmonypress Thu, 12/26/2002 - 06:03
User Badges:

It would be hard to test TCP/IP since they only drop for about 30 seconds. Our NT sever is the only thing seeding the zone (that I'm aware of). We only have 1 switch on our network, and all other devices on it appear to be working fine, only the mac ports are affected (5 ports), even one mac that is hooked up directly to the NT servers NIC card drops off. As of now we don't have a packet sniffer, are there any fully operational demos out there I could try? Would a packet sniffer see past the switch?

harmonypress Mon, 12/30/2002 - 07:50
User Badges:

TCP/IP is still responding, I was able to ping macs IP address.

vfranck Tue, 12/17/2002 - 15:33
User Badges:

try disabling spanning tree on that switch, or at least use portfast feature...

russell-r Tue, 12/17/2002 - 16:03
User Badges:

I would also look at your version of OpenTransport and ensure there are no known bugs related to this problem....

Actions

This Discussion