×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

cannot receive call during SRST mode.

Unanswered Question
Jan 21st, 2003
User Badges:

I have a 3620 router, configured as SRST gateway. During SRST mode, I was unable to receive any call from PSTN, I have to dial the full digits to make PSTN call. i don't have the debug info now. Append is the configuration, what could have gone wrong:

!

clock timezone singapore 8

voice-card 1

!

ip subnet-zero

!

!

no ip domain-lookup

!

ip audit notify log

ip audit po max-events 100

!

class-map match-all voip-media

match access-group 100

class-map match-all voip-sig

match access-group 101

class-map match-all voipmedia

match ip dscp 46

class-map match-all voipsig

match ip dscp 26

!

!

policy-map wanqos

class voipmedia

priority 1000

class voipsig

bandwidth 200

class class-default

fair-queue

policy-map mark2zero

class class-default

set ip dscp 0

policy-map voip-qos

class voip-media

priority 1000

class voip-sig

bandwidth 200

class class-default

fair-queue

policy-map dscp2cos

class voipmedia

set cos 5

class voipsig

set cos 3

!

!

isdn switch-type basic-net3

!

voice rtp send-recv

!

voice class codec 100

codec preference 1 g711ulaw

!

!

!

voice class h323 10

h225 timeout tcp establish 3

!

!

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

controller E1 1/0

pri-group timeslots 1-31

!

translation-rule 389

Rule 1 638937.% 37 ANY abbreviated

!

translation-rule 9

Rule 0 ^.% 9

!

translation-rule 68266

Rule 0 ^682661.% 1

Rule 1 ^682662.% 2

Rule 2 ^682663.% 3

Rule 3 ^682665.% 5

!

!

!

!

interface BRI0/0

description Backup ISDN 64K for BMRC Leased

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

ppp authentication chap

!

interface Ethernet0/0

bandwidth 100

ip address 10.178.203.254 255.255.255.0

no ip route-cache

no ip mroute-cache

full-duplex

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.178.203.254

!

interface Serial0/0

description 2048K Leased Line to Science Park

bandwidth 2048

backup delay 0 20

backup interface Dialer0

ip address 10.178.221.4 255.255.255.248

encapsulation ppp

no ip mroute-cache

service-policy output wanqos

!

interface Ethernet0/1

bandwidth 100

no ip address

no ip route-cache

no ip mroute-cache

shutdown

full-duplex

!

interface Serial1/0:15

no ip address

no ip route-cache

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn T309-enable

isdn send-alerting

isdn sending-complete

no cdp enable

!

interface Dialer0

ip address 10.178.221.3 255.255.255.248

ip access-group 102 in

encapsulation ppp

dialer pool 1

dialer idle-timeout 900

dialer string 68730244

dialer-group 1

ppp authentication chap

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.178.221.1

ip route 10.178.192.0 255.255.255.0 10.178.221.1

ip route 10.178.196.0 255.255.255.0 10.178.221.1

ip route 10.178.204.0 255.255.255.0 10.178.221.1

no ip http server

no ip pim bidir-enable

!

!

logging history debugging

logging trap debugging

logging 10.178.203.1

access-list 100 permit udp any any range 16384 32767

access-list 100 permit udp any range 16384 32767 any

access-list 101 permit tcp any host 10.178.196.1

access-list 101 permit tcp host 10.178.196.1 any

access-list 101 permit tcp any host 10.178.196.2

access-list 101 permit tcp host 10.178.196.2 any

access-list 102 deny tcp any host 10.178.196.1

access-list 102 deny tcp host 10.178.196.1 any

access-list 102 deny tcp any host 10.178.196.2

access-list 102 deny tcp host 10.178.196.2 any

access-list 102 permit ip any any

dialer-list 1 protocol ip list 102

!

call rsvp-sync

!

voice-port 1/0:15

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 200 voip

incoming called-number .

destination-pattern 68266[1-3,5]..

progress_ind setup enable 3

translate-outgoing calling 9

translate-outgoing called 68266

voice-class codec 100

voice-class h323 10

session target ipv4:10.178.196.2

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 100 pots

destination-pattern 9[6,9].......

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

!

dial-peer voice 101 pots

destination-pattern 9018T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 018

!

dial-peer voice 102 pots

destination-pattern 9800T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 800

!

dial-peer voice 103 pots

destination-pattern 91800T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 1800

!

dial-peer voice 104 pots

destination-pattern 91900T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 1900

!

dial-peer voice 105 pots

destination-pattern 91...

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 1

!

dial-peer voice 106 pots

destination-pattern 91..

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 1

!

dial-peer voice 107 pots

destination-pattern 99..

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 9

!

dial-peer voice 108 pots

destination-pattern 900T

progress_ind alert enable 8

direct-inward-dial

port 1/0:15

prefix 00

!

dial-peer voice 201 voip

incoming called-number .

destination-pattern 68266[1-3,5]..

progress_ind setup enable 3

translate-outgoing calling 9

translate-outgoing called 68266

voice-class codec 100

voice-class h323 10

session target ipv4:10.178.196.1

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

ip qos dscp cs3 signaling

no vad

!

!

!

call-manager-fallback

limit-dn 7940 2

limit-dn 7960 4

timeouts interdigit 5

ip source-address 10.178.203.254 port 2000

max-ephones 24

max-dn 96

dialplan-pattern 1 68266... extension-length 3

keepalive 10

translate called 68266

call-forward busy 68266195

call-forward noan 68266195 timeout 20000

date-format dd-mm-yy

!

!

line con 0

password xxxxxx (moderator edit)

line aux 0

password xxxxxxx (moderator edit)

line vty 0 4

exec-timeout 5 0

password xxxxxx (moderator edit)

!

!

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smalkeric Mon, 01/27/2003 - 14:10
User Badges:
  • Silver, 250 points or more

You can check for known bugs in the Cisco Bug Tool Kit. I found one such bug in the Tool kit, similar to this one. Please check it out.The bug ID is CSCdv75720. The following debugs could help you find out the reasons.


debug vpm sig

debug voip ccapi inout

debug vtsp session


I am not very sure of the solution, if the above bug is the one found in this case.Does anybody has the solution to this?


trailman73 Fri, 01/31/2003 - 14:54
User Badges:
  • Bronze, 100 points or more

Have you tried using the num-exp command? I am using this and it works very well.


num-exp DID EXTENSION


for example: num-exp 7035551212 3062


Geoff


Actions

This Discussion