Bank ATM machine problems

Unanswered Question
Jan 26th, 2003

I have been working on moving a Bank's ATM machine over from an old 2520 router to a newer 3640 router. The ATM machine works using BSTUN with a loopback address. I duplicated the configuration on the 2520 EXACTLY onto the 3640 but could not get the ATM machine talking with the new router, as soon as I put the old router back in place the ATM machine came up. Is there something easy I am missing when trying to make this switch? I can post the running configs of both if needed but it would require alot of editing (It is a bank..heh).... thanks in advance!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
a.manosca Sun, 01/26/2003 - 17:14

hmm, sounds familiar....

Sometimes, changing the router and copying the exact config doesn't work,

specially if the router was changed from one platform to another.

I assume you are using the same cable to connect to the ATM machine.

This be could be a software issue and it would be better if you could review

the Release Notes for the IOS version of your 3640.

Some of the default 3640 configurations might have an effect.

This troubleshooting guide might help:

http://www.cisco.com/warp/public/100/bsc_guide2.html

deilert Mon, 01/27/2003 - 05:24

If the serial interface is a dce do not forget to set the clock

jbouwkamp@netco... Mon, 01/27/2003 - 05:37

The original 2520 router had the ATM plugged in on Serial 1 with no clock rate settings, the new 3640 router has the ATM plugged in to serial 1/0 with no clock rate settings. So does that sound like the clock rate is a correct issue? (I would test it but its a two hour drive to the site and no remote access...) thanks! I had the baud rate set to 9600 so should clock rate be the same? When I do a show bstun events it shows that the remote router is sending signals but the local ATM is showing no packets, would no clock rate setting cause this? thanks for the help!!

deilert Mon, 01/27/2003 - 06:18

you only need to set the clock if your serial interface is acting as the DCE. do a sh controllers and see if a dce cable is attached. If the line goes up it is not a clocking issue.

Can you paste configs from the 2520 & 3640

john-lucero@wipp.ws Mon, 01/27/2003 - 12:11

This is probably to simple, but is the new serial interface shutdown? The problem may be as simple as typeing no shutdown on the interface in question.

a.manosca Mon, 01/27/2003 - 23:56

If it was working with the 2520 router with no clock settings,then it shouldn't be the culprit. It would be helpful if you can post the IOS versions of the routers,

an extract of the config, and some debugs you have captured.

jbouwkamp@netco... Tue, 01/28/2003 - 06:00

Here is the config of the 2520 that is working, I changed a few IP addresses and passwords to protect the innocent....

Current configuration:

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname

!

enable secret

!

partition flash 2 8 8

!

isdn switch-type ntt

!

bstun peer-name 172.172.27.1

bstun protocol-group 2 bsc

source-bridge ring-group 1000

!

interface Loopback0

ip address 172.172.27.1 255.255.255.0

no ip mroute-cache

no ip route-cache

!

interface Ethernet0

ip address 172.15.10.251 255.255.255.0

!

interface Serial0

no ip address

!

interface Serial1

description ATM machine G2 c9 P33

no ip address

no ip mroute-cache

encapsulation bstun

no ip route-cache

bandwidth 9600

no keepalive

full-duplex

ignore-dcd

nrzi-encoding

bstun group 2

bsc char-set ebcdic

bsc primary

bstun route address C9 tcp 172.120.2.254

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

!

router eigrp 10

network 172.15.0.0

network 172.172.0.0

!

ip classless

ip route 172.62.237.0 255.255.255.0 172.176.42.100

ip route 172.176.42.254 255.255.255.255 172.176.42.100

!

!

line con 0

line aux 0

transport input all

line vty 0

password

login

length 40

line vty 1 4

password

login

!

end

and here is the 3640 configuration:

Current configuration : 1490 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Main

!

enable secret 5

!

ip subnet-zero

!

!

no ip domain-lookup

!

call rsvp-sync

!

!

!

!

!

!

!

source-bridge ring-group 1000

!

bstun peer-name 172.172.27.1

bstun protocol-group 2 bsc

!

interface Loopback0

ip address 172.172.27.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0/0

ip address 172.15.10.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

description T1 to

ip address 172.20.17.2 255.255.255.252

fair-queue

!

interface Serial0/1

description T1 to

ip address 172.22.8.2 255.255.255.252

!

interface Serial0/2

description T1 to

ip address 172.22.9.2 255.255.255.252

!

interface Serial0/3

no ip address

shutdown

clockrate 2000000

!

interface Serial1/0

description ATM machine G2 c9 P33

bandwidth 9600

no ip address

encapsulation bstun

no ip route-cache

no ip mroute-cache

no keepalive

full-duplex

ignore-dcd

nrzi-encoding

bstun group 2

bsc primary

bstun route address C9 tcp 172.120.2.254

!

interface Serial1/1

no ip address

shutdown

clockrate 2000000

!

router eigrp 10

network 172.15.0.0

network 172.20.0.0

network 172.22.0.0

network 172.172.0.0

no auto-summary

!

ip classless

ip route 172.62.237.0 255.255.255.0 172.176.42.100

ip route 172.176.42.254 255.255.255.255 172.176.42.100

no ip http server

!

!

dial-peer cor custom

!

!

!

!

line con 0

line aux 0

line vty 0 4

password

login

!

end

deilert Tue, 01/28/2003 - 06:08

Can you paste in the output of sh int s1/0 and sh bstun

jbouwkamp@netco... Tue, 01/28/2003 - 06:55

It might be Monday before I can do that, I am 2 hours away from site and don't want to make the drive till I have a solution and the person that is on site that could get the configs for me is away on training this week. I will post them Monday for sure and I appreciate all the help!

Actions

Login or Register to take actions

This Discussion

Posted January 26, 2003 at 4:06 PM
Stats:
Replies:10 Avg. Rating:
Views:352 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,732
3 1,675
4 1,624
5 1,529