Load balancing creates incorrct routing 2ISP 2 routers and NAT mapping

Unanswered Question

Hello, i need help, i called cisco support and for 3 days they could not help me

I have 2 2660 routers , 2 different ISP's, 2 offices. RTR1 for office1 and ISP1. RTR2 for office 2 and ISP2. ISP's and interoffice connection is T1. Ext ip of ISP1 is 1.1.1.1, ISP2 is 2.2.2.2. Office (RTR1) lan is 192.168.1.0, office2 (RTR2) lan is 192.168.7.0. interconnection is .6.1(serial1) and .6.2(serial1). I have a server in office1 192.168.1.13 and ip nat 192.168.1.13 1.1.1.1 works fine, office 2 ipnat 2.2.2.2 192.168.1.13 does not work. RTR1 config is ip route 0.0.0.0 0.0.0.0 1.1.1.1, but when i add ip route 0.0.0.0 0.0.0.0 serial1 RTR1 nat fails and RTR2 works, when i remove the added route RTR1 work RTR2 fails for email server and load shring is removed. So here is my question, How can i make sure that if request comes from RTR1 it goes back to RTR1 and same for RTR2 when i enable load balancing. Another words: You have a room with 2 doors (doorA and doorB). I f person enters room using doorA then person should exit using doorA and same goes for doorB. But if people already inside the room they have a choice of doorA or doorB whotever is closer(balancing). I do not want to use BGP or EBGP or IBGP. the protocol i use is rip, redistribute connected, ip classless. Please advice if i need a switch or create a VLAN. I would like to see an example if possible. How can i make it work?, may be i should use some other products? Please advice.HELP.

Thank You

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.

Try this....


Disable rip from both routers all floating static routes need to be added.

Add default routes to outside world in both routers going through respective serial interfaces.


In rtr1 add TWO routes to 192.168.7.0/24 with administrative distance 120 both, one through ur ISP1 interface and other through ur internal T1 interface.


Do the same in rtr2, add two routes to 192.168.1.0/24 with administrative distances both 120, one through ur ISP2 and other through internal T1.


Hope it works!!


Vikas

Try this....


Disable rip from both routers all floating static routes need to be added.

Add default routes to outside world in both routers going through respective serial interfaces.


In rtr1 add TWO routes to 192.168.7.0/24 with administrative distance 120 both, one through ur ISP1 interface and other through ur internal T1 interface.


Do the same in rtr2, add two routes to 192.168.1.0/24 with administrative distances both 120, one through ur ISP2 and other through internal T1.


Hope it works!!


Vikas

Actions

This Discussion