×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Question on Combining Voice & Data on a T1

Unanswered Question
Feb 14th, 2003
User Badges:

I have 2 offices connected via a T1, currently used for data only. Each end has a Cisco 2621 with a WIC-1T for the T1 termination. Ethernet is connected to a LAN on each end. Each office also has a Mitel PBX. I would like to combine voice and data on the T1 between offices, giving 12 channels each to voice and data.


Can I put a VWIC-2MFT-T1-DI in each of the 2621's and do this, connecting one port to the PBX and one port to the T1? In the documentation I have read it is not clear if I can insert the LAN data from the ethernet port into the T1 using this method, or if I would need a Digital T1 Packet Voice Trunk Network Module.


The voice traffic is only going PBX to PBX. PBX interface on each end is D4(SF) AMI E&M.


Thanks in advance for any suggestions.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chester Rieman Fri, 02/14/2003 - 08:14
User Badges:
  • Cisco Employee,

Yes you can do this. The best way is probably using connection trunk:

http://www.cisco.com/en/US/tech/tk652/tk701/technologies_configuration_example09186a00800afd65.shtml

You will need a NM-HDV-2T1-24= at each end.

Also you don't have to divide it into voice and data, use the whole T1 for both, using LLQ to provide qos for the voice traffic. Using vad in combination with the voice vad-time command will give you almost all the bandwidth for data when voice is not active, voice will only use the BW when calls are active.


r.yard Tue, 02/18/2003 - 06:04
User Badges:

Thanks for the response. The solution looks workable.


If I don't need the dynamic bandwidth allocation between voice and data, will the VWIC-2MFT-T1-DI support both voice and data on the T1 without using the NM-HDV-2T1-24=? A sample config would be:


controller T1 0/0

description to PBX

framing sf

linecoding ami

clock source line

ds0-group 1 timeslots 1-12 type e&m-wink


controller T1 0/1

description to Router B

framing esf

linecoding b8zs

clock source internal

tdm-group 2 timeslots 1-12

channel-group 0 timeslots 13-24


int serial 0/1:0

encapsulation frame-relay


int serial0/1:0.1

ip address 10.0.0.1 255.255.255.0

frame-relay interface-dlci 100 br


interface ethernet 0

ip address 10.0.2.1 255.255.255.0


connect tdm1 t1 0/0 1 t1 0/1 2

doug.porter Wed, 05/07/2003 - 11:27
User Badges:

The config is interesting but I'm trying to understand the relationship of the DS0 group, the TDM-GROUP, and the Channel-group.


On Cont T10/0, why a DS0 group and not TDM group?


On Cont T10/1, why is the ds0 group of cont 0/0 now a tdm-group?


According to Cisco documentation, TDM group on one controller, and a TDM group on the other controller, are merely connected with the "Connect" command.


Thanks in advance.


Doug

r.yard Mon, 05/12/2003 - 10:28
User Badges:

Since my original post a few months ago I've made some changes to the configuration & now have it up and running. I have the relevant portions posted below for the benefit of other readers.


The TDM group under each controller carries the voice data from the main office PBX to the branch office PBX. The crossover of the voice traffic is made with the "connect" statement.


The serial interface is assigned to channels 13-24 (768K) of the T1 with the "channel-group 0" command. Note that the default speed per channel is 56K. 64K must be specified to get the maximum bandwidth.


I went with this configuration to avoid the hardware cost involved in the network voice modules. The tradeoff is that my bandwidth is fixed at 768K for voice and 768K for data. A packetized voice solution would allow this to change dynamically.


Both the data & voice have been very stable on the T1 since I've implemented this solution. I'm saving a bunch of Telco trunc costs at the remote office and have increased my bandwidth to 768K between offices.


controller T1 0/1

framing esf

clock source line primary

linecode b8zs

channel-group 0 timeslots 13-24 speed 64

tdm-group 1 timeslots 1-12 type e&m

description "Connection from DCE"

!

controller T1 0/2

framing esf

linecode b8zs

tdm-group 2 timeslots 1-12 type e&m

description "Connection to PBX"


interface Serial0/1:0

description "Data to Remote Office"

ip address 10.0.0.1 255.255.255.240


connect tdm1 T1 0/1 1 T1 0/2 2

Actions

This Discussion