×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.
donewald Fri, 02/14/2003 - 10:28
User Badges:
  • Silver, 250 points or more

It works fine. Just like if you were using DHCP on a legacy multi-segment network. If DHCP server resides on the same VLAN as the client then no relay is needed. If on a different VLAN than the DHCP server the Clients DHCP Discover would need a relay. No multiple DHCP servers are required.

Hope this helps,

Don

patuba Fri, 02/14/2003 - 10:32
User Badges:

Thanks for the answer. Is the relay agent a workstation or is it part of the switch, a Catalyst 5500?

donewald Fri, 02/14/2003 - 10:37
User Badges:
  • Silver, 250 points or more

The relay is the function or service provided by the routing device (RSM or external router maybe for you) that is routing between VLANS. See ip-helper for your DCHP forwarding needs.


Hope this helps,

Don

patuba Fri, 02/14/2003 - 10:42
User Badges:

Thanks again. So if I understand VLANs correctly I would have to setup DHCP to serve the same IP Address subnet to the same VLAN, i.e. assigning anything in 10.14.1.x 255.255.255.0 to VLAN 2, only IP addresses with 10.14.1.x would work in VLAN 2?

donewald Fri, 02/14/2003 - 10:53
User Badges:
  • Silver, 250 points or more

You are correct with your "DHCP to serve same ip to same VLAN" except with the ip helper (relay) you can do the following scenerio.

Say VLAN 1 = 1.1.1.0/24

VLAN1 (routed interface) 1.1.1.1/24

DHCP Server = 1.1.1.2/24

Hosts on VLAN 1 = 1.1.1.3 - 254/24 (could get DHCP address without helper/relay)

VLAN 2 = 2.2.2.0/24

VLAN 2 (routed interface) 2.2.2.1/24

No DHCP server - but an ip helper/relay on the routed interface for VLAN2 pointing to 1.1.1.2

Hosts on VLAN2 = 1.1.1.3 - 254/24 (hosts would request addr and the routers interface would bundle this request up and send it (unicast to DHCP server). The DHCP server would need an address range (Nt calls them scopes) for the VLAN2 address range.

Hope this makes more sense. Just think of VLANs as separate switches/BCAST Domains. You'll need a routing device to get from one to another.

Don

patuba Fri, 02/14/2003 - 10:59
User Badges:

Thanks for all of the help. I really appreciate it. 2 more questions if you don't mind.


1. Do you know what kind of router interface blade would work on a Catalyst 5500 switch?


2. We have 3 Catalyst 5500 switches, would they all need a router interface blade to do VLANs or would only the main swich need one?


Thanks again,


Matt

donewald Fri, 02/14/2003 - 11:04
User Badges:
  • Silver, 250 points or more

You can use an RSM in a 5500 to provide routing functions. Depending on how the catalysts were connected (FastE/Gig) you could run trunks between them and use only one RSM to provide routing functions for all.


Regards,

Don

patuba Fri, 02/14/2003 - 11:50
User Badges:

Since you are being so helpful I was wondering if you could help me with another problem?


Everyday at exactly 4:30 p.m. our WAN connection slows to a crawl for 15-30 minutes then returns to normal. There are no automated/scheduled tasks running at this time.


I have tried using a packet sniffer on the Ethernet interface of the router to monitor traffic on the router. There is no more network traffice from the LAN at 4:30 than any other time, the total packet amount on the interface is similar to other times during the day. Do you have a suggestion on something else to try to locate the slowdown? I've ran out of ideas.


Thanks for all of your help!!

donewald Fri, 02/14/2003 - 12:16
User Badges:
  • Silver, 250 points or more

You need to gather more information regarding this problem. Meaning, "whats slow??. Is it an application that is slow or any WAN destined traffic? If it's all traffic then you might have an issue with your provider (assuming this is where your WAN connection goes). They maybe be having the issue that is effecting your data. Also look at your network equipment to ensure it's not an issue with resources (e.g. Memory/etc) due to some network event going on at this time. Sorry I can't be more specific but this is a hard one to tackle without much more information.


Hope this helps,

Don

patuba Fri, 02/14/2003 - 12:37
User Badges:

It seems to effect mainly IP connections, AS/400 clients, Internet traffic, Citrix Clients. All of this traffic uses the WAN. I haven't contacted the service provider, ISP, yet.

9mmurphy Fri, 02/14/2003 - 13:46
User Badges:

Here is something to consider, without knowing more about your network.


I assume you don't have the RSM yet and therefore you have one large bridged network. You may be experiencing heavy traffic on your local LAN. Your users are starting to end their day, are backing up data across you LAN, writing files out to servers, Closing applications, etc.... Some servers may be doing some replication/backup at that time. All of these items are just some examples of local traffic that could cause you some problems with latency.


At 4:30 check your switch performance and see if you notice an increase at that time.


HTH

patuba Fri, 02/14/2003 - 13:55
User Badges:

That's good advise. We don't have Cisco Works so how would you recommend checking switch performance?

Two threads in one here so I'll respond to each in turn...

1. DHCP for VLANS.

Typical installation is you set up a DHCP SCOPE on a per VLAN basis. Ideally you set up two servers for redundancy with non-overlapping IP address assignment. The servers can be on the same segment, even one without any client such as in your server pool core. Clients issue DHCP requests and router forwards the requests to the DHCP servers by virtue of the IP HELPER command. If your edge is only Layer-2 then you would only need to put the Routing function in the Core and put the IP helper on each interface.


2 Poor performance at 4:30.

Gut tells me that your users are writing back Roaming Profiles at that time. Sounds like everybody is bailing at the same time and saving configs. Reset your interface stats at the edge and see if it is only coming in from the WAN side. Does it slow down in your head-office network or just the WAN? Don't forget to check multiple protocol stats if you are running them (IP & IPX of you are using them for Novell.)


Good luck.

hallharken Mon, 02/24/2003 - 12:16
User Badges:


Hello,


I think you mean Hosts on VLAN2 = 2.2.2.3-254/24, don't you ?


Hall

Actions

This Discussion