×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

801 with ISDN problems

Unanswered Question

Hi all,

I am having some problems with my configs for my routers, its a problem that has only recently occured and appears to be ios independant, although I can't guarantee it.

I can put the config in the router and all will work fine however if I reboot the router fails to connect. A show isdn stat says layer 2 is not activated. If I unplug and replug the isdn it works again. This has happened at at least 4 sites so the isdn supply is unlikely to be the issue, as is the actual router as I have tried 6 so far that show this problem. It usually occurs with the original IOS so I try upgrading to c800-y6-mw.122-13a.bin but this makes no difference.

I get the same issue if I use faststep as well.

I have included the config and a copy of what happens when I unplug and replug the isdn at the bottom.


I would really appreciate anyones help on this,


cheers for your time.

Andy


--------------------------------------------------------------------------------------------------------


clock set 11:12:00 25 February 2003

config t

enable password password

enable secret pencil

hostname router

boot system flash c800-y6-mw.122-13a.bin

ip subnet-zero

no ip domain-lookup

isdn switch-type basic-net3

time range

periodic daily 05:30 to 20:00

end


config terminal

map-class dialer DialClass

access-list 18 permit 192.168.2.0 0.0.0.255

access-list 121 deny udp any eq netbios-dgm any

access-list 121 deny udp any eq netbios-ns any

access-list 121 deny udp any eq netbios-ss any

access-list 121 deny tcp any eq 137 any

access-list 121 deny tcp any eq 138 any

access-list 121 deny tcp any eq 139 any

access-list 121 permit ip any any time-range TIME

dialer-list 1 protocol ip permit


interface e0

ip address 192.168.2.5 255.255.255.0

ip access-group 121 in

no ip proxy-arp

ip nat inside

no shutdown


interface bri0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap pap callin

no shutdown


int dialer1

ip address negotiated

ip access-group 121 in

no ip proxy-arp

ip nat outside

encap ppp

no ip split-horizon

dialer pool 1

dialer idle-timeout 60

dialer string telnumber class DialClass

dialer-group 1

ip nat inside source list 18 interface dialer1 overload

interface dialer1

ppp authentication chap pap callin

ppp chap hostname username

ppp chap password password

ppp pap sent-username username password password

no shut

end


config terminal

ip route 0.0.0.0 0.0.0.0 dialer1

end



--------------------------------------------------------------------------------------------------------

router#ping 158.152.1.58


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 158.152.1.58, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

router#ping 158.152.1.58


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 158.152.1.58, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

router#ping 158.152.1.58

00:01:33: BRI0 : start_t4 - timer T4 already running


00:01:33: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 64 changed to up

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Tue, 02/25/2003 - 06:04
User Badges:
  • Red, 2250 points or more

Try to add the global command:

isdn tei neg first


This might be a solution. We use this on all ISDN routers and we never have the problem you describe.


Regards,

Leo

Hi,

Thanks for the reply.

The command is slightly different on the ios I am running now "isdn tei first-call" but it didn't seem to help I still have the same problem.

I have now also found that the problem occurs like this:


Power off reboot - all works fine

Soft reboot - no outbound connection


This happens on multiple routers, and on IOS c800-y6-mw.121-17.bin, c800-y6-mw.121-18.bin, c800-y6-mw.122-13a.bin and c800-y6-mw.122-8.bin as far as I know. Im kinda stumped!


All works fine for my customers until they soft reset!


cheers

Andy

lgijssel Tue, 02/25/2003 - 11:07
User Badges:
  • Red, 2250 points or more

OK, I have another one that might apply. You are doing something with the clock, probably to allow connections only on specified times. After a soft reset, the clock settings are gone and you start again at 0:00:00. In your config the ISDN is blocked during this time, it will take until 05:30 (or 5,5 hours uptime) before the clock reaches a valid time for ISDN to activate. Did you check what happens when you change this?

To make this work, you would need to configure ntp to set the clock. The ntp source should not be on the remote side of the ISDN link, otherwise you will have long uptimes.


Leo



Actions

This Discussion