×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Immediate help on DLSW+

Unanswered Question
Feb 25th, 2003
User Badges:

Hi,


I have 2 catalyst 6006 switches with 4 msfc cards in total on my site.I need to configure dlsw+ i.my lan is ethernet and so i need to bridge the ethernet traffic to dlsw+ network.all the msfc's will work in hsrp mode for redundancy.i will be using a 3662 router as dlsw+ peer to switch packet to client router.

Now my problem is that i may need to segment my lan into 2 or more vlan's.

how will i configure my msfc to bridge the packets coming from all vlan's to the msfc and send them to my 3662 router which is a dlsw+ peer to client router.


Thanks in advance

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
thisisshanky Tue, 02/25/2003 - 09:35
User Badges:
  • Purple, 4500 points or more

Create a bridge group and assign the required vlan interfaces to the same bridge-group


bridge 1 protocol ieee

int vlan 1

bridge-group 1

int vlan 2

bridge-group 1


Now you can peer the MSFC with the 3662 using DLSW. Try using a loopback interface as the peering address, to ensure stability. Also make sure, if you use loopback, to include that network into your IGP to ensure connectivity.


To find out more on DLSW configs, visit,


http://www.cisco.com/en/US/tech/tk331/tk336/technologies_configuration_example09186a0080093ece.shtml



If you are not planning to directly peer with the client router, then your 3662 might be needed to be configured as a Border router and the MSFC and the client put as Border clients. To see sample configs, please visit,


http://www.cisco.com/en/US/tech/tk331/tk336/technologies_configuration_example09186a0080093db7.shtml


Hope this helps you!

exlservice Wed, 02/26/2003 - 08:42
User Badges:

Hi Sankar,

Thanks for ur help.But need more from you buddy.i am pasting here a sample config of one of my msfc that i framed out of the inputs you provided,with loopback interface and peer config with 3662 router.can u please see if this is ok.

interface Vlan1

ip address 10.19.1.250 255.255.255.0 alt ip address 10.19.1.251 255.255.255.0

no ip redirects

bridge-group 1

standby 1 priority 110 alt standby 1 priority 109

standby 1 ip 10.19.1.254 alt standby 1 ip 10.19.1.254

!

interface Vlan2

ip address 10.19.2.250 255.255.255.0 alt ip address 10.19.2.251 255.255.255.0

no ip redirects

bridge-group 1

standby 1 priority 108 alt standby 1 priority 107

standby 1 ip 10.19.2.254 alt standby 1 ip 10.19.2.254


interface Vlan24

ip address 10.19.24.250 255.255.255.0 alt ip address 10.19.24.251 255.255.255.0

no ip redirects

standby 1 priority 108 alt standby 1 priority 107

standby 1 ip 10.19.24.254 alt standby 1 ip 10.19.24.254


bridge 1 protocol ieee


interface loopback 0

ip address 10.19.5.250 255.255.255.0

no ip redirects


dlsw local-peer peer-id 10.19.5.250 group 10 promiscuous

dlsw remote-peer 0 tcp 10.19.24.2 (ethernet ip of my 3662 router)

dlsw bridge-group 1


I have not bridged vlan 24 here..

Please see if this config is right or i need to do something else.

Thanks & waiting for ur reply

thisisshanky Wed, 02/26/2003 - 09:30
User Badges:
  • Purple, 4500 points or more

Hi, the configs look fine. I see that you are using Border peering also. I think, if you use promiscous on the MSFC, then there is no need for a dlsw remote-peer statement towards the 3662. dlsw remote-peer statement is needed only at the 3662 router. Promiscous keyword is used to reduce the number of remote-peer statements that are required on a particular router. (Assume you had 10 routers peering to a core router. The core can be configured in promiscous mode, with no remote-peer statements on the core, but all the 10 routers will have one remote-peer statements each towards the core)


Otherwise i would say everything looks fine to me..

Actions

This Discussion