×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

3550-48(emi) communicate with inter 510t layer 2 switch

Answered Question
Mar 3rd, 2003
User Badges:

I have such network:

all client were located in inter three 510t switch ,they were be stacked together, I purchase a cisco 3550-48(emi) switch as the layer 3 switch to make the different vlan can communicate each other.the 3550_48 only as a routing switch ,all the port in 3550 only connect to the trunk group to 510t or the lan server.

how can i configue the 3550 to make the inter-vlan routing come true.

I Know how to make standard 802.1q trunk and virtual interface , but in 3550 only when the special ethernet port were added to a svi the correspond vlan can be actived, how can i do?

ex

server ip address 10.12.82.0/26

other client 10.12.82.63/26---10.12.82.254/26

another ip network 172.16.1.0/24


thanks so much for the help

Correct Answer by milan.kulik about 14 years 5 months ago

Let's say you want to route between VLAN1, VLAN2 and VLAN3.

Just configure a 802.1q trunk port and add IP addresses to interface VLAN1, interface VLAN2 and interface VLAN3.

Example:

IP routing

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,3

switchport mode trunk

switchport nonegotiate

no ip address

!

interface Vlan1

ip address 10.12.82.1 255.255.255.192

!

interface Vlan2

ip address 10.12.82.63 255.255.255.192

!

interface Vlan3

ip address 172.16.1.1 255.255.255.0


Also check with "sh vlan" and "sh int g0/1 switchport" that your VLANs and trunk port are running correctly.


Regards,

Milan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Correct Answer
milan.kulik Tue, 03/04/2003 - 01:06
User Badges:
  • Red, 2250 points or more

Let's say you want to route between VLAN1, VLAN2 and VLAN3.

Just configure a 802.1q trunk port and add IP addresses to interface VLAN1, interface VLAN2 and interface VLAN3.

Example:

IP routing

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,2,3

switchport mode trunk

switchport nonegotiate

no ip address

!

interface Vlan1

ip address 10.12.82.1 255.255.255.192

!

interface Vlan2

ip address 10.12.82.63 255.255.255.192

!

interface Vlan3

ip address 172.16.1.1 255.255.255.0


Also check with "sh vlan" and "sh int g0/1 switchport" that your VLANs and trunk port are running correctly.


Regards,

Milan

efrahim Tue, 03/04/2003 - 06:28
User Badges:
  • Cisco Employee,

just to let you know that when the vlans start forwarding on the trunk link, at that time all the vlan interfaces will be up too. For the vlan to be up, atleast have one port active in that vlan and that could be statically configured port or the trunk port.


Hope this answers your question regarding vlan svi's

Actions

This Discussion