×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

How to specify which modem to use for callback?

Unanswered Question

I am trying to setup the following on a router 2610 with two analog modems attached:


User dials in to router using modem1, service exec-callback, then the router should call back the user on modem2.


I can't figure out how to make the router use modem2 for the callback instead

of modem1, apart from the username based solution via

"username dialin callback-line 34". But I am looking for a generic solution that

applies to all users.


Can someone help?


Thank you

Dorothea



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
liviu.gheorghe Tue, 03/11/2003 - 08:39
User Badges:
  • Bronze, 100 points or more

You can configure the line for the first modem as "modem dialin" and the line for modem2 as "modem inout".

This way you can use both modems for dialin calls, but only modem2 can be used to call out.


I have done so (see below), but when I authenticate as user "callback"

the router tries to call back on line 33 (modem1). The same line that was

used for dialing in. Only when I authenticate as user "cb", who has

the "callback-line" specified it will use line 34 (modem2).


What I am looking for is a way to make the router always choose modem2

for calling back.


Here are the relevant parts of my running-config:


username callback callback-dialstring 3120 password 7 callback

username cb callback-dialstring 3120 callback-line 34 password 7 cb


interface Group-Async1

no ip address

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer rotary-group 1

async mode interactive

no peer default ip address

fair-queue 64 16 0

no cdp enable

group-range 33 33

!

interface Group-Async2

no ip address

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer rotary-group 1

async mode interactive

no peer default ip address

fair-queue 64 16 0

no cdp enable

group-range 34 34

!

interface Dialer1

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer enable-timeout 20

peer default ip address pool dialin

no cdp enable

!

ip local pool dialin 192.168.1.40


line 33

session-timeout 2

exec-timeout 2 0

script reset reset

script modem-off-hook offhook

script callback callback

login authentication dialin

modem Dialin

modem autoconfigure discovery

autocommand menu terminals

transport input all

transport output telnet

callback forced-wait 30

stopbits 1

speed 115200

flowcontrol hardware

line 34

session-timeout 2

exec-timeout 2 0

script reset reset

script modem-off-hook offhook

script callback callback

login authentication dialin

modem InOut

modem autoconfigure discovery

autocommand menu terminals

transport input all

transport output telnet

callback forced-wait 30

stopbits 1

speed 115200

flowcontrol hardware



Cheers


Dorothea

liviu.gheorghe Tue, 03/11/2003 - 09:04
User Badges:
  • Bronze, 100 points or more

This is because you configured a dialer rotary group and the router tries to call out on the first available line in a rotary group.

Remove the dialer interface and the dialer rotary-group 1 from the 2 group-async interfaces, put the 2 async lines in one Group-async interface.

One of the lines will be configured with modem dialin and the other with modem inout.

I think this will do the trick.

I am afraid not. I have tried your suggestions, see below, but when

I login as "callback" the callback is still initiated on line 33. With "debug modem" and "debug callback" I get the following:


*Mar 5 18:38:58: TTY33: DSR came up

*Mar 5 18:38:58: tty33: Modem: IDLE->(unknown)

*Mar 5 18:38:58: TTY33: EXEC creation

*Mar 5 18:38:58: TTY33: set timer type 10, 30 seconds

*Mar 5 18:39:06: TTY33: set timer type 10, 30 seconds

*Mar 5 18:39:50: TTY33 Callback process initiated, user: callback dialstring 3120

*Mar 5 18:39:58: TTY33 Callback forced wait = 30 seconds

*Mar 5 18:39:59: TTY33: DSR was dropped

*Mar 5 18:39:59: TTY33: Quickly dropping DTR

*Mar 5 18:39:59: tty33: Modem: READY->HASPROC

*Mar 5 18:39:59: TTY33 Callback process fail - modemcheck status=80010601

*Mar 5 18:39:59: TTY33: Line reset by "Callback Process"

*Mar 5 18:39:59: TTY33: Modem: HASPROC->HANGUP

*Mar 5 18:39:59: TTY33: destroy timer type 0

*Mar 5 18:39:59: TTY33: destroy timer type 1

*Mar 5 18:39:59: TTY33: destroy timer type 3

*Mar 5 18:39:59: TTY33: destroy timer type 4

*Mar 5 18:39:59: TTY33: destroy timer type 2

*Mar 5 18:40:00: TTY33: dropping DTR, hanging up

*Mar 5 18:40:00: tty33: Modem: HANGUP->IDLE

*Mar 5 18:40:05: TTY33: restoring DTR

*Mar 5 18:40:06: TTY33: autoconfigure probe started


It seems to me it tries line 33 for callback and then notices that it

is configured for dialin only.

Here is the running-config:


username callback callback-dialstring 3120 password 7 callback

username cb callback-dialstring 3120 callback-line 34 password 7 cb

!

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c

chat-script reset "" "ATH1" OK

!

!

interface Group-Async1

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

async mode interactive

peer default ip address pool dialin

fair-queue 64 16 0

no cdp enable

group-range 33 34

!

line 33

session-timeout 2

exec-timeout 2 0

script reset reset

script modem-off-hook offhook

script callback callback

login authentication dialin

modem Dialin

modem autoconfigure discovery

autocommand menu terminals

transport input all

transport output telnet

callback forced-wait 30

stopbits 1

speed 115200

flowcontrol hardware

line 34

session-timeout 2

exec-timeout 2 0

script reset reset

script modem-off-hook offhook

script callback callback

login authentication dialin

modem InOut

modem autoconfigure discovery

autocommand menu terminals

transport input all

transport output telnet

callback forced-wait 30

stopbits 1

speed 115200

flowcontrol hardware




liviu.gheorghe Thu, 03/13/2003 - 00:27
User Badges:
  • Bronze, 100 points or more

I did a test yesterday in my lab, and the result was the same like yours.

If your call is answered by line 1, the callback will be placed using the same line.

If the call is answered by line 2, then the callback will be placed using line 1, specified by username callback-line command.

I think this is either a bug or a feature.

As an workaround, if you want users calling into a line and the callback goung out the second line, give the users the phone number of the second line or swap lines.

Actions

This Discussion