×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Qos over frame-relay doesn't work fine!!!

Unanswered Question
Mar 30th, 2003
User Badges:

Dear support,


This is the configuration of the routers i use to make QOS of voice over IP to enhance the quality of voice with a heavy load of Data transfer..


2 sites linked togather with frame-relay connection 64Kbps ( h.323 voice protocol )


version 12.2 (3)


ip subnet-zero


access-list 102 permit udp any any range 5000 5075

access-list 102 permit udp any any range 16000 20000

access-list 103 permit tcp any any eq 1720

access-list 103 permit tcp any any range 16000 20000

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any range 16000 20000



class-map voip-sig

match access-group 103

class-map voip-traf

match access-group 102


policy-map voip-pol

class voip-traf

priority 12

class voip-sig

bandwidth 8

class class-default

fair-queue


interface ethernet 0

ip address 192.168.0.200 255.255.255.0


interface serial 0

bandwidth 64

no ip address

no fair-queue

encapsulation frame-relay IETF

frame-relay lmi-type cisco

frame-relay traffic-shaping


interface serila 0.1 point-to-point

ip address 10.0.0.1 255.255.255.0

frame-relay interface-dlci 16

class VOIP

frame-relay ip rtp header-compression ( it is not supported in the serial 0 !!! )


map-class frame-relay VOIP

no frame-relay adaptive shaping

frame-relay cir 64000

frame-relay bc 640

frame-relay be 0

frame-relay mincir 64000

service-policy output voip-pol

frame-relay fragment 80


line console 0

exec-timeout 10 0

line vty 0 4

login


Well , i made this configuration on both routers and also i face a problem in the voice quality , still not good !!!

the pinging time is not good ( gives a large time and request time out ... with data transfer.)


I don't know why, so i tried the QOS over PPP and it worked very nice and the voice is clear and the pinging time is steady and no request time out !!!


Please advice what's wrong in the configuration of the Frame-relay QOs...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jbayuka Fri, 04/04/2003 - 08:12
User Badges:
  • Bronze, 100 points or more

With the information that you have provided in your other posts, i understand that this config belongs to the 805 router. Correct me if i am wrong here.


I find that Modular QoS CLI (MQC) - Based Frame Relay Traffic Shaping feature is not supported on 805. May be you better replace this with some other supported model and check it.

sting712 Sat, 04/05/2003 - 13:35
User Badges:

hi , this configuration i sent to u is a test i made in my lab between two 2503 routers with IOS 12.2 (3)...and still i face problems in the quality of voice ..


And also i tested the Qos over PPP just like the example in the Qos over PPP document ( using PPP multilink and .... ) and it gives me a much better quality ..

Why is that?


Note : i went to a client that have a 805 router with 12.2(3) IOS and i found that all the Qos commands in my configuration are exisiting and can be established over his framerelay link..


Waiting for your advice..

pswarovsky Tue, 05/27/2003 - 00:15
User Badges:

I think shaping rate on dlci must be a little bit lower than the speed on the main serial interface. If you clock S0 only with 64k shaping and QoS on s0.1 works fine, but you run in a bottleneck on S0 (long delay/drops) caused by additional FR-overhead.

Actions

This Discussion