×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

1603 isdn dial problem

Unanswered Question
Apr 3rd, 2003
User Badges:

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Can anyone help, I am having problems with the isdn on a 1603 router. The config below is one i took straight out of a cisco manual so i assume it is ok, but i stll cant get the bri port to dial. I have checked the isdn line with other equipment and they are fine. i am trying to dial an adtran over isdn. All i want to see at this stage is that the cisco has dialled.

please find attached a copy of the config i have on the 1603, and an output when i try to ping ( with debug q921,931, and dialer switched on):


router config :

Router#sh run

Building configuration...


Current configuration:

!

version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

!

username cisco-b xxxxxxxx0 xxxxxxxx

isdn switch-type basic-net3

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface BRI0

ip address 10.170.0.1 255.255.0.0

encapsulation ppp

dialer idle-timeout 300

dialer map ip 10.170.0.2 name cisco-b xxxxxxxxxxxxxxxx

dialer-group 1

ppp authentication chap

!

ip classless

ip route 192.168.1.0 255.255.255.0 10.170.0.2

!

dialer-list 1 protocol ip permit

!

line con 0

line vty 0 4

login

!

end


and here is the output from a ping :

Router#ping 192.168.1.1


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:


00:35:59: BRI0: Dialing cause ip (s=10.170.0.1, d=192.168.1.1)

00:35:59: BRI0: Attempting to dial --moderator edit-- xxxxxxxxxxxx

00:35:59: ISDN BR0: TX -> IDREQ ri = 48769 ai = 127 .

00:36:01: ISDN BR0: TX -> IDREQ ri = 42642 ai = 127 .

00:36:03: ISDN BR0: TX -> IDREQ ri = 4019 ai = 127 .

00:36:05: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 255 changed to down

.

00:36:07: BRI0: wait for carrier timeout, call id=0x800A.

Success rate is 0 percent (0/5)


Any suggestions would be great. By the way the sh isdn stat shows deactivated and the bri light(s) on the cisco are not /have not lit. As i say thought the lines are good.


cheers

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
zahmed Thu, 04/03/2003 - 08:12
User Badges:
  • Cisco Employee,

Router is definitely trying to dialout but layer 2 is not coming up. Router is sending

q921 IDREQuest to get a TEI assigned by the switch, but we don't see IDASSN

(ID assign) back from the switch in response to that.


~Zulfi

oj88 Fri, 04/04/2003 - 08:35
User Badges:

"sh isdn stat" should indicate "ACTIVE" in Layer 1 and "MULTIPLE_FRAME_ESTABLISHED" in Layer 2. If either if these antries aren't there, don't bother attempting to dial, as it will definitely fail.


Also, try to clear up the BRI interface by issuing the "clear int bri0". You can also do a "shut" and "no shut" on the BRI interface to try to reset the link. Sometimes, rebooting also helps.


If that didn't work, check with your provider if you're using the correct ISDN switch-type. Also, if you're in a region that requires you to put in some SPIDs (also provided by your provider), you will need to do so using the following commands under the BRI interface config:


isdn spid1

isdn spid2


In the end, your "sh isdn stat" should look something like the following example output: (Taken from a 2600 router)


sh isdn stat

Global ISDN Switchtype = basic-ni

ISDN BRI0/0 interface

dsl 0, interface ISDN Switchtype = basic-ni

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 111, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI = 112, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

TEI 111, ces = 1, state = 5(init)

spid1 configured, spid1 sent, spid1 valid

Endpoint ID Info: epsf = 0, usid = 1, tid = 1

TEI 112, ces = 2, state = 5(init)

spid2 configured, spid2 sent, spid2 valid

Endpoint ID Info: epsf = 0, usid = 3, tid = 1

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

idj.vanderven Tue, 05/06/2003 - 05:28
User Badges:

Try the next config, might work:

Global config:

!

isdn switch-type basic-net3

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1 max-link 1

isdn switch-type basic-net3

ppp authentication chap pap callin

!

interface Dialer1

description TEST

ip address negotiated

no ip proxy-arp

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer idle-timeout 300

dialer string class DialClass

dialer hold-queue 10

dialer load-threshold 10 either

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password

!

map-class dialer DialClass

dialer-list 1 protocol ip permit


Good luck.


Rgds.


IDJ van der Ven

Actions

This Discussion