×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Voice Vlan Issue

Unanswered Question
Apr 10th, 2003
User Badges:

Hi,


We are using 2 Vlans

Vlan 1: PCs

Vlan 2: IP Telephony

Callmanager is DHCP-Server to the IP Phones.


There is Inter-VLAN Routing between the Vlans.


At the 2950 switch there is

switchport voice vlan configured on the interface.


But only the PC connected behind the Ip Phon is working OK.


Any ideas what is wrong in this case.


reg. August

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ksilva Thu, 04/10/2003 - 07:52
User Badges:

do you have the port setup as a trunk with dot1q encapsulation?

interface FastEthernet0/X

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan X

spanning-tree portfast


you might need to add in :

switchport trunk native vlan XXX

if you nativ trunk is something other than the default


don't forget QOS...

paul.harrison Thu, 04/10/2003 - 09:51
User Badges:
  • Bronze, 100 points or more

August,


Are you saying the phone isn't working but the PC is?


Is the Call manager in the same subnet as the phones? if so do not set the vlan on the switchport as the data vlan but make it the phone VLAN, because the call manager will not go into the voice Vlan on its own.



Also make sure you do not use vlan 1 for either the data or voice vlan, especially if you are putting DHCP servers into each VLAN. I've come accross problems whereby a PC booting from behind a phone will be given an address by the DHCP server for the phones, even though it's not the correct VLAN , just because the data VLAN was VLAN 1, hey set it to anything else and no problems.


Hope this helps


Paul


marinaibm Thu, 04/10/2003 - 10:33
User Badges:
  • Silver, 250 points or more

probably you didnt configure the router to forward the bootp requests from ip phones to the dhcp server in the data vlan..


interface vlan 2

ip helper-address 10.1.1.1 (your dhcp server)

asarkany Fri, 04/11/2003 - 02:46
User Badges:

Hi,


Thanks for your replies.


The solution in this case.


The port settings have to set to 100full


reg. August / NTS

asarkany Sat, 04/12/2003 - 00:12
User Badges:

No,


You can set also the CP7960/40 ip phones to 100 full. (the default is auto)

Unlock the phone and change the settings


So we set the switchport to 100full, the phone on both ports to 100full and the pc to 100 full.


We had similiar problems with the speed/duplex-settings in the past.


Phones were rebooting all time --> port settings

PC has bad performance --> port settings


August


Actions

This Discussion