×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

PPP over ISDN PRI

Unanswered Question
Apr 19th, 2003
User Badges:

Hi

I have 3660 router with E1 as PRI

the configuration is :


controller E1 4/0

pri-group timeslots 1-31

!

interface Serial4/0:15

no ip address

encapsulation ppp

dialer map ip 1.1.1.2 71869912

dialer-group 1

dialer pool-member 1

isdn switch-type primary-net5

ppp authentication chap

!

interface Dialer102

ip address 193.100.102.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer string 71000

dialer caller 71000

dialer-group 1

ppp authentication chap

ppp chap hostname xxxxx

ppp chap password *****

!

dialer-list 1 protocol ip permit


when i tried to callin to this router the connection didn't came up the debugging of ppp negotiation demonstrate that only the LCP is came up and no NCP negotiation.

the soft version is : 12.2(16)

can any one help me ? the probleme is in this router because i tried the other router work properly, i tested it with a third router.

THX

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hweiwoo Sat, 04/19/2003 - 04:14
User Badges:

as you say ,the 3 layer aren't negotiation..

interface dialer [num] must be same to dialer pool-member [num]

tepatel Sat, 04/19/2003 - 09:03
User Badges:
  • Cisco Employee,

You have configured the dialer-map (lagacy way) and the dialer profile (using dialer pool) togather and that surely massed up the config. Now youneed to decide which method you want to use, dialer-map or dialer profile.


The dialin call may not have connected properly because of the "dialer remote-name "is missing fromthe config under the interface dialer 102. Also "dialer caller and dialer string" which is the same number.You might want to remove dialer caller 71000.


Pl. visit following url for configuring and troubleshooting dialer profile

http://www.cisco.com/warp/public/129/23.html


aybra Sun, 04/20/2003 - 23:29
User Badges:

Hi

Thanks for the reply

sorry the config that i possted is wrong there aren't the dialer map,

i tried with the tow possibility, with dialer map and without and didn't work

also i tried with " dialer remote-name " and the same case

with debug i see that the router bound the call with the dialer interface 102 and negociate LCP and authentification only then the call stay connected for 180s then it get down, it didn't try to negociate NCP.

Please it's so urgent and with important castumer, it's bank

thanks for your help

rjackson Mon, 04/21/2003 - 06:03
User Badges:
  • Bronze, 100 points or more

So what does the 3640 really look like and what does the config on the other side look like?

aybra Mon, 04/21/2003 - 06:24
User Badges:

Hi Thanks for the reply

the others side is OK because i tested them with my second router and they work fine so the problem is in the Cisco 3660.

the other side is configured with simple dialer over BRI

thx

tepatel Mon, 04/21/2003 - 08:16
User Badges:
  • Cisco Employee,

Need to see the current running config from 3600 side "receiving the call" with the following debug to see that is going on.


debug isdn q931

debug dialer

debug ppp nego

debug ppp auth

aybra Tue, 04/22/2003 - 01:30
User Badges:

Hi the debug that you demand are :

tunrtc13#show debugging

Dial on demand:

Dial on demand events debugging is on

PPP:

PPP authentication debugging is on

PPP protocol negotiation debugging is on

ISDN:

ISDN Q921 packets debugging is on

ISDN Q931 packets debugging is on

ISDN Q921 packets debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

DSL 32 --> 47

- - - - - - - - - - - - - - - -

ISDN Q931 packets debug DSLs. (On/Off/No DSL:1/0/-)

DSL 0 --> 31

1 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

DSL 32 --> 47

- - - - - - - - - - - - - - - -

tunrtc13#ping 1.1.1.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 1.1.1.2, timeout is 2 seconds:

*Mar 4 14:54:43.922: Se4/0:15 DDR: rotor dialout [best] least recent failure is

also most recent failure

*Mar 4 14:54:43.922: Se4/0:15 DDR: rotor dialout [best] trying untried dialout

*Mar 4 14:54:43.922: Se4/0:15 DDR: rotor dialout [best] also has most recent failure

*Mar 4 14:54:43.922: Se4/0:15 DDR: rotor dialout [best]

*Mar 4 14:54:43.922: Se4/0:15 DDR: Dialing cause ip (s=1.1.1.1, d=1.1.1.2)

*Mar 4 14:54:43.926: Se4/0:15 DDR: Attempting to dial 710000

*Mar 4 14:54:43.926: ISDN Se4/0:15: TX -> INFOc sapi=0 tei=0 ns=11 nr=120 i=0x0802002105040288901803A9839F7009813731383639393132

*Mar 4 14:54:43.926: SETUP pd = 8 callref = 0x0021

*Mar 4 14:54:43.926: Bearer Capability i = 0x8890

*Mar 4 14:54:43.926: Channel ID i = 0xA9839F

*Mar 4 14:54:43.926: Called Party Number i = 0x81, '71869912', Plan:ISD

N, Type:Unknown

*Mar 4 14:54:43.938: ISDN Se4/0:15: RX <- RRr sapi=0 tei=0 nr=12

*Mar 4 14:54:43.958: ISDN Se4/0:15: RX <- INFOc sapi=0 tei=0 ns=120 nr=12 i=0x080280210D1803A9839F

*Mar 4 14:54:43.958: SETUP_ACK pd = 8 callref = 0x8021

*Mar 4 14:54:43.958: Channel ID i = 0xA9839F

*Mar 4 14:54:43.958: ISDN Se4/0:15: TX -> RRr sapi=0 tei=0 nr=121

*Mar 4 14:54:44.578: ISDN Se4/0:15: RX <- INFOc sapi=0 tei=0 ns=121 nr=12 i=0x080280210729050304160A09

*Mar 4 14:54:44.578: CONNECT pd = 8 callref = 0x8021

*Mar 4 14:54:44.578: Date/Time i = 0x0304160A09

*Mar 4 14:54:44.578: ISDN Se4/0:15: TX -> RRr sapi=0 tei=0 nr=122

*Mar 4 14:54:44.606: %LINK-3-UPDOWN: Interface Serial4/0:30, changed state to up

*Mar 4 14:54:44.606: Se4/0:30: interface must be fifo queue, force fifo

*Mar 4 14:54:44.610: %DIALER-6-BIND: Interface Se4/0:30 bound to profile Di106

*Mar 4 14:54:44.610: Se4/0:30 PPP: Using dialer call direction

*Mar 4 14:54:44.610: Se4/0:30 PPP: Treating connection as a callout

*Mar 4 14:54:44.610: Se4/0:30 PPP: Phase is ESTABLISHING, Active Open [0 sess,0 load]

*Mar 4 14:54:44.610: Se4/0:30 LCP: O CONFREQ [Closed] id 67 len 15

*Mar 4 14:54:44.610: Se4/0:30 LCP: AuthProto CHAP (0x0305C22305)

*Mar 4 14:54:44.610: Se4/0:30 LCP: MagicNumber 0x1C2305D8 (0x05061C2305D8)

*Mar 4 14:54:44.610: ISDN Se4/0:15: TX -> INFOc sapi=0 tei=0 ns=12 nr=122 i=0x080200210F

*Mar 4 14:54:44.610: CONNECT_ACK pd = 8 callref = 0x0021

*Mar 4 14:54:44.618: ISDN Se4/0:15: RX <- RRr sapi=0 tei=0 nr=13

*Mar 4 14:54:44.626: Se4/0:30 LCP: I CONFACK [REQsent] id 67 len 15

*Mar 4 14:54:44.626: Se4/0:30 LCP: AuthProto CHAP (0x0305C22305)

*Mar 4 14:54:44.626: Se4/0:30 LCP: MagicNumber 0x1C2305D8 (0x05061C2305D8)

*Mar 4 14:54:45.322: Se4/0:30 LCP: I CONFREQ [ACKrcvd] id 1 len 32

*Mar 4 14:54:45.322: Se4/0:30 LCP: MRRU 1590 (0x11040636)

*Mar 4 14:54:45.322: Se4/0:30 LCP: EndpointDisc 3 0100.a2ff.2541 (0x1309030100A2FF2541)

*Mar 4 14:54:45.322: Se4/0:30 LCP: AuthProto CHAP (0x0305C22305)

*Mar 4 14:54:45.322: Se4/0:30 LCP: MagicNumber 0xA3A92671 (0x0506A3A92671)

*Mar 4 14:54:45.322: Se4/0:30 LCP: LinkDiscriminator 4448 (0x17041160)

*Mar 4 14:54:45.322: Se4/0:30 LCP: O CONFREJ [ACKrcvd] id 1 len 12

*Mar 4 14:54:45.322: Se4/0:30 LCP: MRRU 1590 (0x11040636)

*Mar 4 14:54:45.322: Se4/0:30 LCP: LinkDiscriminator 4448 (0x17041160)

*Mar 4 14:54:45.338: Se4/0:30 LCP: I CONFREQ [ACKrcvd] id 2 len 28

*Mar 4 14:54:45.338: Se4/0:30 LCP: MRU 1590 (0x01040636)

*Mar 4 14:54:45.338: Se4/0:30 LCP: EndpointDisc 3 0100.a2ff.2541 (0x1309030100A2FF2541)

*Mar 4 14:54:45.338: Se4/0:30 LCP: AuthProto CHAP (0x0305C22305)

*Mar 4 14:54:45.338: Se4/0:30 LCP: MagicNumber 0xA3A92671 (0x0506A3A92671)

*Mar 4 14:54:45.338: Se4/0:30 LCP: O CONFACK [ACKrcvd] id 2 len 28

*Mar 4 14:54:45.338: Se4/0:30 LCP: MRU 1590 (0x01040636)

*Mar 4 14:54:45.342: Se4/0:30 LCP: EndpointDisc 3 0100.a2ff.2541 (0x1309030100A2FF2541)

*Mar 4 14:54:45.342: Se4/0:30 LCP: AuthProto CHAP (0x0305C22305)

*Mar 4 14:54:45.342: Se4/0:30 LCP: MagicNumber 0xA3A92671 (0x0506A3A92671)

*Mar 4 14:54:45.342: Se4/0:30 LCP: State is Open

*Mar 4 14:54:45.342: Se4/0:30 PPP: Phase is AUTHENTICATING, by both [0 sess, 0load]

*Mar 4 14:54:45.342: Se4/0:30 CHAP: Using alternate hostname XXXX

*Mar 4 14:54:45.342: Se4/0:30 CHAP: O CHALLENGE id 56 len 30 from "XXXX"

*Mar 4 14:54:45.374: Se4/0:30 CHAP: I CHALLENGE id 1 len 30 from "XXXX".

*Mar 4 14:54:45.374: Se4/0:30 CHAP: Using alternate hostname XXXX

*Mar 4 14:54:45.374: Se4/0:30 CHAP: Ignoring Challenge with local name

*Mar 4 14:54:45.378: Se4/0:30 CHAP: I RESPONSE id 56 len 30 from "XXXX"

*Mar 4 14:54:45.378: Se4/0:30 CHAP: O SUCCESS id 56 len 4...

*Mar 4 14:54:50.610: %ISDN-6-CONNECT: Interface Serial4/0:30 is now connected to 710000 XXXX.

Success rate is 0 percent (0/5)



the config is :

interface Serial4/0:15

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

isdn switch-type primary-net5

no cdp enable

ppp authentication chap

!

interface Dialer106

ip address 1.1.1.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name XXXX

dialer string 710000

dialer caller 710000

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication chap

ppp chap hostname XXXX

ppp chap password 7 ****

!

dialer-list 1 protocol ip permit



tepatel Tue, 04/22/2003 - 08:31
User Badges:
  • Cisco Employee,

You have collectd the debug from the router which is calling out or dialing out. We need to see the debug and config from the router which is "receiving the call" as per


Mar 4 14:54:44.610: Se4/0:30 PPP: Treating connection as a callout


Also pl. leave the hostnames in the debug as it is so that we can see the router is binding the call properly or not.


Or open a tac case by logging at "www.cisco.com/tac"

Actions

This Discussion