OSPF:default information originate

Unanswered Question

Hi,


I've two areas area 100 & area 200.


area 100 -> ABR for area 100 -> ABR for area 200<-area 200


I just want ABRs to advertise "default-information always" to thier respective areas. But when I say "default information originate always" in the ABR-100. The same also reflected in the ABR-200.


How should I get rid of the problem?


Assuming ABR-100 advertise 20.1.192.0/19 subnet and ABR-200 advertise 20.1.128.0/19 among themselves. ABR-200 is default router for the area-200 & ABR-100 is default router for area 100.


I understand route-map option in the command


"default-information originate route-map always"


can be configured to address the issue in the,but some how I'm doing mistake in configuring the route-map.


Any suggestions ?


Thanks





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rjackson Mon, 04/21/2003 - 07:36
User Badges:
  • Bronze, 100 points or more

I think you want to configure each router in the areas as a stub.



"area 200 stub" in each router in area 200. On the abr it should be

"area 200 stub no-summary" to cut it down to just the default.


Remove the defaultinfo orignate stuff.

m.gamal Tue, 04/22/2003 - 00:34
User Badges:

Sir

sorry to tell u that i didn't understand what exactly do u want to do.?

and if u plz provide me with more info about..if there is area 0 between your two areas or not..??

why you want to use route map.

if you want the default to propagate throught your domain, then what you have done is right..

can you please expalin??


Thanks

Hi,


I resolved the issue by defining the areas as nssa, however I would like to know the significance of "route-map" in the command

"default-information originate route-map always".


So that I guess the same function shall be implemented with route-map.


Now let me explain the scenario.Assume I have two areas and they have respective ABRs (ofcourse they too ASBRs running BGP).


Every area has thier own internation gateway, so it is not required area 200 to use the gateway of area 100 .


Prior defining the areas as nssa if I say "default-information originate always" at my ABR-100 , ABR-200 also takes the ABR-100 as its default gateway.

I want to get rid of this, IS THAT POSSIBLE TO ADDRESS THIS WITH THE "ROUTE-MAP OPTION" in the command


"default-information originate route-map always"


Here the config details removed the ospf nssa definition of 300,400:


!

abr_asbr_area100#

!

router ospf 9829

network 300 range 10.1.192.0 255.255.255.224.0

network 20.0.224.192 0.0.0.3 area 0

network 20.0.231.132 0.0.0.3 area 300

network 20.1.192.64 0.0.0.63 area 300

network 202.54.66.192 0.0.0.3 area 300

!

!

router bgp 100

network 20.1.192.0 mask 255.255.192.0

neighbor 202.54.66.194 remote-as 200

!

ip route 20.1.192.0 255.255.192.0 null 0




!


abr_asbr_area200#

!

router ospf 9830

network 400 range 30.1.192.0 255.255.255.224.0

network 30.0.224.192 0.0.0.3 area 0

network 30.0.231.132 0.0.0.3 area 400

network 30.1.192.64 0.0.0.63 area 400

network 203.54.66.192 0.0.0.3 area 400

!

!

router bgp 200

network 30.1.192.0 mask 255.255.192.0

neighbor 203.54.66.194 remote-as 100

!

ip route 30.1.192.0 255.255.192.0 null 0



Hope this helps


Dinesh


rjackson Tue, 04/22/2003 - 05:24
User Badges:
  • Bronze, 100 points or more

This gets confusing because route-maps are showing up everywhere these days. However, I believe that when used this way the route map is being used for its original purpose. That is it filters routes from advertisements, it does not control where those advertisements go. That is to say that if you had multiple default routes but only want the default orignate command to advetised a subset of them this route map would filter out the ones that should not be advertised. They will still get advertised out all interfaces that run ospf.


If anyone has a good summary of the different ways route maps are used I'd like to see it.

Actions

This Discussion