3550 voice vlan config again

Unanswered Question
Apr 26th, 2003
User Badges:

Hi All,


I had saw some post about 3550 voice vlan in this forum. Many people said that the voice vlan just can be configured in trunk mode as follow:


int f0/1

mls qos trust cos

switchport trunk encap dot1q

switchport mode trunk

switchport trunk native vlan 1

switchport voice vlan 100


But in the manual of 3550, the manual said the voice vlan just can be configured in " access port " and the port that configured with voice vlan can use dot1x authentication. And dot1x authentication just can be configured in the ports that explicitly config " switchport mode access" command. And I had saw some training material ( but not cisco's, like IPexpert and some others), I had saw some samples that they config voice vlan as follow:


int f0/1

switchport mode access

mls qos trust cos

switchport voice vlan 100


so that make me confused. many people said second sample ( that use "switchport mode access") is wrong because when you use " switchport mode access" , the port can not accept the 802.1q tag, so the port can not recoginze the traffic is data or voice. That's also reasonable. So, I am really very confuse. Hope the experience can give me a hand. Thank you!


Waimen



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
davidcooper Mon, 04/28/2003 - 11:27
User Badges:

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12113ea1/3550scg/sw8021x.htm#50544


802.1X is configured independantly of Voice-VLAN. The documentation states that the operation in 802.1X mode is a bit different, in that the voice vlan will be in a down state until it receives CDP from the IP Phone. The 802.1X applies primarily to the device behind the IP Phone. You configure the voice VLAN per normal using 'switchport voice vlan'. Don't forget QoS.

andrew.butterworth Wed, 01/14/2004 - 10:55
User Badges:
  • Gold, 750 points or more

With the 3550 you don't need to set ports that connect to Cisco IP Phones as 802.1q trunks. If you enable a Voice VLAN this is signalled to the phone through CDP, the switch accepts frames tagged with the Voice VLAN ID. The access vlan will be used for the attached PC and dot1x will operate on this. The config below is from a working switch:


interface FastEthernet0/2

switchport access vlan 99

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 99,199

switchport mode access

switchport voice vlan 199

no ip address



Andy

Actions

This Discussion