×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DIAL-IN and Site-to-Site ISDN with one PRI

Unanswered Question
Jun 26th, 2003
User Badges:

Hello,


I have the following config on my PRI Interface:


interface Serial1/0:15

ip address 192.168.0.1 255.255.255.0

ip helper-address 172.22.22.1

encapsulation ppp

dialer idle-timeout 180

dialer wait-for-carrier-time 60

dialer map ip 192.168.0.11 name router1 12345

dialer map ip 192.168.0.21 name router2 98764

dialer map ip 192.168.0.22 name router3 462842

dialer-group 1

isdn switch-type primary-net5

peer default ip address dhcp

compress stac

ppp callback accept

ppp authentication chap pap

!

ip route 10.100.100.0 255.255.255.0 192.168.0.11

ip route 10.100.101.0 255.255.255.0 192.168.0.21

ip route 10.100.102.0 255.255.255.0 192.168.0.22


People can Dial in With ther PC an ISDN Card and get an IP Adress from the DHCP-Server from the pool 192.168.0.200 to 192.168.0.230.


Teh three Router are Cisco 801 and can build up a Dial Connection to the router.


I want to configure the Router links with a small network:


192.168.1.0; 192.168.1.4 and 192.168.1.8


The RAS User will still in future use the Pool 192.168.0.0


I have tried to use the config:


interface Serial1/0:15

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type primary-net5

ppp authentication chap pap

!

interface Dialer 1

ip address 192.168.0.1 255.255.255.0

ip helper-address 172.22.22.1

encapsulation ppp

dialer idle-timeout 180

dialer pool 1

dialer-group 1

peer default ip address dhcp

ppp callback accept

ppp authentication chap pap

!

interface Dialer 2

description Router 1

ip address 192.168.1.1 255.255.255.252

encapsulation ppp

dialer idle-timeout 180

dialer pool 1

dialer-group 1

dialer remote name Router1

dialer string 12345

ppp authentication chap callin

!

ip route 10.100.100.0 255.255.255.0 192.168.1.2


If I use this config only the Dialer 2 for the Site-to-Site connection works.


If I delete the Dialer 2 ant there is only one Dialer in the Dialer Pool 1 the Dialer 1 for Dial In works.


Can anybody help me with this problem?


Is there maybe a other solution to solve this problem?


Thanks for your help!!!!!!!


Best regards


Peer



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
makchitale Thu, 06/26/2003 - 18:23
User Badges:
  • Silver, 250 points or more

1)When using dialer profiles, dynamic binding of call to the correct dialer interface is critical or else the call will fail....


2)Within Dialer Profile, there is no method to configure a generic dialer profile (or even a default profile) for a group of users that share the same characteristics. Each user must have its own profile.


Depending on the number of dialin users, we can use combination of virtual profiles (for dialin) & dialer profiles (for dial out).....unless we want to create multiple dialer interfaces for each dialin user.


For you setup to work please refer to (your exact requirement)

http://www.cisco.com/warp/public/793/access_dial/pri_dialin_6435.html

NOTE: In the above for dialin, the binding can be done based on "dialer remote-name xxx" or "dialer caller" or "dialer called"


For info on Virtual-Profiles:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/vprof.htm


For more info on dialer-Profiles:

http://www.cisco.com/warp/public/129/23.html


Thanks, Mak.



pkohlstetter Sun, 06/29/2003 - 08:05
User Badges:

I have tried to find some informations about Virtual-Profiles and i have read the page "Info on Virtual-Profiles".


But I have no idea how to configure virtual profiles for dial in.


Can you give me an sample config or a webpage with this info.


Thanks

makchitale Sun, 06/29/2003 - 09:19
User Badges:
  • Silver, 250 points or more

Create a virtual-template interface so that a dynamic virtual access interface is cloned/ created for every new dialup call....


virtual-profile virtual-template 1 <==global command


interface virtual-template 1

ip unnumbered ethernet 0 or loopback0

encapsulation ppp

ppp authentication chap


NOTE: this holds good if we are going to apply common configs to each dynamically created virtual-access interface, however if we need different values (say like idle timeout for different users) then we need to go with dialer profiles.


http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fdial_c/fnsprt8/dafvrtmp.htm

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/dial_c/dcvprof.htm


Thanks, Mak.

pkohlstetter Sun, 06/29/2003 - 22:55
User Badges:

I have tried to build a virtual-template Config with my Test-Router cisco 1720.


But I can not dialin with the virtual template. I try to get a connection from my PC with the User koli. But the call is not accepted.


The command "encapsulation ppp" is configured on Interface virtual-template 1 but it is not shown. Is this ok or iss this a bug.


Can anybody find the problem in this config?


Building configuration...


Current configuration : 1815 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname blue

!

aaa new-model

aaa authentication ppp default local

aaa authorization network default local

enable secret xxx

!

username koli password 0 xxxx

memory-size iomem 25

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

virtual-profile virtual-template 1

isdn switch-type basic-net3

!

!

!

!

!

!

interface Loopback10

ip address 192.168.200.1 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface BRI0

description BRI

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

isdn switch-type basic-net3

!

interface FastEthernet0

description LAN Test

ip address 10.100.100.61 255.255.255.0

speed auto

!

interface Virtual-Template1

ip unnumbered Loopback10

no peer default ip address

ppp authentication chap

!

interface Dialer1

ip address 192.168.100.1 255.255.255.0

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer-group 1

peer default ip address pool blue

ppp authentication chap ms-chap callin

!

interface Dialer5

ip address 192.168.250.1 255.255.255.0

encapsulation ppp

dialer pool 1

ppp authentication chap

!

ip local pool blue 192.168.100.100 192.168.100.110

ip local pool blue2 192.168.200.100 192.168.200.110

ip classless

ip route 192.168.100.0 255.255.255.0 Dialer1

no ip http server

ip pim bidir-enable

!

access-list 115 remark Tarffic VPN

access-list 115 permit ip 192.168.118.0 0.0.0.255 any

access-list 115 deny ip any any

access-list 116 permit ip 10.100.100.0 0.0.0.255 any

access-list 116 deny ip any any

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password xxx

!



Actions

This Discussion