×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Remote Site Issue With Redistributed Static Routes

Answered Question
Jul 1st, 2003
User Badges:

I am having a problem with my remote site utilizing the static routes from my main site (both are 7204VXR). I am using OSPF and statics and believe the issue lies with my remote site seeing my main site as a type E2 as well as the static addresses. I have no problem at all with the static addresses at my main site. I know this is probably a very easy issue, it is just one that I am stuck on at this point. Here are excerpts from the configs:


Main Site:

interface Serial1/0:0

description P2P Channel 0

bandwidth 1536

ip address 10.236.176.6 255.255.255.252

ip ospf network point-to-point

ip ospf cost 65

!

interface FastEthernet2/0

ip address 10.236.144.17 255.255.255.240

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

redistribute static subnets

passive-interface FastEthernet2/0

network 10.236.0.0 0.0.255.255 area 0.0.0.0

!

ip classless

ip route 10.0.0.0 255.0.0.0 10.236.144.18

ip route 10.0.0.0 255.0.0.0 10.236.144.19

ip route 162.2.0.0 255.255.0.0 10.236.144.18

ip route 162.2.0.0 255.255.0.0 10.236.144.19

ip route 172.20.100.0 255.255.255.0 10.236.144.18

ip route 172.20.100.0 255.255.255.0 10.236.144.19

ip route 172.28.0.0 255.255.255.0 10.236.144.18

ip route 172.28.0.0 255.255.255.0 10.236.144.19

ip route 192.168.0.0 255.255.0.0 10.236.144.18

ip route 192.168.0.0 255.255.0.0 10.236.144.19

no ip http server

ip ospf name-lookup

ip pim bidir-enable

!


Remote site:

interface Serial1/0:0

description PPP Channel 0

bandwidth 1536

ip address 10.236.176.5 255.255.255.252

ip ospf network point-to-point

ip ospf cost 65

!

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

redistribute static subnets

network 10.236.0.0 0.0.255.255 area 0.0.0.0

!

ip classless

no ip http server

ip ospf name-lookup

ip pim bidir-enable

!

Correct Answer by deilert about 14 years 1 month ago

These ip addresses are all on the same subnet , if you can ping 17 & 20 it proves that your routing is working , where are you trying to ping thses hosts from ? maybe there is no way back to your source from the client router .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
deilert Tue, 07/01/2003 - 12:01
User Badges:
  • Silver, 250 points or more

When you are redistributing your static routes you are not specifying a metric, If you specify a metric in your redistribution command the static will become less attactive .


redistribute static metric XX metric-type 1 subnets


a metric type of E2 , does not pass the cost of every hop along the way. A metric of 1 will include the costs of all the hops .


Since you did not specify the metric-type , the default E2 is used

OSPF by default uses 20 as the cost when a default metric is not secified for all routes except BGP this is given a 1 .

tstriegel Wed, 07/02/2003 - 08:55
User Badges:

I apologize for not giving more information regarding my issue. Originally I was using the line


redistribute static metric 10 metric-type 1 subnets


but I had no luck with that so I reverted to the redistribute static subnets. I tried this line again and still no luck but let me explain furter: 144.17 connects to a switch (.144.20), which has a four port VLAN for these connections. My router connects with .17, my client's routers are .18 and .19. From my main router I can get to the .18 and .19 through .17 as well as all static route conenctions but from my remote router, I can only ping .17 and .20. I cannot get to .18, .19 or any of the static routes.

Correct Answer
deilert Wed, 07/02/2003 - 09:03
User Badges:
  • Silver, 250 points or more

These ip addresses are all on the same subnet , if you can ping 17 & 20 it proves that your routing is working , where are you trying to ping thses hosts from ? maybe there is no way back to your source from the client router .

mark-obrien Wed, 07/02/2003 - 11:03
User Badges:
  • Bronze, 100 points or more

Do your client's routers have static routes for your remote router, i.e., the 10.236.176.4/30 address? If not, they will not be able to reach your remote router.


Mark

tstriegel Wed, 07/02/2003 - 13:43
User Badges:

All I can say is duh! I set this up in my test environment (this is currently working with Nortel equipment in my production environment, which I am replacing), and I can't beleive I did not think of this. I ended up making a routed port my "client router" and had the same issue. As soon as I put a static route on that "client router" all my internal statics worked for the remote site.


In case you wanted to know how this has been working in my production environment, the requests are going out from the remote site, through my site to the client, then sent from the client back through another remote site with a direct connection to the initial remote site. I will have this changed very soon.


I just wanted to thank you all for your help. I had been ripping my hair out on this one.

mark-obrien Tue, 07/01/2003 - 15:50
User Badges:
  • Bronze, 100 points or more

What do you mean by problems with the remote site "utilizing the static routes"

from the main site? Are these routes in your routing table? Are they in your OSPF database? Are you just not able to ping hosts that take those routes? Please explain further.


Mark

ruwhite Tue, 07/01/2003 - 16:49
User Badges:
  • Gold, 750 points or more

configure default-metric 10 under router ospf is my first guess. If it still doesn't work, then we'll probably need a show ip ospf data external from the router doing the redistribution.


Russ.W

Actions

This Discussion