Can anyone look at my output and tell me why my Terminal Server not serving

Answered Question
Jul 7th, 2003
User Badges:

I'm wondering if its because I don't have enough mem. but not for sure


#show ver

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-D-L), Version 12.0(5)T, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Fri 23-Jul-99 03:53 by kpma

Image text-base: 0x03043078, data-base: 0x00001000


ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFT

WARE (fc1)


HQ_Qu_TS uptime is 55 minutes

System returned to ROM by power-on

System image file is "flash:c2500-d-l.120-5.T.bin"


cisco 2509 (68030) processor (revision M) with 2048K/2048K bytes of memory.

Processor board ID 09298124, with hardware revision 00000000

Bridging software.

X.25 software, Version 3.0.0.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

8 terminal line(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102


HQ_Qu_TS#show run a telnet connect

Building configuration...


Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname HQ_Qu_TS

!

!

!

!

!

!

ip subnet-zero

ip host Bronx_SW1 2005 5.5.5.5

ip host Frame_FS1 2004 4.4.4.4

ip host Brooklyn_R1 2003 3.3.3.3

ip host Bronx_R1 2002 2.2.2.2

!

!

!process-max-time 200

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

no ip directed-broadcast

!

interface Ethernet0

ip address 192.168.10.1 255.255.255.0

no ip directed-broadcast

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

ip classless

no ip http server


line con 0

transport input none

line 1 8

no exec

transport input all

line aux 0

line vty 0 4

login

!

end



Q_Qu_TS#telnet 2.2.2.2 2002

Trying 2.2.2.2, 2002 ...

% Destination unreachable; gateway or host down


HQ_Qu_TS#telnet 3.3.3.3 2003

Trying 3.3.3.3, 2003 ...

% Destination unreachable; gateway or host down


HQ_Qu_TS#

Correct Answer by deilert about 14 years 1 month ago

enter this


ip host Bronx_R1 1.1.1.1 2002

Correct Answer by frejac about 14 years 1 month ago

The ip-address that you should enter is the loopback of the terminal server. not the target router.


(Meaning that you should use 1.1.1.1)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
frejac Mon, 07/07/2003 - 08:58
User Badges:

1st: where are the ip-adresses 2.2.2.2 and 3.3.3.3? Didnt you mean to point them to 1.1.1.1?

2nd: do a show line and see what it says regarding speed and bits. I suppose the "no exec" may do something negative for you, but I dont remember right now.


a.ford Mon, 07/07/2003 - 09:19
User Badges:

The ip addresses are the loopbacks of the other routers (2x-2503, 1x4500)


the no exec keeps the system from spawning an exec process which ocupys the line making it inaccessible.


HQ_Qu_TS#show line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

* 0 CTY - - - - - 0 0 0/0 -

1 TTY 9600/9600 - - - - - 0 0 0/0 -

2 TTY 9600/9600 - - - - - 0 9 0/0 -

3 TTY 9600/9600 - - - - - 0 0 0/0 -

4 TTY 9600/9600 - - - - - 0 0 0/0 -

5 TTY 9600/9600 - - - - - 0 0 0/0 -

6 TTY 9600/9600 - - - - - 0 0 0/0 -

7 TTY 9600/9600 - - - - - 0 0 0/0 -

8 TTY 9600/9600 - - - - - 0 0 0/0 -

9 AUX 9600/9600 - - - - - 0 0 0/0 -

10 VTY - - - - - 0 0 0/0 -

11 VTY - - - - - 0 0 0/0 -

12 VTY - - - - - 0 0 0/0 -

13 VTY - - - - - 0 0 0/0 -

14 VTY - - - - - 0 0 0/0 -

deilert Mon, 07/07/2003 - 09:36
User Badges:
  • Silver, 250 points or more

you do not need the ip addresses of the loopbacks in your ip host statement . just the async line that is connected to that box .

i.e.ip host Bronx_SW1 1.1.1.1 2005



you can also add menu statements


ip host myport x.x.x.x (loopback address of router )


menu tty title ^C


Type a number to select a device

^C

menu tty text 1 connection to router 1

menu tty command 1 telnet myport 2001

menu tty text 2 connection to router 2

menu tty command 2 telnet myport 2002

menu tty text 10 EXIT the menu

menu tty command 10 menu-exit

menu tty clear-screen


a.ford Mon, 07/07/2003 - 10:09
User Badges:

It won't allow me to just enter the line number (see below)


HQ_Qu_TS#config t


HQ_Qu_TS(config)#no ip host Bronx_R1 2002 2.2.2.2

HQ_Qu_TS(config)#ip host Bronx_R1 2002

% Incomplete command.


HQ_Qu_TS(config)#

Correct Answer
frejac Mon, 07/07/2003 - 10:12
User Badges:

The ip-address that you should enter is the loopback of the terminal server. not the target router.


(Meaning that you should use 1.1.1.1)

a.ford Mon, 07/07/2003 - 10:21
User Badges:

Dayum, ol doppie me. it worked. I had a 2509 a few years ago, and could've sworn I did it like with the loopback of the other router. \


Thanks folks.



Correct Answer
deilert Mon, 07/07/2003 - 10:15
User Badges:
  • Silver, 250 points or more

enter this


ip host Bronx_R1 1.1.1.1 2002

Actions

This Discussion