×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Connecting two 1751 w/serial interfaces

Answered Question

I am attempting to connect to 1751 routers w/serial interfaces via t1 line. Router "A" (host side) is identical to router "B" remote side. I want to keep them on the same subnet for simplicity purposes. I have performed this feat with csu/dsu modules in the past, but never with serial interfaces. Host side has an internet gateway seperate from the router itself - which the remote side will need access to also. For the life of me I cannot figure out what I am doing wrong. This is the configuration from router "A", router "B's" configuration is identical except for the BVI 1 IP address is x.x.x.22 instead of x.x.x.21. Any help is greatly appreciated.


Using 876 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco1

!

enable password xxxx

!

memory-size iomem 25

ip subnet-zero

no ip domain lookup

!

!

!

bridge irb

!

!

interface FastEthernet0/0

description connected to EthernetLAN_1

no ip address

no keepalive

speed auto

bridge-group 1

!

interface Serial0/0

description connected to CiscoB

ip unnumbered FastEthernet0/0

bridge-group 1

!

interface BVI1

ip address 192.168.0.21 255.255.255.0

!

router rip

version 2

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

bridge 1 protocol ieee

!

line con 0

exec-timeout 0 0

password xxxx

login

line aux 0

line vty 0 4

password xxxx

login

!

no scheduler allocate

end


Correct Answer by deilert about 14 years 1 month ago

the config looks ok , what about the B router config ? ALso did you find out who is providing clock ? "Find out from the telco . Also who owns the Csu's , like I said before either one of the cs's or the telco is going to have to supply clock.

Correct Answer by deilert about 14 years 1 month ago

can you paste in sh controllers & sh int serial x & sh run from cisco b , also I am not sure that you can use ip unnumbered f0/0, f0/0 has no ip address , you may have to use ip unnumbered bvi 1


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
steven-dunn Tue, 07/08/2003 - 16:37
User Badges:

How far do you get ?

Does the line come up ?

Can you ping the remote end ?

Can you see the CDP neighbour ?


I can't ping the remote or router "B" from the host router ("A"). Everything is coming up on the host side ("A"), but on the remote("B") side the BVI 1 goes down - states "no active members" - that inturn takes down int fe0/0. Since I have two different telcoms involved, I have just switched from HDLC protocol to PPP. I was hoping that might have something to do with it.

deilert Wed, 07/09/2003 - 03:21
User Badges:
  • Silver, 250 points or more

Can you paste in a sh controllers serial x from both sides , also a sh int serial x from both sides , I beleive the problem is you are not providing clock , The serial interface that has a DCE cable attached has to have a clock rate configured

Here is the serial, I will paste the other shortly. Both serial int are identical. I can get the line up but the protocol keeps going down. I have to confess that this is the first serial interface I've setup, usually end up using the csu/dsu modules - I think I am overlooking something simple here. Thanks for the help. Just FYI - I have tried different encapsulations for kicks/grins - to no avail.


show interface serial0/0

Serial0/0 is up, line protocol is down

Hardware is PowerQUICC Serial

Description: connected to CiscoA

Interface is unnumbered. Using address of FastEthernet0/0 (0.0.0.0)

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation FRAME-RELAY IETF, loopback not set

Keepalive set (10 sec)

LMI enq sent 11, LMI stat recvd 0, LMI upd recvd 0, DTE LMI down

LMI enq recvd 0, LMI stat sent 0, LMI upd sent 0

LMI DLCI 1023 LMI type is CISCO frame relay DTE

Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0

Last input never, output 00:00:04, output hang never

Last clearing of "show interface" counters 00:01:54

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

20 packets output, 263 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up


CiscoB>show protocol serial0/0

Serial0/0 is up, line protocol is down

Interface is unnumbered. Using address of FastEthernet0/0 (0.0.0.0)


deilert Wed, 07/09/2003 - 09:17
User Badges:
  • Silver, 250 points or more

Are you using an external CSU or an internal WIC or is this a back to back connection

deilert Wed, 07/09/2003 - 10:10
User Badges:
  • Silver, 250 points or more

you are also missing this command from your config


bridge 1 route ip

ekarnicki Wed, 07/09/2003 - 10:04
User Badges:

Is there a reason you are using Frame for the encapsulation? If there is no specific reason you are using frame-relay encapsulation, try PPP or HDCL. Make sure your encapsulation matches on both ends..


-e

I keep getting s0/0 up - line protocol down. How do I determine the clock rate if the telco supplied the CSU with a v.35 jack? Should they have told me the clock rate? At any rate, here are the current configurations - This is just from Router "A" or the host side - Router "B" is still identical except for the BVI 1 IP. Thanks again. Back at PPP encapsulation. Due to lenght, I had to post remaining config on another post.


Router config:

Using 891 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname CiscoA

!

enable password xxxx

!

memory-size iomem 25

ip subnet-zero

no ip domain lookup

!

!

!

bridge irb

!

!

interface FastEthernet0/0

description connected to EthernetLAN_1

no ip address

no keepalive

speed auto

bridge-group 1

!

interface Serial0/0

description connected to CiscoB

ip unnumbered FastEthernet0/0

encapsulation ppp

bridge-group 1

!

interface BVI1

ip address 192.168.0.21 255.255.255.0

!

router rip

version 2

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

exec-timeout 0 0

password 7 111A0C15071D1918

login

line aux 0

line vty 0 4

password xxxx

login

!

end

************************************

sh controller:

Interface FastEthernet0/0

Hardware is PQUICC MPC860P ADDR: 80C91310, FASTSEND: 80011BA4

DIST ROUTE ENABLED: 0

Route Cache Flag: 1

ADDR_LOW =0x000B466B, ADDR_HIGH =0x00003BF0, HASH_HIGH =0x04000100, HASH_LOW =0x04200000

R_DES_ST =0x01917720, X_DES_ST =0x01917960, R_BUFF_SIZ=0x00000600, ECNTRL =0xF0000006

IEVENT =0x00000000, IMASK =0x0A000000, IVEC =0xC0000000, R_DES_ACT=0x01000000

X_DES_ACT=0x00000000, MII_DATA =0x50821000, MII_SPEED =0x00000014, R_BOUND =0x00000600

R_FSTART =0x00000500, X_FSTART =0x00000440, FUN_CODE =0x7F000000, R_CNTRL =0x0000000C

R_HASH =0xEF0005F2

X_CNTRL =0x00000004

HW filtering information:

Promiscuous Mode Enabled

Software MAC address filter(hash:length/addr/mask/hits):

pquicc_fec_instance=0x80C93070

rx ring entries=64, tx ring entries=32

rxring=0x1917720, rxr shadow=0x80C93264, rx_head=30, rx_tail=0

txring=0x1917960, txr shadow=0x80C93390, tx_head=19, tx_tail=19, tx_count=0

RX_RING_ENTRIES

status 8000, len 40, buf_ptr 1917AE0

status 8000, len F7, buf_ptr 1918140

status 8000, len 40, buf_ptr 19187A0

status 8000, len 60, buf_ptr 1918E00

status 8000, len 68, buf_ptr 1919460

status 8000, len 60, buf_ptr 1919AC0

status 8000, len 68, buf_ptr 191A120

status 8000, len 60, buf_ptr 191A780

status 8000, len 68, buf_ptr 191ADE0

status 8000, len F2, buf_ptr 191B440

status 8000, len FA, buf_ptr 191BAA0

status 8000, len 40, buf_ptr 191C100

status 8000, len 40, buf_ptr 191C760

status 8000, len F7, buf_ptr 191CDC0

status 8000, len F7, buf_ptr 191D420

status 8000, len 40, buf_ptr 191DA80

status 8000, len 40, buf_ptr 191E0E0

status 8000, len F7, buf_ptr 191E740

status 8000, len 40, buf_ptr 191EDA0

status 8000, len 40, buf_ptr 191F400

status 8000, len 40, buf_ptr 191FA60

status 8000, len 40, buf_ptr 19200C0

status 8000, len F7, buf_ptr 1920720

status 8000, len 40, buf_ptr 1920D80

status 8000, len F7, buf_ptr 19213E0

status 8000, len 40, buf_ptr 1921A40

status 8000, len 40, buf_ptr 19220A0

status 8000, len 40, buf_ptr 1922700

status 8000, len 40, buf_ptr 1922D60

status 8000, len F7, buf_ptr 19233C0

status 8000, len 0, buf_ptr 1855E20

status 8000, len 0, buf_ptr 18557A0

status 8000, len 0, buf_ptr 1855120

status 8000, len 0, buf_ptr 1854AA0

status 8000, len 0, buf_ptr 1854420

status 8000, len 0, buf_ptr 1853DA0

status 8000, len 0, buf_ptr 1853720

status 8000, len 0, buf_ptr 18530A0

status 8000, len 0, buf_ptr 1852A20

status 8000, len 0, buf_ptr 18523A0

status 8000, len 0, buf_ptr 1851D20

status 8000, len 0, buf_ptr 18516A0

status 8000, len 0, buf_ptr 1851020

status 8000, len 0, buf_ptr 18509A0

status 8000, len 0, buf_ptr 1850320

status 8000, len 0, buf_ptr 184FCA0

status 8000, len 0, buf_ptr 184F620

status 8000, len 0, buf_ptr 184EFA0

status 8000, len 0, buf_ptr 184E920

status 8000, len 0, buf_ptr 184E2A0

status 8000, len 0, buf_ptr 184DC20

status 8000, len 0, buf_ptr 184D5A0

status 8000, len 0, buf_ptr 184CF20

status 8000, len 0, buf_ptr 184C8A0

status 8000, len 0, buf_ptr 184C220

status 8000, len 0, buf_ptr 184BBA0

status 8000, len 0, buf_ptr 184B520

status 8000, len 0, buf_ptr 184AEA0

status 8000, len 0, buf_ptr 184A820

status 8000, len 0, buf_ptr 184A1A0

status 8000, len 0, buf_ptr 1849B20

status 8000, len 0, buf_ptr 18494A0

status 8000, len 0, buf_ptr 1848E20

status A000, len 0, buf_ptr 18487A0


TX_RING_ENTRIES

status 0, len 3C, buf_ptr 1800E87

status 0, len 3C, buf_ptr 1801107

status 0, len 3C, buf_ptr 1801387

status 0, len 3C, buf_ptr 1801747

status 0, len 3C, buf_ptr 1801887

status 0, len 3C, buf_ptr 18019C7

status 0, len 3C, buf_ptr 1801C47

status 0, len 3C, buf_ptr 1801EC7

status 0, len 3C, buf_ptr 19717C7

status 0, len 3C, buf_ptr 1971A47

status 0, len 3C, buf_ptr 1971CC7

status 0, len 3C, buf_ptr 1971F47

status 0, len 3C, buf_ptr 19721C7

status 0, len 3C, buf_ptr 1972587

status 0, len 3C, buf_ptr 1972807

status 0, len 3C, buf_ptr 1972D07

status 0, len 3C, buf_ptr 18014C7

status 0, len 3C, buf_ptr 1800207

status 0, len 3C, buf_ptr 1800347

status 0, len 3C, buf_ptr 18005C7

status 0, len 169, buf_ptr 1806562

status 0, len 3C, buf_ptr 1800487

status 0, len 3C, buf_ptr 1800707

status 0, len 3C, buf_ptr 1800847

status 0, len 3C, buf_ptr 1800FC7

status 0, len 3C, buf_ptr 1800E87

status 0, len 3C, buf_ptr 1801107

status 0, len 3C, buf_ptr 1800487

status 0, len 3C, buf_ptr 1800987

status 0, len 3C, buf_ptr 1800C07

status 0, len 3C, buf_ptr 1800D47

status 2000, len 3C, buf_ptr 1800FC7

throttled=0, enabled=0, disabled=0

rx_framing_err=0, rx_overflow_err=0, rx_buffer_err=0

rx_no_enp=0, rx_discard=0

tx_one_col_err=0, tx_more_col_err=0, tx_no_enp=0, tx_deferred_err=0

tx_underrun_err=0, tx_late_collision_err=0, tx_loss_carrier_err=1

tx_exc_collision_err=0, tx_buff_err=0, fatal_tx_err=0

PHY registers:

Register 00 1000

Register 01 782D

Register 02 7810

Register 03 0003

Register 04 01E1

Register 05 45E1

Register 06 0001

Register 16 0000

Register 17 0000

Register 18 4000

Register 19 0000

Register 20 38C8



Interface Serial0/0

Hardware is PowerQUICC MPC860

DTE V.35 TX and RX clocks detected.

idb at 0x80CAB1C0, driver data structure at 0x80CB2CCC

SCC Registers:

General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8

Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x06

Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E

Interrupt Registers:

Config [CICR]=0x00365F80, Pending [CIPR]=0x84008000

Mask [CIMR]=0x40204000, In-srv [CISR]=0x00000000

Command register [CR]=0x600

Port A [PADIR]=0x0000, [PAPAR]=0x0903

[PAODR]=0x0000, [PADAT]=0xFFFF

Port B [PBDIR]=0x0180F, [PBPAR]=0x0E00E

[PBODR]=0x00000, [PBDAT]=0x3077C

Port C [PCDIR]=0x000, [PCPAR]=0x000

[PCSO]=0x020, [PCDAT]=0xFCC, [PCINT]=0x000

Receive Ring

rmd(FF002430): status 9000 length F address 1967144

rmd(FF002438): status 9000 length 10 address 1965744

rmd(FF002440): status 9000 length F address 19677C4

rmd(FF002448): status 9000 length F address 1966444

rmd(FF002450): status 9000 length F address 19643C4

rmd(FF002458): status 9000 length F address 1964A44

rmd(FF002460): status 9000 length 60C address 1965DC4

rmd(FF002468): status 9000 length 60C address 1966AC4

rmd(FF002470): status 9000 length 60C address 1864AE4

rmd(FF002478): status 9000 length 60C address 1864464

rmd(FF002480): status 9000 length 60C address 1863DE4

rmd(FF002488): status 9000 length 60C address 1863764

rmd(FF002490): status 9000 length 60C address 18630E4

rmd(FF002498): status 9000 length 60C address 1862A64

rmd(FF0024A0): status 9000 length 60C address 18623E4

rmd(FF0024A8): status B000 length 60C address 1861D64

Transmit Ring

tmd(FF0024B0): status 0 length E address 0

tmd(FF0024B8): status 0 length E address 0

tmd(FF0024C0): status 0 length E address 0

tmd(FF0024C8): status 0 length E address 0

tmd(FF0024D0): status 0 length E address 0

tmd(FF0024D8): status 0 length E address 0

tmd(FF0024E0): status 0 length E address 0

tmd(FF0024E8): status 0 length E address 0

tmd(FF0024F0): status 0 length E address 0

tmd(FF0024F8): status 0 length E address 0

tmd(FF002500): status 0 length 0 address 0

tmd(FF002508): status 0 length 0 address 0

tmd(FF002510): status 0 length 0 address 0

tmd(FF002518): status 0 length 0 address 0

tmd(FF002520): status 0 length 0 address 0

tmd(FF002528): status 2000 length 0 address 0


tx_limited=1(2)


SCC GENERAL PARAMETER RAM (at 0xFF003C00)

Rx BD Base [RBASE]=0x2430, Fn Code [RFCR]=0x18

Tx BD Base [TBASE]=0x24B0, Fn Code [TFCR]=0x18

Max Rx Buff Len [MRBLR]=1548

Rx State [RSTATE]=0x18008440, BD Ptr [RBPTR]=0x2460

Tx State [TSTATE]=0x18000548, BD Ptr [TBPTR]=0x24B8


SCC HDLC PARAMETER RAM (at 0xFF003C38)

CRC Preset [C_PRES]=0xFFFF, Mask [C_MASK]=0xF0B8

Errors: CRC [CRCEC]=0, Aborts [ABTSC]=0, Discards [DISFC]=0

Nonmatch Addr Cntr [NMARC]=0

Retry Count [RETRC]=0

Max Frame Length [MFLR]=1608

Rx Int Threshold [RFTHR]=0, Frame Cnt [RFCNT]=65530

User-defined Address 0000/0000/0000/0000

User-defined Address Mask 0x0000



buffer size 1524


PowerQUICC SCC specific errors:

0 input aborts on receiving flag sequence

0 throttles, 0 enables

0 overruns

0 transmitter underruns

0 transmitter CTS losts


Here is the remaining config.


******************************************

show Interface serial0/0

Serial0/0 is up, line protocol is down

Hardware is PowerQUICC Serial

Description: connected to CiscoB

Interface is unnumbered. Using address of FastEthernet0/0 (0.0.0.0)

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

LCP REQsent

Closed: BRIDGECP, IPCP, CCP, CDPCP, LLC2, BACP

Last input 00:00:06, output 00:00:01, output hang never

Last clearing of "show interface" counters 00:06:53

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

62 packets input, 813 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

2 input errors, 0 CRC, 2 frame, 0 overrun, 0 ignored, 0 abort

85 packets output, 1190 bytes, 0 underruns

0 output errors, 0 collisions, 7 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up

*************************************************************

sh int fastethernet0/0

FastEthernet0/0 is up, line protocol is up

Hardware is PQUICC_FEC, address is 000b.466b.3bf0 (bia 000b.466b.3bf0)

Description: connected to EthernetLAN_1

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output 00:00:01, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

153 packets input, 16757 bytes

Received 75 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

353 packets output, 24787 bytes, 0 underruns

1 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

1 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

********************************************************

sh interface bvi 1

BVI1 is up, line protocol is up

Hardware is BVI, address is 000b.466b.3bf0 (bia 0000.0000.0000)

Internet address is 192.168.0.21/24

MTU 1500 bytes, BW 1544 Kbit, DLY 5000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/0 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

4 packets output, 246 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

***************************************

show protocol serial0/0

Serial0/0 is up, line protocol is down

Interface is unnumbered. Using address of FastEthernet0/0 (0.0.0.0)

CiscoA#>

Correct Answer
deilert Wed, 07/09/2003 - 14:03
User Badges:
  • Silver, 250 points or more

can you paste in sh controllers & sh int serial x & sh run from cisco b , also I am not sure that you can use ip unnumbered f0/0, f0/0 has no ip address , you may have to use ip unnumbered bvi 1


It is the exact same as router "A" with the exception of the IP BVI 1. I can ping the routers from their respective internal LANs and I can ping from the routers insdie their respective LANS - I just can't ping devices from LAN "A" to LAN "B" or from router "A" to Router "B" and vice versa - because my s0/0 is up - line protocol is down. Do you think changing the ip unnumbered f0/0 for s0/0 to ip unnumbered bvi 1 will help resolve this. I can give it a shot. any other ideas in the mean time?

deilert Thu, 07/10/2003 - 09:07
User Badges:
  • Silver, 250 points or more

Have you tried HDLC encap ? Your LCP is not coming up in PPP , If you change to HDLC encap and you still get protocol down , you need to investigate the CSU being misconfigured ,


Can tou paste in a sh serial X from the B router

deilert Thu, 07/10/2003 - 09:18
User Badges:
  • Silver, 250 points or more

It is the easiest to configure , as long as it a Cisco box that is attached on the other end , I would use HDLC .

Yes, two identical cisco 1751 brand spankin new on each side. Let me ask you another question, If the remote router "B" is still on PPP encap aand I have changed the host router "A" to HDLC - should i be able to get a s0/0 is up - line protocol up on the host side? Thanks for all your advice - has been a big help so far.

deilert Thu, 07/10/2003 - 09:51
User Badges:
  • Silver, 250 points or more

no you must use the same encap on each end HDLC>>>HDLC or PPP >>.PPP , If you are using boxes from differnet vendors on a point to point link you have to use PPP.

deilert Thu, 07/10/2003 - 11:40
User Badges:
  • Silver, 250 points or more

Yes it will, What brings up and keeps up your line protocol the the tranmitting and receipt of keepalive packets . The line protocol will drop after 3 keepalives are missed .

deilert Thu, 07/10/2003 - 11:48
User Badges:
  • Silver, 250 points or more

I thought you said this is using an external CSU that is provided by the Telco , Who is providing clock , you may not need to set clock on the serial interface , Also the config on the B router can't be the same if you are providing clock on the B router , Does the B router have a DTE or a DCE cable attached ?

deilert Fri, 07/11/2003 - 07:50
User Badges:
  • Silver, 250 points or more

Either the csu/dsu or the provider will have to supply clock , You can supply clock on a serial interface with a DCE cable attached , I wouls not recommend this for a long haul wide area connection . If you have access the the Csu's configure one to provide clock and the other to look for clock from the network.

take a look at the following config. I reset both router to defaults (erased) and started from scratch. Router "A" is now on 192.168.0.21 and Router "B" 192.168.10.22 - each on their own subnets. The s0/0 line protocol still toggles up/down about every 10 seconds - toggling faster than before, but still not remaining up. HDLC on both ends. I have called the telecom - "they are investigating", but state everything appears fine from their site. Thanks


sh config

Using 786 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-xxx!

hostname CiscoA

!

enable password xxxx

!

memory-size iomem 25

ip subnet-zero

no ip domain lookup

!

!

!

!

!

interface FastEthernet0/0

description connected to EthernetLAN_1

ip address 192.168.0.21 255.255.255.0

no keepalive

speed auto

!

interface Serial0/0

description connected to CiscoB

ip unnumbered FastEthernet0/0

no logging event link-status

!

router rip

version 2

network 192.168.0.0

no auto-summary

!

ip classless

no ip http server

!

!

snmp-server community public RO

snmp-server enable traps tty

!

line con 0

exec-timeout 0 0

password xxx

login

line aux 0

line vty 0 4

password xxxx

login

!

end


*****************************************



CiscoA#sh interface fastethernet0/0


FastEthernet0/0 is up, line protocol is up

Hardware is PQUICC_FEC, address is 000b.466b.3bf0 (bia 000b.466b.3bf0)

Description: connected to EthernetLAN_1

Internet address is 192.168.0.21/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:02, output 00:00:19, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

30 packets input, 4027 bytes

Received 30 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

7 packets output, 1625 bytes, 0 underruns

3 output errors, 0 collisions, 3 interface resets

0 babbles, 0 late collision, 0 deferred

3 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out


******************************************


CiscoA#sh int s0/0


Serial0/0 is up, line protocol is up

Hardware is PowerQUICC Serial

Description: connected to CiscoB

Interface is unnumbered. Using address of FastEthernet0/0 (192.168.0.21)

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 247/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set

Keepalive set (10 sec)

Last input 00:00:04, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/2/256 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 1158 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

21 packets input, 504 bytes, 0 no buffer

Received 21 broadcasts, 0 runts, 0 giants, 0 throttles

9 input errors, 0 CRC, 9 frame, 0 overrun, 0 ignored, 0 abort

63 packets output, 8512 bytes, 0 underruns

0 output errors, 0 collisions, 12 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

DCD=up DSR=up DTR=up RTS=up CTS=up


CiscoA#

Correct Answer
deilert Fri, 07/11/2003 - 14:28
User Badges:
  • Silver, 250 points or more

the config looks ok , what about the B router config ? ALso did you find out who is providing clock ? "Find out from the telco . Also who owns the Csu's , like I said before either one of the cs's or the telco is going to have to supply clock.

I ran the debug command - take a look and see what you think. Thanks



debug serial interface

Serial network interface debugging is on

CiscoA#

*Mar 1 00:18:03.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:05.227: Serial0/0: HDLC myseq 107, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:18:06.227: Serial0/0: attempting to restart

*Mar 1 00:18:06.227: PowerQUICC(0/0): DCD is up.


*Mar 1 00:18:13.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:15.227: Serial0/0: HDLC myseq 108, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:18:23.731: Illegal HDLC serial type code 776, PC=0x800140CC


*Mar 1 00:18:23.731: Illegal HDLC serial type code 776, PC=0x800140CC


*Mar 1 00:18:23.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:23.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:25.227: Serial0/0: HDLC myseq 109, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:18:33.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:35.227: Serial0/0: HDLC myseq 110, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:18:36.227: Serial0/0: attempting to restart

*Mar 1 00:18:36.227: PowerQUICC(0/0): DCD is up.


*Mar 1 00:18:43.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:45.227: Serial0/0: HDLC myseq 111, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:18:53.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:18:55.227: Serial0/0: HDLC myseq 112, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:19:03.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:19:05.227: Serial0/0: HDLC myseq 113, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:19:06.227: Serial0/0: attempting to restart

*Mar 1 00:19:06.227: PowerQUICC(0/0): DCD is up.


*Mar 1 00:19:13.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:19:15.227: Serial0/0: HDLC myseq 114, mineseen 0, yourseen 0, line do

wn

*Mar 1 00:19:23.731: Illegal HDLC serial type code 776, PC=0x800140CC


*Mar 1 00:19:23.731: Illegal HDLC serial type code 776, PC=0x800140CC


*Mar 1 00:19:23.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:19:23.731: Illegal HDLC serial type code 777, PC=0x800140CC


*Mar 1 00:19:25.227: Serial0/0: HDLC myseq 115, mineseen 0, yourseen 0, line do

wn

Actions

This Discussion