×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

EIGRP Message "Route configuration changed"

Unanswered Question
Jul 28th, 2003
User Badges:

.Jul 26 11:23:23 BST: %DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 10.10.10.1 (Serial1/5) is down: route configuration changed


I get this message when I change a distribute-list on the router.


Can I confirm, that every time you change a distribute list (ie no dist-list 10 then re-apply it) the eigrp adj resets with this error and this is normal operation. Is this the same with prefix lists if you take a list off then re-apply it?


many thx.


ps. could not find a reference on the cisco website anywhere specifying this particular eigrp NBRCHANGE message above :)


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kfarrington Mon, 07/28/2003 - 01:44
User Badges:

Sorry guys,


have the documentation in front of me. had to search on yahoo.


searchnetworking.techtarget.com/searchNetworking/downloads/TroubleshootingIProuting.pdf


it is normal operation. still dont know if this applies to prefix lists tho...


ruwhite Mon, 07/28/2003 - 02:44
User Badges:
  • Gold, 750 points or more

EIGRP doesn't keep track of what it has advertised to each neighbor, and thus it doesn't know what it should withdraw from any given neighbor when you change the filtering. Thus, the only way to make certain all of your neighbors have the right information when filtering is changed is to reset the neighbors on which filtering has changed.


This may change at some point in the future, but for now, it's normal operation.


Russ.W

kfarrington Mon, 07/28/2003 - 04:05
User Badges:

Thx Russ once again.


Just tested distribute-list vs prefix-lists


dist lists automatically reset the adj, and prefix lists you have to manually reset the adj for the change in the prefix list to take effect.


details below :))



DISTRIBUTE-LISTS


router eigrp 100

passive-interface Serial0/0

network 10.0.0.0

network 11.0.0.0

distribute-list 1 in FastEthernet0/0

no auto-summary

eigrp log-neighbor-changes

!

access-list 1 permit 11.11.2.0

access-list 1 permit 11.11.3.0


QOS-RTR1# sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route


Gateway of last resort is not set


C 172.19.0.0/16 is directly connected, Dialer1

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

R 10.3.1.0/24 [120/1] via 10.1.1.2, 00:00:26, FastEthernet0/0

[120/1] via 10.2.1.2, 00:00:26, Serial0/0

C 10.2.1.0/30 is directly connected, Serial0/0

C 10.1.1.0/24 is directly connected, FastEthernet0/0

11.0.0.0/24 is subnetted, 2 subnets

D 11.11.2.0 [90/156160] via 10.1.1.2, 00:05:00, FastEthernet0/0

D 11.11.3.0 [90/156160] via 10.1.1.2, 00:05:02, FastEthernet0/0

S 193.177.238.0/24 [250/0] via 172.19.1.254

QOS-RTR1#








QOS-RTR2>sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR


Gateway of last resort is not set


10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 10.3.1.0/24 is directly connected, Loopback1

C 10.2.1.0/30 is directly connected, Serial1/0

C 10.1.1.0/24 is directly connected, Ethernet0/0

11.0.0.0/24 is subnetted, 4 subnets

C 11.11.2.0 is directly connected, Loopback2

C 11.11.3.0 is directly connected, Loopback3

C 11.11.4.0 is directly connected, Loopback4

C 11.11.5.0 is directly connected, Loopback5

12.0.0.0/24 is subnetted, 1 subnets

C 12.12.1.0 is directly connected, Loopback6

QOS-RTR2>













when acl changed


*Mar 3 19:59:35 GMT: %SYS-5-CONFIG_I: Configured from console by console

*Mar 3 19:59:44 GMT: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.2 (FastEthernet0/0) is down: route configuration changed

*Mar 3 19:59:47 GMT: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.2 (FastEthernet0/0) is up: new adjacency

QOS-RTR1#



4d23h: %SYS-5-CONFIG_I: Configured from console by vty0 (10.1.1.1)

4d23h: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.1 (Ethernet0/0) is down: peer restarted

4d23h: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.1 (Ethernet0/0) is up: new adjacency

QOS-RTR2>

-------------------

PREFIX-LISTS


!

router eigrp 100

passive-interface Serial0/0

network 10.0.0.0

network 11.0.0.0

distribute-list prefix ken in FastEthernet0/0

no auto-summary

eigrp log-neighbor-changes

!

ip prefix-list ken seq 5 permit 11.11.2.0/24

ip prefix-list ken seq 10 permit 11.11.3.0/24




QOS-RTR1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route


Gateway of last resort is not set


C 172.19.0.0/16 is directly connected, Dialer1

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

R 10.3.1.0/24 [120/1] via 10.1.1.2, 00:00:24, FastEthernet0/0

[120/1] via 10.2.1.2, 00:00:24, Serial0/0

C 10.2.1.0/30 is directly connected, Serial0/0

C 10.1.1.0/24 is directly connected, FastEthernet0/0

11.0.0.0/24 is subnetted, 2 subnets

D 11.11.2.0 [90/156160] via 10.1.1.2, 00:09:39, FastEthernet0/0

D 11.11.3.0 [90/156160] via 10.1.1.2, 00:09:40, FastEthernet0/0

S 193.177.238.0/24 [250/0] via 172.19.1.254

QOS-RTR1#












when acl changed



!

ip prefix-list ken seq 5 permit 11.11.2.0/24

ip prefix-list ken seq 10 permit 11.11.3.0/24

ip prefix-list ken seq 15 permit 11.11.4.0/24 <- line added

!





QOS-RTR1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route


Gateway of last resort is not set


C 172.19.0.0/16 is directly connected, Dialer1

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

R 10.3.1.0/24 [120/1] via 10.1.1.2, 00:00:08, FastEthernet0/0

[120/1] via 10.2.1.2, 00:00:08, Serial0/0

C 10.2.1.0/30 is directly connected, Serial0/0

C 10.1.1.0/24 is directly connected, FastEthernet0/0

11.0.0.0/24 is subnetted, 2 subnets

D 11.11.2.0 [90/156160] via 10.1.1.2, 00:11:16, FastEthernet0/0

D 11.11.3.0 [90/156160] via 10.1.1.2, 00:11:17, FastEthernet0/0

S 193.177.238.0/24 [250/0] via 172.19.1.254

QOS-RTR1#



cleard eigrp manually


QOS-RTR1#

QOS-RTR1#cle ip eigrp nei

QOS-RTR1#

*Mar 3 20:23:36 GMT: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.2 (FastEthernet0/0) is down: manually cleared

*Mar 3 20:23:37 GMT: %DUAL-5-NBRCHANGE: IP-EIGRP 100: Neighbor 10.1.1.2 (FastEthernet0/0) is up: new adjacency

QOS-RTR1#

QOS-RTR1#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route


Gateway of last resort is not set


C 172.19.0.0/16 is directly connected, Dialer1

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

R 10.3.1.0/24 [120/1] via 10.1.1.2, 00:00:17, FastEthernet0/0

[120/1] via 10.2.1.2, 00:00:17, Serial0/0

C 10.2.1.0/30 is directly connected, Serial0/0

C 10.1.1.0/24 is directly connected, FastEthernet0/0

11.0.0.0/24 is subnetted, 3 subnets

D 11.11.2.0 [90/156160] via 10.1.1.2, 00:00:04, FastEthernet0/0

D 11.11.3.0 [90/156160] via 10.1.1.2, 00:00:05, FastEthernet0/0

D 11.11.4.0 [90/156160] via 10.1.1.2, 00:00:05, FastEthernet0/0

S 193.177.238.0/24 [250/0] via 172.19.1.254

QOS-RTR1#









ruwhite Mon, 07/28/2003 - 04:14
User Badges:
  • Gold, 750 points or more

Ah, yes.... In fact, the behaviour for distribute lists was just changed recently, if I remember right, and there's always this big argument over that behaviour--do customers actually like it that the neighbors reset, or should we not do that? The arguments are:


-- If you don't reset the neighbor autmatically, then customers will be surprised when the filter doesn't take effect.


-- If you reset the neighbor autmatically, then customers will be surprised over the neighbor reset, or perhaps a neighbor reset each time they change a configured filter (or how do you handle filtering mechanisms that can support adding and removing filter lines).


I think, for now, the argument in favor of automatic resets has won, but I'm not certain any code was put in place for anything other than distribute lists. I could file something for prefix lists, if it's not already filed. I'll put that on my list of things to do....


:-)


Russ.W

Actions

This Discussion