using a 3550 switch as default gateway - conf included. is this ok?

Unanswered Question
Aug 4th, 2003
User Badges:

Ok - we just setup a 3550 switch to be our default router and I need some advice as to if i set it up correctly or any gotcha's that i may have missed:

as you can see i have the 4 subnets. i do not have a route configured to the other 3 subnet ports - I wasn't sure if the box handled that or if I need to add a static route - what i mean is if client 1.1.1.2 needs to get to 1.1.2.3, do i need to add a route to fast/ethernet2? does this config look ok and are there any issues that i may encounter with this type of configuration? thanks for any info. (newbie - still learning :))


config:



!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname router

!

enable secret 5 xxxx

enable password 7 xxxxx

!

ip subnet-zero

ip routing

!

!

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no switchport

ip address 1.1.2.1 255.255.255.0

!

interface FastEthernet0/3

no switchport

ip address 1.1.3.1 255.255.255.0

!

interface FastEthernet0/4

no switchport

ip address 1.1.4.1 255.255.255.0

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 1.1.1.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.27.52.213

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.xx.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip http server

!

!

!

line con 0

line vty 0 4

password 7 xxxx

login

line vty 5 15

password 7 xxxx

login

!

end


(numbers changed to protect the innocent.)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Prashanth Krishnappa Mon, 08/04/2003 - 11:58
User Badges:
  • Cisco Employee,

You do not need top configure anything to route from one interface to another on the SAME 3550/router

rbinc Mon, 08/04/2003 - 12:14
User Badges:

Ok great. I wasn't sure. Is this config look ok? Any issues that may arise that i haven't configured for?

rbinc Tue, 08/05/2003 - 07:56
User Badges:

ok, i enabled two ports and i can't get to the network on teh 2nd port. what am i doing wrong? :(

toslat Tue, 08/05/2003 - 09:25
User Badges:

u might have to enable ip routing. seems its turned off by default.

rbinc Tue, 08/05/2003 - 09:36
User Badges:

Ok, I have more information. it appears that it does work but very flaky. ping timeouts etc. router moves very slow. ios is 12.1 - i am going to update the ios and see if that helps. also, i have 65526k/8192k bytes of memory. maybe this isn't enough?

Actions

This Discussion