cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
540
Views
0
Helpful
6
Replies

using a 3550 switch as default gateway - conf included. is this ok?

rbinc
Level 1
Level 1

Ok - we just setup a 3550 switch to be our default router and I need some advice as to if i set it up correctly or any gotcha's that i may have missed:

as you can see i have the 4 subnets. i do not have a route configured to the other 3 subnet ports - I wasn't sure if the box handled that or if I need to add a static route - what i mean is if client 1.1.1.2 needs to get to 1.1.2.3, do i need to add a route to fast/ethernet2? does this config look ok and are there any issues that i may encounter with this type of configuration? thanks for any info. (newbie - still learning :))

config:

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname router

!

enable secret 5 xxxx

enable password 7 xxxxx

!

ip subnet-zero

ip routing

!

!

spanning-tree extend system-id

!

!

!

interface FastEthernet0/1

no ip address

!

interface FastEthernet0/2

no switchport

ip address 1.1.2.1 255.255.255.0

!

interface FastEthernet0/3

no switchport

ip address 1.1.3.1 255.255.255.0

!

interface FastEthernet0/4

no switchport

ip address 1.1.4.1 255.255.255.0

!

interface FastEthernet0/5

no ip address

!

interface FastEthernet0/6

no ip address

!

interface FastEthernet0/7

no ip address

!

interface FastEthernet0/8

no ip address

!

interface FastEthernet0/9

no ip address

!

interface FastEthernet0/10

no ip address

!

interface FastEthernet0/11

no ip address

!

interface FastEthernet0/12

no ip address

!

interface FastEthernet0/13

no ip address

!

interface FastEthernet0/14

no ip address

!

interface FastEthernet0/15

no ip address

!

interface FastEthernet0/16

no ip address

!

interface FastEthernet0/17

no ip address

!

interface FastEthernet0/18

no ip address

!

interface FastEthernet0/19

no ip address

!

interface FastEthernet0/20

no ip address

!

interface FastEthernet0/21

no ip address

!

interface FastEthernet0/22

no ip address

!

interface FastEthernet0/23

no ip address

!

interface FastEthernet0/24

no ip address

!

interface GigabitEthernet0/1

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

ip address 1.1.1.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.27.52.213

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.xx.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip route x.x.x.x x.x.x.x x.x.x.x

ip http server

!

!

!

line con 0

line vty 0 4

password 7 xxxx

login

line vty 5 15

password 7 xxxx

login

!

end

(numbers changed to protect the innocent.)

6 Replies 6

Prashanth Krishnappa
Cisco Employee
Cisco Employee

You do not need top configure anything to route from one interface to another on the SAME 3550/router

Ok great. I wasn't sure. Is this config look ok? Any issues that may arise that i haven't configured for?

ok, i enabled two ports and i can't get to the network on teh 2nd port. what am i doing wrong? :(

u might have to enable ip routing. seems its turned off by default.

IP routing is enabled.

Ok, I have more information. it appears that it does work but very flaky. ping timeouts etc. router moves very slow. ios is 12.1 - i am going to update the ios and see if that helps. also, i have 65526k/8192k bytes of memory. maybe this isn't enough?