×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Spanning tree problem

Unanswered Question
Aug 12th, 2003
User Badges:

I have this setup:

a 2621 with its fa0/0 connected to a 2912(a) and its fa0/1 to another 2912(b). The 2 2912 are connected using a crossover cable. I enable IRB on 2621 and make it as root of vlan1. A laptop is attached to 2912a to ping the router. Everything is fine when all cables are connected. But if the link from 2912a to 2621 is disconnected, the ping to the router cannot be resumed. I suspect there is something wrong with the spanning tree since I found ALL connected ports are in the state of forwarding(before disconnecting the link from 2912a to 2621). There should be a blocked port on one of the 2912 but in this case no.

Is there something wrong with the config, or there is no way to make this work? Actually I want to use both ethernet ports on 2621 for resiliency.


2621 ver: 12.1(20)

2912 ver: 12.0(5)WC8

2621 config:

-------------

bridge irb

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

bridge-group 1

!

interface FastEthernet0/1

no ip address

speed 100

full-duplex

bridge-group 1

!

interface BVI1

ip address 10.1.1.1 255.0.0.0

!

ip classless

no ip http server

!

bridge 1 protocol ieee

bridge 1 route ip

bridge 1 priority 1

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Mon, 08/18/2003 - 01:24
User Badges:
  • Red, 2250 points or more

Hi,

if STP works correctly one side of the line between 2912s should be blocked (2621 is root).

Check on both 2912 who's the root from their point of view.

See STP statictics if BPDUs are coming correct way.

Regards,

Milan

Actions

This Discussion