×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Passive Interface command usage

Answered Question
Aug 31st, 2003
User Badges:

We have a HSSI frame Relay interface with about 50 subinterfaces on it. We're running OSPF on all of them but have the need to run RIPv2 on a single new PVC.


How can I setup RIP to run on the specific sub interface without having to use the passive interface command on all the other subinterfaces ?


I'd also like to to stop OSPF routing updates on this interface also but am not sure if this is possible.


thanks



Correct Answer by ruwhite about 13 years 11 months ago

Simply cover all the interfaces under OSPF, as you normally would, and then passive that one interface out. For RIP, it's not so easy, since there's no wildcard bits under RIP. You can use the passive interface default command, as the first reply noted, under RIP, to resolve this.


http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008784e.html


2651A#sho run | b rip

router rip

passive-interface default

no passive-interface FastEthernet0/0

....


Russ.W

Correct Answer by bbranch about 13 years 11 months ago

You can use the "passive interface default" command to make all interfces passive, then enable RIP on the individual interfaces that require it:


!

router rip

passive-interface default

no passive-interface s0/0.1



also if you make the OSPF network statements specific for an interface then you can control which interfaces you enable it on:


!

router ospf 1

network 10.1.1.1 0.0.0.0 area 0.0.0.0



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
bbranch Mon, 09/01/2003 - 01:35
User Badges:
  • Silver, 250 points or more

You can use the "passive interface default" command to make all interfces passive, then enable RIP on the individual interfaces that require it:


!

router rip

passive-interface default

no passive-interface s0/0.1



also if you make the OSPF network statements specific for an interface then you can control which interfaces you enable it on:


!

router ospf 1

network 10.1.1.1 0.0.0.0 area 0.0.0.0



Correct Answer
ruwhite Mon, 09/01/2003 - 05:51
User Badges:
  • Gold, 750 points or more

Simply cover all the interfaces under OSPF, as you normally would, and then passive that one interface out. For RIP, it's not so easy, since there's no wildcard bits under RIP. You can use the passive interface default command, as the first reply noted, under RIP, to resolve this.


http://www.cisco.com/en/US/products/sw/iosswrel/ps1830/products_feature_guide09186a008008784e.html


2651A#sho run | b rip

router rip

passive-interface default

no passive-interface FastEthernet0/0

....


Russ.W

Actions

This Discussion