×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 2611 configure adsl connection with isdn backup

Unanswered Question
Sep 11th, 2003
User Badges:
  • Bronze, 100 points or more

Hi,


First let me tell you that I new at configuring routers.


I have a Cisco 2611 which I would like to configure to use ADSL

and in case of connection failure switch to ISDN.

When the connection is restored, it should switch back to ADSL.


Please look at the config below, and tell me what is wrong.


START CONFIG:


Using 1385 out of 29688 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname {XX HostName XX}

!

enable secret 5 {XX Secret XX}

!

username {XX Username XX} password 0 {XX Password XX}

!

!

!

!

ip subnet-zero

!

isdn switch-type basic-net3

!

!

!

interface Ethernet0/0

ip address 10.0.0.253 255.255.255.0

ip nat inside

!

interface BRI0/0

no ip address

encapsulation ppp

isdn switch-type basic-net3

isdn answer1 9999

isdn answer2 9999

no cdp enable

!

interface Ethernet0/1

backup delay 5 10

backup interface Dialer1

ip address {XX Outside IP ADSL XX} 255.255.255.248

ip nat outside

no ip route-cache

no ip mroute-cache

!

interface Dialer1

ip address {XX Outside IP ISDN XX} 255.255.255.0

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer in-band

dialer idle-timeout 180

dialer string {XX ISP Number XX}

no cdp enable

ppp authentication pap callin

ppp pap sent-username {XX Username ISP XX} password 7 {XX Password ISP XX}

!

router rip

version 2

network 10.0.0.0

!

ip nat inside source list 1 interface Ethernet0/1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 {XX IP ISP XX}

ip route 0.0.0.0 0.0.0.0 Dialer1 250

ip route 10.0.0.0 255.255.255.0 10.0.0.254

ip http server

!

access-list 1 permit any

!

line con 0

exec-timeout 0 0

login local

stopbits 1

line aux 0

line vty 0 4

password {XX Password XX}

login

!

end


END CONFIG


Thank you very much for any help you can provide me with.


Thierry

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
thisisshanky Thu, 09/11/2003 - 07:07
User Badges:
  • Purple, 4500 points or more

First of all, when the ADSL link fails, there is no way the router comes ot know that the ADSL link has failed. because you connect to the DSL modem via ethernet, and that link will remain up all the time.


On the dialer interface, you have not specified any dialer-list which associates interesting traffic for dialing the ISDN line


dialer-list 1 protocol ip permit


int dialer 1

dialer-group 1


Also if both service providers (the one for ADSL and ISDN) are diff and have given different address pools (public IP) you will need to use NAT with route maps to translate to the appropriate pool, in case of failure.


http://www.cisco.com/warp/public/105/nat_routemap.html

Anonymous (not verified) Fri, 09/12/2003 - 02:23
User Badges:

Thank you for your answer.

But I will need a little extra help, like I said, I'm new at this.


Anonymous (not verified) Mon, 09/15/2003 - 23:48
User Badges:

Anybody?

ilev Wed, 09/24/2003 - 23:48
User Badges:

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 8/48

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface BRI0

ip address negotiated

ip nat outside

encapsulation ppp

dialer idle-timeout 600

dialer string xxxx

dialer load-threshold 1 either

dialer watch-group 1

dialer-group 1

isdn switch-type basic-net3

ppp authentication chap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp pap sent-username xxxx password xxxx

ppp multilink

!

interface FastEthernet0

ip address 10.3.2.235 255.255.0.0

ip access-group 120 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

load-interval 30

shutdown

speed auto

no cdp enable

hold-queue 100 out

!

interface Dialer0

ip address negotiated

ip access-group 102 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp pap sent-username xxxx password xxxxx

!

router mobile

!

ip classless

ip route profile

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 BRI0

no ip http server

no ip http secure-server

!

!

logging trap errors

dialer-list 1 protocol ip permit

no cdp run

!

!

line con 0

line aux 0

line vty 0 4

login

!

no scheduler allocate

!

end

Actions

This Discussion