Vlan problem with catalyst 2924

Unanswered Question
Sep 16th, 2003
User Badges:

HI,

I have this error in a catalyst 2924XL :

""""""""""""""""""""""""""""""""""""""""""""""""""""

(0), with c4506-2 FastEthernet4/2 (8).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/24

(0), with c4506-1 FastEthernet4/2 (8).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEthernet0/23.

"""""""""""""""""""""""""""""""""""""""""""""""""""""

we have the same configuration in another catalyst 2924 and we dont have this problem.

help please .

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tsettle Tue, 09/16/2003 - 06:51
User Badges:
  • Cisco Employee,

What vlan are the ports in? If these are access ports (single vlan) then the message is saying for example that the vlan for c4506-2 fe4/2 is different from 2924xl fa0/24. If these are trunk links then the native vlans are different on each end. This is just a warning message. The only issue is that you are bridging the two vlans together. Depending on your topology, this may not be a problem. Never-the-less you should verify the configuration and clean it up if necessary.

ffati Tue, 09/16/2003 - 07:11
User Badges:

the problem is that the catalyst 2924 don't support trunk,

so, we have configure the port in the federator to be in vlan X but all ports in catalyst 2924 are in VLAN 1.

we have tried to create other VLAN but 2924 can't be a VTP client

milan.kulik Tue, 09/16/2003 - 23:44
User Badges:
  • Red, 2250 points or more

Hi,

what IOS version are you running on the 2924?

Cat2924XL can support trunks and VTP unless they are really old (4MB DRAM) - check the sh ver output.

Even if 2924 were not able to support trunks or VTP - couldn't you configure the proper VLANs on the 2924 manually?

Regards,

Milan

ffati Wed, 09/17/2003 - 01:26
User Badges:

Hi,

***********************

sh version

Cisco Internetwork Operating System Software

IOS (tm) C2900XL Software (C2900XL-HS-M), Version 11.2(8.11)SA6, MAINTENANCE INT

ERIM SOFTWARE

Copyright (c) 1986-1903 by cisco Systems, Inc.

Compiled Thu 17-Jul-03 12:35 by antonino

Image text-base: 0x00003000, data-base: 0x0020E2E0


ROM: Bootstrap program is C2900XL boot loader

cisco WS-C2924C-XL (PowerPC403GA) processor (revision 0x11) with 4096K/640K byte

s of memory.

Processor board ID 0x09, with hardware revision 0x00

Last reset from warm-reset


Processor is running Enterprise Edition Software

Cluster member switch capable

24 Ethernet/IEEE 802.3 interface(s)


32K bytes of flash-simulated non-volatile



************************************************

we can create the other VLAN manually but it is not the same one as that which was created on the federator.


thanks

milan.kulik Wed, 09/17/2003 - 03:47
User Badges:
  • Red, 2250 points or more

Hi,

I've got no experience with such an old IOS.

But it really doesn't support VTP at all?

If you try "sh vtp ?" does it show anything?

If not: what is the difference if you create the VLAN manually?

Try sh cdp nei detail on both sides of the line and see what is the CDP info (including native VLAN) sent.

Regards,

Milan


glen.grant Thu, 09/18/2003 - 16:37
User Badges:
  • Purple, 4500 points or more

This is really rather interesting , I have never seen this problem with the old 4 meg boxes and we have a ton of them . I notice you are running a version that was just released in July, I have a feeling they accidently introduced this problem with the new code , I would actually downgrade the switch to 11.2.8.6.SA6 , I know it doesn't happen with this version . I have never seen this problem with versions under 12.X . Give it a try.

andrew.butterworth Wed, 09/17/2003 - 04:25
User Badges:
  • Gold, 750 points or more

It looks like the 2928XL is connected to a Cat 4506 switch that has Layer-3 interfaces as opposed to Layer-2 (switchport mode access), hence the Native VLAN-0 and your 2924XL VLAN-8. This is because CDP reports the VLAN ID of the interface in the updates, these are inconsistent between the 2 catalysts. What is the configuration of the Catalyst 4506?


Andy

ffati Wed, 09/17/2003 - 06:42
User Badges:

hi

even if i create a new vlan interfaces in 2924, i can't access to it, because the link between the catalyst and federator is not a trunk.

i have tried to configure the catalyst to be a 2924 vtp client and the same domain to all other equipements. but it doesn't recognize vlan already created in the vtp server.

***************************

configuration of the port in 4506 that is connected to 2924 :

!

interface FastEthernet4/2

description vers 1 etage

switchport access vlan 8

no logging event link-status

duplex full

!


thanks


andrew.butterworth Wed, 09/17/2003 - 09:01
User Badges:
  • Gold, 750 points or more

Get the thing upgraded to a later IOS image to start with, even if you don't have a CCO account you can download IOS for the 2924XL. MAKE SURE YOU HAVE ONE OF THE NEWER VERSIONS WITH 8MB IF YOU WISH TO DOWNLOAD 12.0(x).


Andy

ffati Thu, 09/18/2003 - 08:40
User Badges:

HI,

actual version in catalyst2924 is 11.2(8.11)SA6


Actions

This Discussion