Connecting multiple Cisco Catalyst 2950 switches

Unanswered Question
Sep 23rd, 2003

I know this should be a no brainer but for some reason I can't get my new cisco 2950 switches to talk to eachother or any of my company's old netgear hubs. anybody have any ideas? I have run through the initial config and added a default gateway. I can't seem to get the ports to come up.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
konigl Tue, 09/23/2003 - 14:53

Do you even get a link LED when you connect hub to switch? Switch to switch? If not, and you're using copper cable, make sure you're using Ethernet cross-over cables instead of regular straight-through patch cables on the hub-to-switch and switch-to-switch connections. Pins 1 and 2 at one end go to 3 and 6 at the other, respectively; and 3 and 6 at one end go to 1 and 2 at the other, respectively. This is good for Ethernet (10-meg) and Fast Ethernet (100-meg) connections. Gigabit Ethernet (1000-meg) over copper uses two more pairs that also need to be crossed in this case: 5 and 4 go to 7 and 8, and 7 and 8 go to 5 and 4, as above.

Workstation, printer, or server-to-switch connections use straight-through patch cables. Ethernet and Fast Ethernet use two of the four pairs; Gigabit uses all four pairs.

If you're not sure if a patch cable is a cross-over or not, here's a quick-and-dirty test: find two ports on the same hub or switch. Plug one end of the cable into one port. Then, plug the other cable end into the other: if you immediately get a link LED on both ports, disconnect the cross-over cable; if no LEDs, you've probably got yourself a straight-through. DO NOT LEAVE THIS CABLE CONNECTED ANY LONGER THAN NECESSARY TO CHECK FOR LINK. Else you can create a broadcast storm with this Ethernet loop, unless Spanning Tree blocks one of the ports.

What kind of Netgear hubs are they? They may have cross-over ports that allow you to use a straight-through patch cable to connect to another hub or switch. The port takes care of the cross-over. On some devices, it may be labeled MDI/MDI-X.

It may be that you also have to manually set port speed (10 or 100) and duplex (half vs. full) on the switch ports connected to the hubs.

It could also be that Spanning Tree is active on the switches, and is not letting traffic pass on a port for 30 to 50 seconds after link is detected. If you are sure that you will not have redundant connections from the hubs to the switches, you can enable Spanning-Tree PortFast on the ports connected to the hubs, so they will go right to forwarding data traffic when they get a link.

Are all the 2950 switchports assigned to the same VLAN? If the switches are new out of the box, then all the ports should be VLAN access ports on VLAN 1.

If it's not any of the above, then we'll need more detailed information to figure out this problem.

Hope this helps.

tsettle Tue, 09/23/2003 - 15:01

connecting to a hub you will need to ensure you are using a crossover cable, configure the switchport as follows:

switchport mode access !default is vlan 1

no shut

int vlan 1

ip add

in the above speed and duplex are auto. if this doesn't work then you may want to hard code these setting based on the hub port. use the following commands:

speed

duplex

with this you should be able to ping.

If still troubles then you may want to share with us relevant version info, running config, and port status information - like do you have link light.

sh ver, sh run, sh int switchport

mrfault Wed, 09/24/2003 - 05:53

Thanks guys for all your help the cross-over cable did the trick. I wish the documentation would have been a little friendlier to the novice user's.

nathan.dixon Sun, 10/26/2003 - 10:28

I've had problem connecting 2950's with hubs. These switches will try to setup a 802.1q trunk link between each other by default (allows virtual lans VLAN's to be carried over a single physical interface).

If there are devices connected to the hub these may cause errors as they clash with the trunk data on the switch ports. To see if this is happening do a "show interface fa 0/x" where x is the switch port connected to the hub. You may see collisions and other errors. "clear counters" will reset these numbers back to 0 so its easier to see whats going on.

To stop the switch ports trying to trunk up use the following command from hyper terminal.

switch>enable

switch# interface fastethernet 0/x (where x is the port connected to hub)

switch# switchport mode access

switch# copy run start (saves the config to NVRAM so it comes back like this next time the power goes off!!)

That should sort it.

Actions

Login or Register to take actions

This Discussion

Posted September 23, 2003 at 1:05 PM
Stats:
Replies:4 Avg. Rating:5
Views:1517 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,736
3 1,675
4 1,624
5 1,529