MGCP Gateway with T1 PRI (Translating incoming calls to VM port)

Unanswered Question

I have an MGCP Gateway with a T1 PRI and I would like to have all incoming calls from the T1 route to the VM pilot number. I tried setting up translation patterns that match the called incoming DID number and then translate it to the VM pilot number, but when you call one of the DID numbers you get a busy signal.


Any ideas or does anyone know of other way of sending all incoming calls to the VM pilot number?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
c-charlebois Tue, 10/07/2003 - 05:50
User Badges:

Without having access to the entire system, all I can suggest is things to check, and you may have already covered these:


First, does the MGCP gateway have the correct CSS to access the translation pattern?


Then, is VM answering any call?


Try giving an IP phone the same CSS and dialing the translatin pattern to see if you can access VM.


Try translating the DNIS to the extension of an IP phone.


Hopefully, this will give you some idea exactly where the problem lies.

electro22 Tue, 10/07/2003 - 07:51
User Badges:

Hi -


Be sure the CSS of the T1 port includes the PRT of the VM port. It is not enough for the CSS of the T1 port to have access to the PRT of the translation pattern, it must also have the PRT of the VM port.


-Jaret

CSS and partitions are set up correctly. I was able to forward a softphone to VM and then translate one of the incoming lines to the softphone and it worked that way. Looks like I'm having a problem with a codec, the original call to the softphone is G729r8 and then once it's transferred it's G711. I've been checking the unity server and G729 codec is enabled.

electro22 Wed, 10/08/2003 - 09:21
User Badges:

Jeremy -


I'm running out of ideas here... If it is a codec issue, a transcoder will fix it for you. I'm not sure how Unity works but it may only want g711 (even though you said its configured to accept g729). If you dont have a transcoder, you can use a T1 port that is not in use as a transcoder. Let me know if you need details on that.

Other than that, i'm at a loss...


-Jaret

I was going to try to set up a transcoder to see if that would fix the problem but the customer doesn't have any extra equipment at this time. But the problem has changed overnight. Now the VM system picks up the call, you then hear one word of the opening greeting, then to a fast busy. I was watching the calls come in on the gateway and now it shows them connecting to the VM system with G711.

johutchins Mon, 10/20/2003 - 13:09
User Badges:

What was the final resolution to this problem ??? I am having the same problem... if a call comes in on my MGCP gateway and it is forwarded directly to VM, I get a busy. But if the calls forwards to IPCC, everything is ok.


Fortuneatly, CFNA works ok on users phones.


--Jon

Here's the fix to the problem I was having with incoming calls from a T1 PRI MGCP gateway forwarded to VM.

Bug: CSCdz17571 and CSCdy26520


Although the bugs talk about DMS100 my configuration have the switch type set to Primary-ni. I went ahead and changed the Service Parameter, DisableAlerting Progress Indicator to True, and now my incoming calls go to VM.

Actions

This Discussion