×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

DSL is down but router doesn't agree...

Unanswered Question
Oct 15th, 2003
User Badges:

Hi, i've some troubles with my 827, when line goes down, it does not change his state: atm is up protocol is up, so the dialer and virtual access. This continues until i manually sh the atm0 and re-up it. Any way to make this automatic?


Here is my config (always under costruction..):


version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname 827

!

enable secret xxxxxxxx

!

!

!

!

!

no ip subnet-zero

no ip source-route

no ip domain-lookup

ip dhcp excluded-address 10.0.0.1 10.0.0.3

!

ip dhcp pool lan

network 10.0.0.0 255.0.0.0

default-router 10.0.0.1

dns-server x.x.x.100 195.210.92.100

!

!

!

!

interface Ethernet0

ip address 10.0.0.1 255.0.0.0

no ip directed-broadcast

ip nat inside

no ip route-cache

no ip mroute-cache

no cdp enable

hold-queue 4096 in

hold-queue 4096 out

!

interface ATM0

no ip address

no ip directed-broadcast

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

bundle-enable

hold-queue 224 in

!

interface Dialer1

bandwidth 300

ip address negotiated

no ip directed-broadcast

ip nat outside

encapsulation ppp

no ip route-cache

no ip mroute-cache

no keepalive

dialer pool 1

dialer idle-timeout 30

dialer wait-for-carrier-time 60

dialer-group 1

fair-queue 64 64 0

no cdp enable

ppp pap sent-username +++ password 7 +++

hold-queue 64 out

!

ip nat translation tcp-timeout 3600

ip nat translation udp-timeout 150

ip nat inside source list 100 interface Dialer1 overload

ip nat inside source static tcp 10.0.0.3 5900 interface Dialer1 5900

ip nat inside source static tcp 10.0.0.3 4662 interface Dialer1 4662

ip nat inside source static udp 10.0.0.3 4662 interface Dialer1 4662

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

access-list 100 permit ip 10.0.0.0 0.255.255.255 any

access-list 101 permit tcp 10.0.0.0 0.255.255.255 any eq ftp

access-list 101 permit tcp 10.0.0.0 0.255.255.255 any eq pop3

access-list 101 permit tcp 10.0.0.0 0.255.255.255 any eq smtp

access-list 101 permit tcp 10.0.0.0 0.255.255.255 any eq www

access-list 101 permit tcp 10.0.0.0 0.255.255.255 host x.x.92.100 eq domain

access-list 101 permit tcp 10.0.0.0 0.255.255.255 host x.x.91.0 eq domain

access-list 101 deny icmp any any

dialer-list 1 protocol ip list 101

no cdp run

!

line con 0

transport input none

stopbits 1

speed 115200

line vty 0 4

password +++

login

!

scheduler max-task-time 5000

end



I've also not solved my problem with DDR -> http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.eea1ca2 if someone is interested :)


Tks in advance for every replies.


Bye.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Georg Pauwen Wed, 10/15/2003 - 04:14
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 WAN

Hello,


you might want to configure keepalives on your atm and your dialer interfaces.


Regards,


GP

travis-dennis_2 Wed, 10/15/2003 - 05:00
User Badges:
  • Gold, 750 points or more

I had a similar problem before that was only correctable by an IOS upgrade to a newer image.

Actions

This Discussion