×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Convert 7960 from SIP to SCCP (Skinny)

Unanswered Question
Nov 6th, 2003
User Badges:

I am attempting to convert a 7960 from SIP to Skinny and have followed the doc here on Cisco to the letter. After making the 1st attempt to just convert it and failing, I am trying to upgrade the SIP firmware in the phone before trying again. The phone finds the TFTP server just fine and tries to upgrade to the new firmware but fails. I am getting "W230 Buffer Full" and "W231 Upgrade file Bad Header" errors. I have tried multiple 3.x and 4.x images and downloaded them several times from the Software Center and I still get the same results. I find it hard to believe the headers are bad every time. I can find no reference to the "W230" error message but I assume it's referring to running out of space while downloading the firmware to the phone. Does anyone have any suggestions? Additionally, the phone says it's got the P0S3Z444 firmware currently on it. Anyone heard of that?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (2 ratings)
Loading.
pacameron Sat, 11/08/2003 - 04:01
User Badges:
  • Silver, 250 points or more

Ensure the SIPdefault.cnf file has the filename of the NEW image in it, without the .bin extension.


Also, edit out all the comments and anything irrelevant from the SIPdefault.cnf file - it seems to have suffered some bloat in later revisions and it does not fit in the buffer after it is pulled from the tftp server.


ric.james Sat, 11/08/2003 - 12:53
User Badges:

The document Cisco provides recommends that you remove everything from the SIPDefault.cnf except the line "image_version:" where the filename is the image you want. (Without the .bin extension.) I've followed that advice. When the phone reloads, it *is* seeing what image file I want to load so I know it's reading the SIPDefault.cnf file OK. I get the errors mentioned when it tries to load that firmware image.

pacameron Sun, 11/09/2003 - 19:53
User Badges:
  • Silver, 250 points or more

The SIP image on the handset may be one of the newer signed binary images which means you can only change over to another signed binary image - they are not downwards compatible with the non signed images. This means you can only upgrade, not downgrade :-(


A signed phone load will only download other signed phone loads. If a phone load is not signed or the file has been tampered with (rendering the signature invalid) the phone will not accept the load. What this really means to you is that upgrade to a signed load, you can NEVER downgrade back to an unsigned load.


The 5.0(1) images within their install programs (executables) and the associated readme's can be obtained at the following web site:


http://www.cisco.com/cgi-bin/tablebuild.pl/ip-7900ser


ric.james Mon, 11/10/2003 - 07:53
User Badges:

After attempting a few of the suggestions given here and elsewhere, I managed to get the phone converted but there are a few issues not mentioned anywhere that I thought others might be happy to know of.


This particular phone wasn't accepting any image upgrades at all (see original note). I kept trying to step backwards in the 3.x and 4.x chains with no luck and attempts to go higher were also unsuccessful. I tried going back to 2.3 and finally managed to make it load. Attempts to upgrade from there remained unsuccessful with the W231 Bad Header error messages coming up.


Part of Cisco's documentation says that older versions of the SIP image had trouble handling files that weren't named with the older DOS 8-character(dot)3-character naming convention. It suggested you rename longer names to match. I was doing this during the upgrade process. Since the version 2.3 image already follows this convention, there's no need to change it. Since it worked and others didn't, I became suspicious that renaming the 3.x chain files was causing the issue. I was correct. Changing the SIPDefault.cnf image_version back to Cisco's original naming and putting the filename back allowed the upgrade to version 3.2. From there, I attempted to simply switch back to the current Skinny image and it worked just fine.


Moral to this story: the header on these files apparently references the expected filename and if it isn't the same, an error occurs.

Actions

This Discussion