Can't change agent state

Unanswered Question
Nov 12th, 2003
User Badges:

When I login to Agent Desktop the state is not ready and if I try to change it: "Change state request error"


In the agent log: " Agent state change request failed: SYS_INSTRUMENT_OUT_OF_SERVICE"


Any idea about this issue?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bpasqual Wed, 11/12/2003 - 09:01
User Badges:
  • Cisco Employee,

Try unassociatong/re-associating the device on the Call Manager.

6rlopez_2 Wed, 11/12/2003 - 09:56
User Badges:

As I have extension mobility I have unassociated the device profile to the RM-User withouth result. Any other idea?

6rlopez_2 Thu, 11/13/2003 - 02:08
User Badges:

I have tried with a DN associated to a phone instead of using Extension Mobility and it has worked. To use extension mobility I have marked the ICD ext. in the user profile associated to a a user.

Anyone with ICD and Extension Mobility has the same problem?

Thanks

j.gavin Tue, 05/18/2004 - 04:32
User Badges:

I am having the same problem. It seems to occur every night because The system works fine all day long, then in the morning, the agentslog in and cannot change the state to ready. I get the exact message as you: "SYS_INSTRUMENT_OUT_OF_SERVICE" in the agent log. I have a TAC case open, but until they give me a resolution, I have to stop and start the CRA engine every morning. If you find out what is causing this problem please post the solution. Thanks.


venkasub Tue, 05/18/2004 - 04:45
User Badges:
  • Bronze, 100 points or more

Hi,

Not sure about the CRS version you are running. It could be CSCec16219—Agent not able to log in after moving stations which is fixed in IPCC Express 3.0(3a)SPD & 3.1(2)SR1. Also make sure that the ICD extension for this agent only appears on one device. Try un-associating the DN from the RM JTAPI userID, updating it, then re-associate it to the RM JTAPI userID again.


Regards

Venkat

yogeswar Wed, 05/19/2004 - 00:02
User Badges:
  • Silver, 250 points or more

Hi,


If the agent cannot go from Not Ready to Ready it is because MIVR thinks the phone is busy. This could mean agent is offhook on the ICD line when trying to go available or they may have ICD extensions appearing on more than one device. If they are using Extension Mobility then only the EM profile should have the ICD extension appearance.


Regards

Yogi

j.gavin Wed, 05/19/2004 - 03:49
User Badges:

Thank you for the good replies. It turns out there were two issues. One was that we recently changed our agents from staic telephone profiles to extension mobility and when the change was made, the current profile of the device had the acd number as well as their mobile profiles. So I went in and removed the acd extension from the telephone and left it in their mobility profile. That cleared up a lot of the problems.


The second issue is likely a documented bug:

CSCec06211. This bug causes the agent to not be able to log in to the agent desktop after changing devices or having their phone re-register too often. TAC will provide me with a Call Manager patch for this but the work-around is to un-associate and re-associate the device with the rmjtapi user.


Thanks again!



Actions

This Discussion