Echo on analog lines

Unanswered Question
Nov 14th, 2003
User Badges:

Hi,


I am getting echo for the first 3-4 seconds of all calls going out my analog lines(ground start). I am running CM 3.3.2 ES 45 and a 3725 with an NM-HDA. Is there anything I can do to solve this?


Thanks

Frank

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
trailman73 Fri, 11/14/2003 - 08:41
User Badges:
  • Bronze, 100 points or more

do you have "echo-cancel coverage" running on the port? if not set it to 24 that should take care of your problem.


Geoff

fmarotta Fri, 11/14/2003 - 08:47
User Badges:

I have tried every echo coverage option available. None of them help. The echo canceler does work but until it kicks in (after 3-4 seconds) i hear bad echo.

jasyoung Fri, 11/14/2003 - 09:16
User Badges:
  • Gold, 750 points or more

Under newer code with EchoBeach, you have the option of using "echo suppressor". This turns the conversation into half-duplex for (by default) the first 7 seconds of the call while the ECANs are converging, thus eliminating the startup time echo.


http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a0080110d29.html#1344082

fmarotta Fri, 11/14/2003 - 10:58
User Badges:

The echo suppressor can only be used on DSPs when the default Cisco G.165 EC is used. The echo suppressor cannot be used with the extended EC.

jasyoung Fri, 11/14/2003 - 20:42
User Badges:
  • Gold, 750 points or more

So far as I know, and my routers running in G.168 mode seem to confirm, suppressor is available in both G.165 and G.168 modes. The gimmick is that suppressor is supposed to be unnecessary in G.168 mode, because G.168 is supposed to converge very fast - and in my experience, it does seem to converge in under one second.


If you're getting 3 or 4 seconds of echo, I would think you are using the G.165 canceller. That URL I posted alleges that G.168 is unavailable on the NM-HDA when on the 2600 platform, which I don't understand, but so be it. I poked at a 2600 + NM-HDA running 12.3(2)T1 this evening to see what the real deal is. I can configure ecan-extended, but I don't get a 64ms coverage option or an ERL adjustment option, so I suspect we're still in G.165 mode regardless.


If you're still in G.165 mode, that would explain your 3 or 4 seconds of convergence time. So, in my opinion, suppressor is still the tool for the job. Is your router not accepting the command?

Actions

This Discussion