×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Can't upload firmware to Catalyst 2822

Unanswered Question
Dec 7th, 2003
User Badges:

Hi all,


I have a Catalyst 2820 (WS-C2822) for my studies, without a valid firmware. I've downloaded v9.00.34 from Cisco, however no terminal software I use would upload it to the switch (or the switch would not accept it).


I tried all possible baud rates (9600 & 57600), and various sw (Hyperterm, TeraTerm), different PCs, different Com ports... All I get is either a timeout or Xmodem errors.


The Switch's Boot firmware version is 2.04


Any help would be really appreciated...


Thanks

Danny

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Georg Pauwen Sun, 12/07/2003 - 14:38
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 WAN

Hello Danny,


can you indicate where exactly you are getting the timeout ? Are you following the ´official´ procedure to recover from corrupted firmware, which is described at at this link ?


http://www.cisco.com/en/US/products/hw/switches/ps597/products_installation_and_configuration_guide_chapter09186a008007ef75.html#xtocid92417


Regards,


Georg

TIMENT Sun, 12/07/2003 - 15:56
User Badges:

Hi Georg,


Thanks for your reply.


Yes I am following the official procedure... I select U, then Y for yes. The switch erases the current invalid firmware (which there is none to begin with) and prompts me with the Baud selection...


To make things simple, I select 9600 baud and select send file from my terminal software (Hyperterm or Teraterm). I select Xmodem send (tried 1K, CRC, Checksum)


After ther first 128 bytes, Hyperterm gives me a message saying that "transfer cancelled by remote system". Teraterm is pretty much the same... Just waits at the first 128bytes for minutes...


Just to inform. This particular 2800 is an older model that comes with a Male DB9 console connector as opposed to the RJ-45. The cable I am using is not a Cisco cable (I think it's a netopia cable), however seeing that I am able to access the Catalyst's menus and navigate without a problem, I am assuming that I am utilizing a correct cable. Unless of course file upload utilizes different pins then sending keystrokes...


I appreciate any and all help.


Thans a lot!

Danny

TIMENT Mon, 12/08/2003 - 05:16
User Badges:

Yup tried that also. Any menu option possible there is (where there is no valid firmware), has been tried. Reset to factory defaults, reset console parameters... etc...


I am really at a dead-stop... I hope I'm not going to have to trash a perfectly good catalyst away...



Actions

This Discussion