static route and eigrp two questions

Answered Question
Dec 11th, 2003
User Badges:

first:

I use static float route to use backup interface,and destination are two net: 21.0.0.0,22.0.0.0 but when master interface serial down ,only the net 21.0.0.0 next hop chage to backup interface and net 22.0.0.0 still use default next hop (the master interface,even it is down),why? it is so strange!

config is below:



interface Serial5/0

ip address 22.52.127.6 255.255.255.252

ip access-group 144 in

ip access-group 144 out

encapsulation ppp

!

ip route 21.52.64.0 255.255.224.0 22.52.124.25 80

ip route 21.52.64.0 255.255.255.0 21.52.127.5

ip route 22.52.64.0 255.255.224.0 22.52.124.25 80

ip route 22.52.64.0 255.255.255.0 21.52.127.5


#show ip interface brief

Serial5/0 22.52.127.6 YES NVRAM down down


#show ip route

S 21.52.64.0/19 [80/0] via 22.52.124.25

S 22.52.64.0/19 [1/0] via 21.52.124.5


#show version

IOS (tm) 7200 Software (C7200-JS-M), Version 12.1(20)E, EARLY DEPLOYMENT RELEASE

SOFTWARE (fc1)


The strange happened in all my wan interface! and I have another 7206 with different IOS at work online too,and even have the trouble!!!


second:same router and same config, i use eigrp too, but when i use no auto-summary config why still a summary address in route table???


#show running-config


router eigrp 1

network 21.0.0.0

network 22.0.0.0

network 23.0.0.0

no auto-summary

eigrp log-neighbor-changes

no eigrp log-neighbor-warnings


#show ip route

D 21.52.0.0/17 is a summary, 21:55:13, Null0


any suggest is thankful!!


DAVID


Correct Answer by ruwhite about 13 years 8 months ago

What you have is:


#1 ip route 22.52.64.0 255.255.255.0 21.52.127.5


-- This one installs because the next hop is reachable through 22.52.124.25, which is outside the range of the destination addresses themselves.


#2 ip route 22.52.64.0 255.255.224.0 22.52.124.25 80


-- This one doesn't install because the lower admin distance route, #1, is installed, instead.


#3 ip route 21.52.64.0 255.255.255.0 21.52.127.5


-- This one doesn't install, because the next hop is only reachable via:


D 21.52.0.0/17 is a summary, 21:55:13, Null0


Which is a summary containing the space of the route itself--and the summary is built on the static route. In other words, it's a recursion loop. x/24 is used to build x/17, and the only way to reach the next hop for x/24 is through the summary to x/17, which is built from x/24 itself. We won't install this route.


#4 ip route 21.52.64.0 255.255.224.0 22.52.124.25 80


This one installs because, again, the next hop is reachable through some address outside the range of the destination address itself--the other static that's still installed.


:-)


Russ.W

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ruwhite Thu, 12/11/2003 - 19:17
User Badges:
  • Gold, 750 points or more

Can do a show ip route 21.52.124.5 when the first interface is down? You don't happen to have a command ip summary-address eigrp configured anyplace on the router, do you?


Russ.W

yongqiang.jin Thu, 12/11/2003 - 19:48
User Badges:

THANKS

as message before,i have do "no auto-summary" in my eigrp ,but i have some summary address in some interface ,is it the reason?


#show running inter se4/0

interface Serial4/0

bandwidth 2048

ip address 21.48.254.117 255.255.255.252 encapsulation ppp

ip summary-address eigrp 1 22.52.0.0 255.255.128.0 5

ip summary-address eigrp 1 21.52.0.0 255.255.128.0 5


DAVID

ruwhite Fri, 12/12/2003 - 04:07
User Badges:
  • Gold, 750 points or more

Yes, this is a manual summary, and isn't impacted by the auto-summary command.


:-)


Russ.W

yongqiang.jin Sun, 12/14/2003 - 18:14
User Badges:

well ,thanks!

but why this summary route is only effect on 22.0.0.0/8 address and not on 21.0.0.0/8 address as i

refer before!



DAVID


Harold Ritter Sun, 12/14/2003 - 18:45
User Badges:
  • Cisco Employee,

This question would be better answer by a "sh ip route" while the serial interface is down. In any case did you try pointing the static route to the serial interface instead of the next-hop ip address as follow:


ip route serial2


This should take care of it.



Harold Ritter Sun, 12/14/2003 - 19:07
User Badges:
  • Cisco Employee,

Sorry, I see you already had the "sh ip route"in there.


What I would still suggest is.


1) Change your static as follow:

ip route 21.52.64.0 255.255.255.0 Serial5/0

ip route 22.52.64.0 255.255.255.0 Serial5/0


This will ensure that as the interface goes down the static routes will be removed from the routing table.


Harold Ritter Sun, 12/14/2003 - 19:42
User Badges:
  • Cisco Employee,

By the way, you should probably configure the physical interface with the floating static as well.



ruwhite Sun, 12/14/2003 - 18:50
User Badges:
  • Gold, 750 points or more

Because 21.52.64.0 falls within the summary range--we won't recurse onto the summary for the next hop towards the summary itself. When the main route fails, we will fall back on the summary as the path to the next hop for the 22 network, since it doesn't fall within the summary, but when we attempt to fall back on the summary for 21.52.64.0, we find this address space is a part of the summary, so that fails. Then, the second static is installed, and we fall back on that.


:-)


Russ.W

yongqiang.jin Mon, 12/15/2003 - 17:38
User Badges:

Thank,

but I do not really understand Russ.W's answer-"we won't recurse onto the summary for the next hop towards the summary itself"

have some document about it?


DAVID

Correct Answer
ruwhite Tue, 12/16/2003 - 05:15
User Badges:
  • Gold, 750 points or more

What you have is:


#1 ip route 22.52.64.0 255.255.255.0 21.52.127.5


-- This one installs because the next hop is reachable through 22.52.124.25, which is outside the range of the destination addresses themselves.


#2 ip route 22.52.64.0 255.255.224.0 22.52.124.25 80


-- This one doesn't install because the lower admin distance route, #1, is installed, instead.


#3 ip route 21.52.64.0 255.255.255.0 21.52.127.5


-- This one doesn't install, because the next hop is only reachable via:


D 21.52.0.0/17 is a summary, 21:55:13, Null0


Which is a summary containing the space of the route itself--and the summary is built on the static route. In other words, it's a recursion loop. x/24 is used to build x/17, and the only way to reach the next hop for x/24 is through the summary to x/17, which is built from x/24 itself. We won't install this route.


#4 ip route 21.52.64.0 255.255.224.0 22.52.124.25 80


This one installs because, again, the next hop is reachable through some address outside the range of the destination address itself--the other static that's still installed.


:-)


Russ.W

ipotts Wed, 12/17/2003 - 05:44
User Badges:

Hi,


I think that #2 is a floating static for #1. They are two independent/different routes, since they have different masks. Therefore with both links up #1 and #2 should be in the main routing table. With the serial down, then #1 should go down. To have a true floating static the network and mask should be identical.


#1 ip route 22.52.64.0 255.255.255.0 21.52.127.5

#2 ip route 22.52.64.0 255.255.224.0 22.52.124.25 80



Regards

Ian

Actions

This Discussion