×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 1760 with VIC-4FXS/DID Problem

Unanswered Question

I've installed cisco 1760 with ViC-4FXS/DID (router information as below) and I found DSP problem. Now I've to reload the router then I can use for awhile but It'll happend again.


Many thanks for any ideas.


----show log ----------

.Mar 2 13:10:07.301: %DSM-3-DSP_TIMEOUT: DSP timeout on channel 2/1 (35), event 0x59: DSP ID=0x1: DSP error stats, dsprm info(mips_released=0, grp=0, dsp=0, bsp_port=0, bsp_ts=0, vic_port=1, vic_ts=4)

.Mar 2 13:10:07.301: %IPM_C54X-3-HOST_XMIT_BLOCKED: Host is unable to transmit packets to DSP 0

.Mar 2 13:10:27.249: %IPM_C54X-1-DSP_TIMEOUT: dsp 0 NOT RESPONDING.

.Mar 2 13:10:28.525: ASSERTION FAILED: file "../src-m860-les/if_ipm_c54x_idma.c", line 660

.Mar 2 13:10:57.217: %IPM_C54X-1-DSP_TIMEOUT: dsp 0 NOT RESPONDING.

.Mar 2 13:10:59.289: %LINK-3-UPDOWN: Interface Foreign Exchange Station with Direct Inward Dialing (FXS-DID) 2/0, changed state to up

.Mar 2 13:10:59.289: %LINK-3-UPDOWN: Interface Foreign Exchange Station with Direct Inward Dialing (FXS-DID) 2/1, changed state to up

.Mar 2 13:10:59.293: %LINK-3-UPDOWN: Interface Foreign Exchange Station with Direct Inward Dialing (FXS-DID) 2/2, changed state to up

.Mar 2 13:11:00.045: %LINK-3-UPDOWN: Interface Foreign Exchange Station with Direct Inward Dialing (FXS-DID) 2/3, changed state to up


------------------ show voice dsp ------------------


DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ============

C549 000 00 g711ulaw Idle Idle 0 0 2/0 NA 0 1250/779

C549 000 01 g711ulaw Idle Idle 0 0 2/1 NA 0 2831/3233

C549 000 02 g711ulaw Idle Idle 0 0 2/2 NA 0 5937/6704

C549 000 03 g711ulaw Idle Idle 0 0 2/3 NA 0 8240/8732


Active Voice Call details



Current total analog signalling channels: 4

Current max allowed digital timeslot for voice: 0

Current number of DSP group: 1

Group 0:

Current allocated analog signalling channels: 4

Current free analog signalling channels: 0

Current allocated digital signalling channels: 0

Current free digital signalling channels: 0

Port(s) served: 2/0 2/1 2/2 2/3

Current Available MIPS: 100

SPMM DSPRM State Image D-sig D-sig A-sig A-sig Mips Voice/Xcode

Dsp Dsp allocate free allocate free Free Chan

0/0 0 DOWN FIXMC 0 0 4 0 100 0

------------------ show version ------------------


Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-SV3Y-M), Version 12.2(15)ZL, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Synched to version 12.3(0.1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Fri 13-Jun-03 09:55 by ealyon

Image text-base: 0x80008120, data-base: 0x811BA6D8


ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

ROM: C1700 Software (C1700-SV3Y-M), Version 12.2(15)ZL, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)


VR340 uptime is 32 minutes

System returned to ROM by reload

System restarted at 17:59:16 UTC Tue Dec 23 2003

System image file is "flash:c1700-sv3y-mz.122-15.ZL.bin"


cisco 1760 (MPC860P) processor (revision 0x500) with 83968K/14336K bytes of memory.

Processor board ID FOC074503QS (1387297808), with hardware revision 0000

MPC860P processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial(sync/async) network interface(s)

4 Voice FXS interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)


Configuration register is 0x2102



------------------ show running-config ------------------



Building configuration...


Current configuration : 3726 bytes

!

! Last configuration change at 18:25:04 UTC Tue Dec 23 2003

! NVRAM config last updated at 18:05:42 UTC Tue Dec 23 2003

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname xxx

!

logging queue-limit 100

enable password <removed>

!

voice-card 2

!

ip subnet-zero

!

!

no ip domain lookup

!

!

ip cef

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.3.254 255.255.255.0

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay

frame-relay traffic-shaping

frame-relay lmi-type ansi

!

interface Serial0/0.200 point-to-point

ip address 10.10.100.22 255.255.255.252

frame-relay interface-dlci 200 CISCO

class 128k

vofr data 4 call-control 5

!

interface Serial0/1

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.100.21

no ip http server

!

!

!

map-class frame-relay 128k

frame-relay cir 128000

frame-relay bc 1000

frame-relay be 0

frame-relay mincir 64000

frame-relay adaptive-shaping becn

frame-relay fair-queue

frame-relay voice bandwidth 40000

frame-relay fragment 160

snmp-server community <removed> RO

snmp-server enable traps tty

!

!

voice-port 2/0

cptone TH

timeouts ringing 30

!

voice-port 2/1

cptone TH

timeouts ringing 30

!

voice-port 2/2

cptone TH

timeouts ringing 30

!

voice-port 2/3

cptone TH

timeouts ringing 30

!

dial-peer cor custom

!

!

!

dial-peer voice 601 pots

destination-pattern 340

port 2/0

!

dial-peer voice 602 pots

destination-pattern 340

port 2/1

!

dial-peer voice 603 pots

destination-pattern 340

port 2/2

!

dial-peer voice 200 vofr

destination-pattern ...

session target Serial0/0 200

dtmf-relay

fax rate 9600

no vad

!

dial-peer voice 604 pots

destination-pattern 340

port 2/3

!

num-exp 205 50088205

num-exp 206 50088206


!

line con 0

password <removed>

login

line aux 0

password <removed>

line vty 0 4

password <removed>

login

!

no scheduler allocate

!

end


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
pacameron Sun, 12/28/2003 - 16:40
User Badges:
  • Silver, 250 points or more

DSP timeouts like this generally indicate a software bug. Since the unit works for a while then fails, I don't think tis is hardware related. There are a lot of DSP related bugs that give this kind of message, so what I suggest is to load a later release of code - I would suggest 12.3.5a IP voice plus feature set. This should have support for the VIC4FXS card.


Please give this a try and see how it goes.



Actions

This Discussion