×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Hub and spoke frame relay

Unanswered Question

Hi,


Between the following 2 configuration of a hub and spoke frame relay, what are the pro and cons???


Eg 1

interface serial 0

encapsulation frame-relay

interface serial 0.1 point-to-point

ip address 10.1.1.1 255.255.255.0

frame-relay interface dlci 100

interface serial 0.2 point-to-point

ip address 10.1.2.1 255.255.255.0

frame-relay interface dlci 200


Eg 2

interface serial 0

encapsulation frame-relay

interface serial 0.1 multipoint

ip address 10.1.1.1 255.255.255.0

frame-relay map 10.1.1.2 100 broadcast

interface serial 0.2 multipoint

ip address 10.1.2.1 255.255.255.0

frame-relay map 10.1.2.2 200 broadcast

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kkalaycioglu Mon, 12/29/2003 - 05:32
User Badges:
  • Bronze, 100 points or more

So that you're using an illegal address space, according to me 1 is better. Main disadvantage of using point-to-point subinterface is that it requires seperate subnets for each point-to-point connection, but I think this is not a concern for your case. Besides some routing protocols (OSPF and ISIS) requires additional configurations for point-to-multipoint FR subifs and frame relay interface configs without subifs. But with point-to-point subifs no need for extra configuration.

Regards.

ruwhite Mon, 12/29/2003 - 05:55
User Badges:
  • Gold, 750 points or more

From a routing perspective, the point-to-point subinterfaces are better on several counts. You've not said what your routing protocol is, but:


-- EIGRP: You'll have to 'modify' your bandwidth statement to make EIGRP run properly on the point-to-multipoint. Stubs also work better on point-to-points.


-- IS-IS: Doesn't support point-to-multipoint.


-- OSPF: There are a lot of options for point-to-multipoints with OSPF, each of which has tradeoffs. If you don't mind the extra configuration of point-to-point subinterfaces, they are going to be better, in the long run, than the point-to-multpoint.


:-)


Russ.W

msdonahue Mon, 12/29/2003 - 09:53
User Badges:

IS-IS is supported in point-to-multipoint frame-relay.


And secondly, with the configs that you have above point-to-point would be the easiest way to go. If you were to use point-to-multipoint you would want the following:


EG2

interface serial 0

encapsulation frame-relay

interface serial 0.1 multipoint

ip address 10.1.1.1 255.255.255.0

frame-relay map ip 10.1.1.2 100 broadcast

frame-relay map ip 10.1.1.3 200 broadcast

frame-relay map ip 10.1.1.x yyy broadcast


You would not want to setup a separate p-2-mp sub-interface for every connection.

msdonahue Mon, 12/29/2003 - 18:25
User Badges:

Yes, you save IP addresses and the configuration is shorter. If you were going to use multiple subinterfaces then you may as well just use P-2-P subinterfaces. Depending on the routing Protocol being used there may be some extra configs but they are far less than having to configure multiple subinterfaces. Also, if you can use inverse-arp for mapping dlci's for the subinterfaces then you do not even need to have the frame-relay map statements and your config is even shorter.

msdonahue Tue, 12/30/2003 - 07:55
User Badges:

R1

interface serial 0

encapsulation frame-relay

interface serial 0.1 multipoint

ip address 10.1.1.1 255.255.255.0

frame-relay interface-dlci 102

frame-relay interface-dlci 103


R2

interface serial 0

encapsulation frame-relay

interface serial 0.1 multipoint

ip address 10.1.1.2 255.255.255.0

frame-relay interface-dlci 201


R3

interface serial 0

encapsulation frame-relay

interface serial 0.1 multipoint

ip address 10.1.1.3 255.255.255.0

frame-relay interface-dlci 301



Just make sure that frame-rlay inverse-arp is not disable. It is enabled by default.


Also note that the spokes, R2 and R3 will not be able to ping one another because they will not be dynamically mapped with inverse-arp. You will still need to do static maps for Spoke to Spoke on the P-2-MP Hub and Spoke design. But this is still shorter than Many P-2-P subs.


The final configs would looks as follows:



R1

interface serial 0

encapsulation frame-relay

interface serial 0.100 multipoint

ip address 10.1.1.1 255.255.255.0

frame-relay interface-dlci 102

frame-relay interface-dlci 103


R2

interface serial 0

encapsulation frame-relay

interface serial 0.201 multipoint

ip address 10.1.1.2 255.255.255.0

frame-relay interface-dlci 201

Frame-relay map ip 10.1.1.3 201


R3

interface serial 0

encapsulation frame-relay

interface serial 0.301 multipoint

ip address 10.1.1.3 255.255.255.0

frame-relay interface-dlci 301

frame-relay map ip 10.1.1.2 301



This will now be treated as a Multipoint connection and a broadcast medium for your Routing Protocols.

dathaide Tue, 12/30/2003 - 18:14
User Badges:

hi

We have a 64k circuit from remote to corporate. What are the benefits of using point to point frame-relay as opposed to a straight point to point. Will be using voip in the configuration.


Please advice on pro's and cons with respect to Voip etc?

thanks

kkalaycioglu Tue, 12/30/2003 - 22:51
User Badges:
  • Bronze, 100 points or more

If you've got a 64K leased line between your corporate and remote it's always better to use it as a leased line instead of frame relay. This you'll get rid of extra protocol overhead, delays (esp. important for VoIP) and some problems about sensing when line goes down. If you're already paying for a leased line according to me you'd better use it as a leased line.

Regards.

ruwhite Wed, 12/31/2003 - 10:22
User Badges:
  • Gold, 750 points or more

Have do you make certain the hub router is always the DIS? And how do you deal with each remote not seeing the SNP's and such from the other remotes? As far as I know IS-IS won't support point-to-multipoint. This would work for OSPF and EIGRP, but I don't know of any way to make this work for IS-IS--each router in IS-IS attached to an apparent broadcast network believes it can communicate directly with each other router on the same broadcast network, which is not the case with point-to-multipoint.


Second, if you're going to point-to-multipoint, why would you use subinterfaces at all? The main interface is a point-to-multipoint, so why not just use the main interface?


Third, since you're using private address space, why not use point-to-point? I don't know of a single advantage of point-to-multipoint for routing, other than the address space conservation--and /31 masks pretty much make the address conservation issue a wash, especially in private address spaces.


:-)


Russ

msdonahue Wed, 12/31/2003 - 10:31
User Badges:

Russ,


I am running IS-IS in a Hub and Spoke, point-to-multipoint, FR setup right now and everything works wonderful.

Anonymous (not verified) Mon, 01/19/2004 - 09:34
User Badges:

I am having trouble getting this working. Are you running the interfaces as physical multipoint, or subinterfaces as multipoint? Would you mind attaching your configs?

msdonahue Mon, 01/19/2004 - 22:51
User Badges:

Here are my configs:


Hub:


interface Serial0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type ansi

!

interface Serial0.110 multipoint

ip address 189.18.110.2 255.255.255.248

ip router isis

frame-relay map clns 204 broadcast

frame-relay map clns 206 broadcast

frame-relay map ip 189.18.110.4 204 broadcast

frame-relay map ip 189.18.110.6 206 broadcast

no frame-relay inverse-arp

clns router isis

isis metric 31

isis password ciscoL2 level-2

isis hello-interval 30

!

router isis

net 8d.0000.0001.0002.00

summary-address 196.5.128.0 255.255.192.0

domain-password ciscodomain


Spoke 1:

interface Serial0/0

ip address 189.18.110.4 255.255.255.248

ip router isis

ip nbar protocol-discovery

encapsulation frame-relay

service-policy output CCIE

isis metric 31

isis password ciscoL2 level-2

isis priority 0

isis hello-interval 30

frame-relay map clns 402 broadcast

frame-relay map ip 189.18.110.6 402

frame-relay map ip 189.18.110.2 402 broadcast

no frame-relay inverse-arp

frame-relay lmi-type ansi

frame-relay ip rtp header-compression

!

router isis

net 00.0000.0001.0004.00

is-type level-2-only

domain-password ciscodomain


Spoke 2:

!

interface Serial0/0

no ip address

encapsulation frame-relay

no frame-relay inverse-arp

frame-relay lmi-type ansi

!

interface Serial0/0.110 multipoint

ip address 189.18.110.6 255.255.255.248

ip nat inside

ip router isis

isis metric 31

isis password ciscoL2 level-2

isis priority 0

isis hello-interval 30

frame-relay map clns 602 broadcast

frame-relay map ip 189.18.110.4 602

frame-relay map ip 189.18.110.2 602 broadcast

no frame-relay inverse-arp

!

!

router isis

summary-address 196.5.128.0 255.255.192.0

redistribute connected route-map IS-IS-R6

redistribute static ip

net 8d.0000.0001.0006.00

domain-password ciscodomain


gleithner Thu, 01/22/2004 - 16:24
User Badges:

I was curious about this as I'd recalled reading about this scenario in Doyles Routing TCP/IP. Multipoints are treated by ISIS as a LAN, p2p's as a p2p, so the only caveat is that if you go multipoint it has to be multipoint on each router, just as it is in msdonahue's configuration(Spoke 1 frame relay on the physical interface treated as multipoint)


If you used p2p at the spoke you'll have to use p2p at the hub. This is different then OSPF where i've used a variety of different types of int and sub-int's(with appropriate ip ospf network types and/or hello/dead parameter changes).



gleithner Thu, 01/22/2004 - 15:57
User Badges:

Firstly, Eg2 doesn't need two multipoint subinfs if it's going to be the hub. You can use one multipoint subif, and all your spokes can be on the same subnet(since multipoint doesn't require diff subnets). Also, you don't need the map statements, use interface dlci instead and InvARP will take care of the rest.


So eg2 could be


interface serial 0.1 multipoint

ip address 10.1.1.1 255.255.255.0

frame-relay interface-dlci 100

frame-relay interface-dlci 200


However, as already stated, multipoint interfaces have other configuring issues with your routing protocols.


Since you could just use VLSM to make small subnets, P2P is probably the way to go. Although with a large number of spokes you'll have to configure each p2p int on the hub.





Actions

This Discussion