×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Path selection in IS-IS

Unanswered Question
Dec 30th, 2003
User Badges:

Scenario;


Four routers in a broadcast (ethernet) single area. Two routers are level 2 routers as they reside in two areas. Routing is working as it should. Adjacencies have formed no problem. Both of these level two routers have FR connections to a hub router using p-to-p. This FR network is the other area.


What I would like to do is have the two level-1 routers use only one of the level-2 routers as the default router, using AD as the deciding factor. I have tried to change the AD on one of the level-2 routers using the following commands:


router(config-router)#distance 116 ip


I have also tried the combination:


router(config-router)#distance 116 sourceIP mask


After clearing the routing tables on all routers, neither of these change the routing tables of the level-1 routers.


I have successfully done what I want by changing the metric, but the suboptimal routing takes place from one level-2 router to the other. For example I changed the isis metric on one of the FR links, and the router then tries to use the other FR link to reach the hub.


This is a lab scenario so "best practices" such as simpley injecting a default route I would prefer to avoid.


Any help would be appreciated as the documentation for IS-IS is reather sparse to say the least.


Regards to all.


Joe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
msdonahue Wed, 12/31/2003 - 09:33
User Badges:

Joe,


If you would like to use AD as the deciding factor, you will need to do that on the 2 L1 routers for the 0.0.0.0/0 default route. AD is a local preference that does not get forwarded in the routing updates. So, if you really want to use AD I would use the following command on the 2 L1 routers:


distance 116 sourceIP mask



Otherwise, I would either change to metric of the routes being sent on the 2 L2 routes or use a filter list to stop one router from sending a default route.

mark-obrien Wed, 12/31/2003 - 09:40
User Badges:
  • Bronze, 100 points or more

Joe,


Admin distance is local only. A router does not send an AD to another router in any protocol. You changed the AD in the level 2 routers, and this will not affect how the level 1 routers will send the traffic. Try entering the distance command into the level 1 routers with the access-list option, where the access-list specifies the address of the advertising router, thus making one of the level 2 routers more believable than the other.


As for your adjusting the metric, I suspect that you increased the metric of one of the frame links to a value greater than the sum of the metrics of the ethernet link and the frame relay link of the other level 2 router. Try making the metric of the frame link of the undesirable router greater than the metric of the frame link of desirable router, but less than the sum mentioned above.


HTH, and Happy New Year,

Mark

ziutek Wed, 12/31/2003 - 16:56
User Badges:

Of course AD doesn't get passed in any routing protocol. I should have remembered that. I guess I was so concentrated on trying to influence the path selection from one of the L2 routers that I couldn't see the forest...


Well, after a littel bit more experimentation I've foudn the only real way of influencing the path selection id through the use of a metric. In this case I just agave one of the FR links a metric of 11, and this dropped the route from the routing tables on the L1 routers. I found that the "distance 116 sourceIP mask" (which by the way is a wild card mask, not a regular subnet mask), I could not selectively change the AD. For example the source IP for some of the multiple paths of of course the same, in this casse the hub of the FR network. So when I added this command, all the parallel path routes changed their AD. I could find no way of using an access-list with isis.


Thanks for the input. and a Happy New Year!


Joe

Actions

This Discussion