vlan IDs are different on links bet 2 layer 3 switches

Unanswered Question
Jan 7th, 2004
User Badges:

hello,


is there any problem if the vlan IDs connecting 2 switches with multiple VLAN differs..say vlan 20 on the core and vlan 30 on the other..both of them are layer 3 and running ospf...interface connection both vlans are not trunked.


thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Thu, 01/08/2004 - 00:17
User Badges:
  • Red, 2250 points or more

Hi,

it should be no problem on L3 interfaces.

I've noticed a problem with this connection while connecting L2 interfaces. Using CDP ver 2 caused error messages in my syslog (CDP v 2 sends "native VLAN" info even on access port which was different on each side).


Regards,

Milan

rpalacio Thu, 01/08/2004 - 02:08
User Badges:

then what could be the reason i couldnt reach the far end switch from any of my vlan on the core except from the directly connected vlan. Intervlan is working fine. the default route specified on the msfc and the on the switch points to the vlan interface of the far end switch.OSPF is both running on both the switches. Ill attached my core config below


Router#sh run

Building configuration...


Current configuration : 646 bytes

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

boot system bootflash:c6msfc2-psv-mz.121-13.E9.bin

boot bootldr bootflash:c6msfc2-boot-mz.121-13.E9.bin

!

clock timezone PDT -7

ip subnet-zero

!

!

!

!

!

!

interface Vlan59

ip address 10.51.20.250 255.255.255.0

!

interface Vlan61

ip address 10.24.50.211 255.255.240.0

!

router ospf 1

log-adjacency-changes

network 10.24.48.0 0.0.15.255 area 4

network 10.51.20.0 0.0.0.255 area 4

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.24.50.201

no ip http server

!

!

!

!

line con 0

exec-timeout 0 0

line vty 0 4

login

!

end


Router#



Cat6506> (enable) sh run

This command shows non-default configurations only.

Use 'show config all' to show both default and non-default configurations.

...............



............................

............................

.........................




..


begin

!

# ***** NON-DEFAULT CONFIGURATION *****

!

!

#time: Wed Jan 7 2004, 18:46:53

!

#version 7.3(1)

!


!

#system

set system name Cat6506

!

#!

#vtp

set vtp domain ht

set vtp mode transparent

set vlan 1 name default type ethernet mtu 1500 said 100001 state active

set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active

set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state activ

e stp ieee

set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active st

p ibm

set vlan 59,61

set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state acti

ve mode srb aremaxhop 0 stemaxhop 0 backupcrf off

!

#ip

set interface sc0 61 10.24.50.21/255.255.240.0 10.24.63.255


set ip route 0.0.0.0/0.0.0.0 10.24.50.201

!

#set boot command

set boot config-register 0x2

set boot system flash bootflash:cat6000-sup2k8.7-3-1.bin

!

# default port status is enable

!

!

#module 1 : 2-port 1000BaseX Supervisor

!

#module 2 : 2-port 1000BaseX Supervisor

!

#module 3 : 16-port 10/100/1000BaseT Ethernet

set vlan 61 3/1-16

!

#module 4 : 48-port 10/100BaseTX Ethernet

set vlan 61 4/1-48

!

#module 5 : 8-port 1000BaseX Ethernet

set vlan 59 5/1

set vlan 61 5/2-6

!

#module 6 empty

!

#module 15 : 1-port Multilayer Switch Feature Card

!

#module 16 : 1-port Multilayer Switch Feature Card

end

Cat6506> (enabl



Actions

This Discussion