×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Simple DNS config Question....

Unanswered Question
Jan 24th, 2004
User Badges:

Hi all. I have not had to mess with my 1605R router in some time and have forgotten how to change my existing two DNS numbers to two new DNS numbers that my ISP is switching us to.

I can telnet to my router and get logged on. I type in <enable> and then can do a <show run>...I know that I need to be in configure mode, but cannot remember the command line to get the old ones out and the new DNS numbers in the config.

It's a very simple set up. Cable mode to the router and then the 2nd interface from router goes to a switch where the feed is shared out to about 8 machines.

It's already set up....I just need to change my DNS numbers on the outside interface....


the dedicated IP, subnet and default gateway all remain as they are now.

Thanks All....

Bryan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
mark-obrien Sat, 01/24/2004 - 14:17
User Badges:
  • Bronze, 100 points or more

Here are the commands you need:


no ip name-server oldaddress1 oldaddress1

ip name-server newaddress1 newaddress2


Good luck.

Mark

atomicweight Sat, 01/24/2004 - 22:51
User Badges:

Ok, cool. I took the numbers out and put the new ones in..no problem. Last question..I think. I notice below there in the DHCP pool that I still see the dns-server old numbers still showing up. Do I need to change these as well?


Thanks so much for replying...

out here..

bryan



mark-obrien Sun, 01/25/2004 - 07:25
User Badges:
  • Bronze, 100 points or more

Yes you do. Those addresses in the DHCP pool are the DNS servers that your DHCP clients will use. If they have the wrong server(s), they will not resolve names on the internet, or your internal network for that matter.


Mark

atomicweight Sun, 01/25/2004 - 10:23
User Badges:

Hey,thanks for writing. I figured I would have to change them. This is probably the last thing I need. I have changed the ip name-server addresses. What command will let me take the existing DNS numbers in the DHCP pool out and what command will let me enter the two new one?


Thanks Again...

After I change these numbers, I'll put the router on the network and see if I can pass the traffic again..


Take Care

bryan


mark-obrien Sun, 01/25/2004 - 13:02
User Badges:
  • Bronze, 100 points or more

Bryan,


Enter these commands:


ip dhcp pool (existing pool name)

no dns-server (server address1) (server address2)...

dns-server (new address1) (new address2)...

^z


Don't forget to save your configuration with the command "copy runn start" so that if the router is rebooted you have these new commands in service.


Mark

atomicweight Tue, 01/27/2004 - 13:36
User Badges:

Hi Mark and thanks for all your help. I changed the DNS numbers in both areas mentioned above just fine. Did a copy run start and got that all done. I returned the router to the network at Branch B library. All machines can now access the Internet just fine. However, I can now not see Library A's 2 websites nor can I connect to the databae to checkout books.


If the ISP (charter cable) only changed the DNS numbers and I made only two changes to the config (that was working just fine before) concerning the DNS numbers and you have been helping me with, why can I now not see my own web server and database located at Branch A?


I have a cable modem at Branch B and a cable modem at Branch A.


I took the router off the network and let everything get info from charters network via my switch out to the cable modem. Everything worked fine. I can only have 3 machines behind the switch working at one time as per Charter's allocation for address's, so that is why I need the router there as we have 6 machines that need to have Internet access. So, I do need the router.


Here is a copy of my current config...if you dont' mind...would you or someone take a look at it and see why I can't pass traffice from the router to Branch A?


The router has this address on it 24.197.19.XXX. My two web servers have the same octets sequence as above with the ending octets being different of course. So, in other words, the router can pass and ping to all address except its own network??


Does anyone see anything in the current config that would cause the router with 24.197.19.xxx on the outside interface not to be able to pass traffic to my two web servers with 24.197.19.xxx numbers respectively?


When I ping from the router to the outside world, I get a return no problem...when I try to ping 24.197.19.xxx, I get time outs??


Here is the current config...





Current configuration : 1219 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname apollo

!

logging rate-limit console 10 except errors

enable secret xxxxx

!

username xxxx password xxxxx

ip subnet-zero

no ip source-route

no ip finger

ip name-server 209.225.8.42

ip name-server 24.240.141.226

!

ip dhcp pool DHCPPoolLAN_1

network 192.168.100.0 255.255.255.0


--More—


default-router 192.168.100.1

dns-server 209.225.x.x x.x.141.226

!

!

!

!

interface Ethernet0

ip address 24.x.x.x x.255.252.0

no ip proxy-arp

ip nat outside

ip rip send version 1 2

ip rip receive version 1 2

no ip route-cache

!

interface Ethernet1

ip address 192.168.100.1 255.255.255.0

no ip proxy-arp

ip nat inside

ip rip send version 1 2

ip rip receive version 1 2

no ip route-cache

!

router rip


--More—


ip rip receive version 1 2

no ip route-cache

!

router rip

network 24.0.0.0

network 192.168.100.0

!

ip nat inside source list 11 interface Ethernet0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 24.197.16.1

no ip http server

!

access-list 11 permit 192.168.100.0 0.0.0.255

!

line con 0

exec-timeout 0 0

transport input none

line vty 0 4

exec-timeout 0 0

login local

!

end


atomicweight Tue, 01/27/2004 - 13:40
User Badges:

Hey, I wanted to add this too.


The correct DNS numbers are these...

209.225.8.42

24.240.141.226


The gateway that should be being used is

24.197.16.1


Thanks again for all your help!!

Bryan



Actions

This Discussion