×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

IPCC Express: Enterprise data does not seem to be updated

Unanswered Question
Feb 3rd, 2004
User Badges:
  • Bronze, 100 points or more

Hi all,


I'm currently trying to test enterprise data but that doesn't work. I already configure a new variable in Desktop Administrator with data type number 2. Then, I modified the default layout in order to display this new variable.


After that, within my script, I used a "Set Enterprise Data" step correctly. (data type = 2, and data value = string variable containing 10 digits DN)


I looked at the trace and the step has been successfully executed. (excerpt form trace below)


796: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:Set Cisco CallID for this call :16777244

797: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:In SetEnterpriseData the ssCorba value is: com.spanlink.storageserver.corba._ssCorbaStub:IOR:000000000000001049444c3a7373436f7262613a312e3000000000010000000000000024010100000a00000031302e302e332e3132007ce60c00000040196f5a000008a600000002

798: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:Prepare data for setEnterpriseDataByCallID

799: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:the 1th try ... sending Enterprise Data by callID <16777244>

800: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:set call ID <16777244> dataType 2 to 4186911671

801: Feb 03 09:53:42.611 EST %MIVR-STEP_ENT_SRV-7-UNK:Set Enterprise Data finish successfully



But, when I looked at the agent desktop, the variable is there, but there is nothing in the value field.


Thanks in advance


Steven Ferland

Bell Canada

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
venkasub Tue, 02/03/2004 - 19:37
User Badges:
  • Bronze, 100 points or more

Hi,

Symptom :- When an Agent receives a call, the Enterprise Data window does not display the expected data.


Possible Cause :- The CRA server is not correctly passing enterprise data from the enterprise data server to the Cisco Agent Desktop. This situation can be a result of incorrect step configuration in the script or in the Enterprise Data Configuration section of the Cisco Desktop Administrator. This situation can also be a result of an out of sync condition between the Enterprise Data subsystem and

the Cisco Desktop Enterprise Server service.


Recommended Action :-

1. Verify the step configuration in the script and in the Enterprise Data

Configuration section in the Cisco Desktop Administrator.

2. Stop and restart the Cisco Desktop Enterprise Server service.


If problem still persists, please open a TAC case and send your script for review.


Regards

Venkat

Actions

This Discussion