Can't call certain numbers??

Unanswered Question
Feb 3rd, 2004
User Badges:

Currently we have a Mitel switch with a PRI connected to a Cisco 3600, which in turn has a PRI connected to the PSTN (Sprint) for our phone service in our office. We are using Mitel IP phones in the office. We also have customers that make calls over our Satellite network, which connects to the Cisco 3600 (not the Mitel) and out the same PRI to the PSTN as our office. Our customers are having no troubles at all (thank god!!!) but our office is having some issues. We are unable to make certain calls out, including local and long distance. We cannot call any 18XX numbers, and various local numbers as well. There is no pattern to the numbers we cannot call, ie. area code or local codes. Keep in mind that we can make some calls no problem, and there is no pattern to the ones we can make. Does anyone have any suggestions?


Dave


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Can you post a copy of the 3600 config (without passwords) so we can take a look? I would think since the customers are working that it wouldn't be the router, but can't say for certain. We could run some debugs on the router to see if it is even seeing the calls from the numbers you can't reach. Also, are the numbers consistent? For example, can you always reach xxx-yyy-zzzz, but not xxx-yyy-aaaa everytime?

vanagon2tdi Wed, 02/04/2004 - 12:20
User Badges:

The numbers are all consistant, as in if 555-6666 does not work once, it never works, and 666-5555 works all the time.

When i do a 'sh voic call' and i am making a call to a number that works, i see a PRI channel grabed for the in-bound to the router (from Mitel) and one for the out-bound to the PSTN. When i make a call to a bad number i only see a channel grabbed for the in-bound from the Mitel.

When i debug the router (i forget the command) i see the following:


------------Good call-------------

Jan 29 15:11:29: ISDN Se2/0:23 Q931: RX <- SETUP pd = 8 callref = 0x011F

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98385

Exclusive, Channel 5

Display i = 0xB1, 'User Name'

Calling Party Number i = 0x2180, '4035348188'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '2446782'

Plan:ISDN, Type:Subscriber(local)

Jan 29 15:11:29: ISDN Se2/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x811F

Channel ID i = 0xA98385

Exclusive, Channel 5

Jan 29 15:11:30: ISDN Se2/0:23 Q931: TX -> ALERTING pd = 8 callref = 0x811F

Progress Ind i = 0x8488 - In-band info or appropriate now available

Jan 29 15:11:33: ISDN Se2/0:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x011F

Cause i = 0x8090 - Normal call clearing

Jan 29 15:11:33: ISDN Se2/0:23 Q931: TX -> RELEASE pd = 8 callref = 0x811F

Jan 29 15:11:33: ISDN Se2/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x011F


-------------Failed Call--------------

Jan 29 15:13:18: ISDN Se2/0:23 Q931: RX <- SETUP pd = 8 callref = 0x0122

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98382

Exclusive, Channel 2

Display i = 0xB1, 'User Name'

Calling Party Number i = 0x2180, '4035348188'

Plan:ISDN, Type:National

Called Party Number i = 0xC1, '5694667'

Plan:ISDN, Type:Subscriber(local)

Jan 29 15:13:18: ISDN Se2/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0x8122

Channel ID i = 0xA98382

Exclusive, Channel 2

Jan 29 15:13:19: ISDN Se2/0:23 Q931: TX -> PROGRESS pd = 8 callref = 0x8122

Progress Ind i = 0x8A81 - Call not end-to-end ISDN, may have in-band info

Jan 29 15:13:19: ISDN Se2/0:23 Q931: RX <- STATUS pd = 8 callref = 0x0122

Cause i = 0x80E4 - Invalid information element contents

Call State i = 0x03

Jan 29 15:13:19: ISDN Se2/0:23 **ERROR**: Ux_Status: STATUS call state mismatch with invalid cause: cause 0x64, state 0x9, peer state 0x3

Jan 29 15:13:19: ISDN Se2/0:23 Q931: TX -> RELEASE pd = 8 callref = 0x8122

Cause i = 0x82EF - Protocol error; unspecified

Jan 29 15:13:19: ISDN Se2/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x0122


Here is a copy of the config:



version 12.3

service timestamps debug datetime localtime

service timestamps log datetime

service password-encryption

!

hostname prigw1

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxXXXXXxxxxXXXXX

!

username company password 7 xxxxXXXXXxxx

clock timezone MDT -7

clock summer-time MDT recurring

voice-card 1

!

voice-card 2

!

voice-card 5

!

aaa new-model

!

!

aaa authentication login telnet group radius local

aaa accounting connection voip stop-only group radius

aaa session-id common

ip subnet-zero

!

!

ip domain name skycomip.com

ip name-server 207.34.x.x

ip name-server 204.50.x.x

!

!

isdn switch-type primary-dms100

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

!

!

!

controller T1 1/0

framing esf

crc-threshold 320

linecode b8zs

pri-group timeslots 1-24

!

controller T1 2/0

framing esf

crc-threshold 320

linecode b8zs

pri-group timeslots 1-24

!

controller T1 5/0

framing esf

crc-threshold 320

linecode b8zs

pri-group timeslots 1-24 nfas_d none nfas_int 1 nfas_group 0

!

controller T1 5/1

framing esf

crc-threshold 320

linecode b8zs

pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 0

gw-accounting aaa

method voip

attribute acct-session-id overloaded

!

!

translation-rule 1

Rule 1 ^7232585 3988399

!

!

translation-rule 2

Rule 0 ^4035438180 180

Rule 1 ^4035438181 181

Rule 2 ^4035438182 182

Rule 3 ^4035438183 183

Rule 4 ^4035438184 184

Rule 5 ^4035438185 185

Rule 6 ^4035438186 186

Rule 7 ^4035438187 187

Rule 8 ^4035438188 188

Rule 9 ^4035438189 189

!

!

translation-rule 3

Rule 0 ^4035438190 190

Rule 1 ^4035438191 191

Rule 2 ^4035438192 192

Rule 3 ^4035438193 193

Rule 4 ^4035438194 194

Rule 5 ^4035438195 195

Rule 6 ^4035438196 196

Rule 7 ^4035438197 197

Rule 8 ^4035438198 198

Rule 9 ^4035438199 199

!

!

translation-rule 4

Rule 0 ^4032898133 133

!

!

!

!

interface FastEthernet0/0

ip address 10.254.254.3 255.255.255.0

no ip redirects

no ip unreachables

no ip mroute-cache

load-interval 30

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.254.249.2 255.255.255.0

duplex auto

speed 100

no keepalive

!

interface Serial1/0:23

description Connected to ISP (PSTN)

no ip address

no logging event link-status

isdn switch-type primary-dms100

isdn incoming-voice modem

no cdp enable

!

interface Serial2/0:23

description Connected to MITEL

no ip address

no logging event link-status

isdn switch-type primary-dms100

isdn protocol-emulate network

isdn incoming-voice modem

no cdp enable

!

interface Serial5/1:23

no ip address

no logging event link-status

isdn switch-type primary-dms100

isdn incoming-voice modem

no cdp enable

!

router eigrp 1

network 10.254.249.0 0.0.0.255

auto-summary

!

ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.254.249.1

ip route 1.1.1.1 255.255.255.255 Null0

!

!

!

!

!

radius-server host 10.254.x.x auth-port 1645 acct-port 1646

radius-server key 7 xxxXXXXxx

!

control-plane

!

!

!

voice-port 1/0:23

echo-cancel coverage 32

!

voice-port 2/0:23

!

voice-port 5/1:23

echo-cancel coverage 32

timeouts interdigit 3

!

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 999 pots

destination-pattern .T

direct-inward-dial

port 5/1:23

!

dial-peer voice 23 voip

huntstop

destination-pattern 20388..

session target ipv4:1.1.1.1

!

dial-peer voice 24 voip

huntstop

destination-pattern 20318..

session target ipv4:1.1.1.1

!

dial-peer voice 1800 pots

destination-pattern 9999

direct-inward-dial

port 5/1:23

prefix 18882235302

!

dial-peer voice 1888 pots

destination-pattern 9998

direct-inward-dial

port 5/1:23

prefix 18888243600

!

dial-peer voice 9000 pots

destination-pattern 9000T

direct-inward-dial

port 5/1:23

!

dial-peer voice 25 voip

huntstop

destination-pattern 72325..

session target ipv4:1.1.1.1

!

dial-peer voice 9997 pots

destination-pattern 9997

direct-inward-dial

port 5/1:23

prefix 3989742

!

dial-peer voice 2023 voip

huntstop

destination-pattern 40320388..

session target ipv4:1.1.1.1

!

dial-peer voice 2024 voip

huntstop

destination-pattern 40320318..

session target ipv4:1.1.1.1

!

dial-peer voice 2025 voip

huntstop

destination-pattern 40372325..

session target ipv4:1.1.1.1

!

!

dial-peer voice 552 voip

description Customer dial peer

huntstop

destination-pattern 4033980304

session target ipv4:10.132.0.2

dtmf-relay cisco-rtp

fax rate 7200

ip qos dscp cs5 media

no vad

!

dial-peer voice 400 pots

huntstop

destination-pattern 403543818.$

translate-outgoing called 2

no digit-strip

port 2/0:23

!

dial-peer voice 401 pots

huntstop

destination-pattern 403543819.$

translate-outgoing called 3

no digit-strip

port 2/0:23

!

dial-peer voice 402 pots

huntstop

destination-pattern 4032898133

translate-outgoing called 4

no digit-strip

port 2/0:23

!

!

line con 0

transport preferred all

transport output all

line aux 0

transport preferred all

transport output all

line vty 0 4

login authentication telnet

transport preferred all

transport input all

transport output all

line vty 5 15

transport preferred all

transport input all

transport output all

!

ntp clock-period 17180189

ntp peer 10.254.x.x

!

!

end

xu_l Wed, 02/04/2004 - 18:06
User Badges:

Try to add these two commands under interface Serial1/0:23:


isdn send-alerting

isdn sending-complete

vanagon2tdi Thu, 02/05/2004 - 06:39
User Badges:

Sorrry but my config is a bit confusing, the Serial interface connected to the PSTN (Sprint)is 5/1:23, so i tried the commands you sent on 5/1. It did not make any difference? Thanks agian for your help!


D

vanagon2tdi Thu, 02/05/2004 - 10:09
User Badges:

The ISP says that we should be running NI2, not dms-100 which is what they originally told us?? On the Cisco i can only choose NI2C, is that the same as NI2??

Thanks!

Dave

Actions

This Discussion